summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2008-01-05 22:46:50 +0000
committerWilliam Hubbs <williamh@gentoo.org>2008-01-05 22:46:50 +0000
commitfde35f8feac6db373bda00bfe11837a188fd06d6 (patch)
tree80391e422dc665e84ed927ab066addc817c5b89d /app-accessibility/brltty
parentTypo fix (diff)
downloadgentoo-2-fde35f8feac6db373bda00bfe11837a188fd06d6.tar.gz
gentoo-2-fde35f8feac6db373bda00bfe11837a188fd06d6.tar.bz2
gentoo-2-fde35f8feac6db373bda00bfe11837a188fd06d6.zip
Version bump. Also, I reworked the startup script so that brltty will start earlier in the boot process.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'app-accessibility/brltty')
-rw-r--r--app-accessibility/brltty/ChangeLog9
-rw-r--r--app-accessibility/brltty/brltty-3.9.ebuild74
-rw-r--r--app-accessibility/brltty/files/brltty.rc8
-rw-r--r--app-accessibility/brltty/files/digest-brltty-3.93
4 files changed, 90 insertions, 4 deletions
diff --git a/app-accessibility/brltty/ChangeLog b/app-accessibility/brltty/ChangeLog
index fbfde66f28ec..fcb64aa46ad0 100644
--- a/app-accessibility/brltty/ChangeLog
+++ b/app-accessibility/brltty/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-accessibility/brltty
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/ChangeLog,v 1.66 2008/01/01 04:58:10 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/ChangeLog,v 1.67 2008/01/05 22:46:49 williamh Exp $
+
+*brltty-3.9 (05 Jan 2008)
+
+ 05 Jan 2008; William Hubbs <williamh@gentoo.org> files/brltty.rc,
+ +brltty-3.9.ebuild:
+ Version bump. Also, I reworked the startup script so that brltty will start
+ early in the boot process.
01 Jan 2008; William Hubbs <williamh@gentoo.org>
-files/brltty-3.7.2-linux-compiler-h.patch,
diff --git a/app-accessibility/brltty/brltty-3.9.ebuild b/app-accessibility/brltty/brltty-3.9.ebuild
new file mode 100644
index 000000000000..f544b8f84710
--- /dev/null
+++ b/app-accessibility/brltty/brltty-3.9.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-3.9.ebuild,v 1.1 2008/01/05 22:46:49 williamh Exp $
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Daemon that provides access to the Linux/Unix console for a blind person"
+HOMEPAGE="http://mielke.cc/brltty/"
+SRC_URI="http://mielke.cc/brltty/releases/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="bluetooth doc gpm iconv java nls ocaml python usb tcl X"
+
+DEPEND="bluetooth? ( net-wireless/bluez-libs )
+ gpm? ( >=sys-libs/gpm-1.20 )
+ iconv? ( virtual/libiconv )
+ java? ( virtual/jdk )
+ nls? ( virtual/libintl )
+ ocaml? ( >=dev-lang/ocaml-3.09.3-r1 )
+ python? ( >=dev-python/pyrex-0.9.4.1 )
+ tcl? ( >=dev-lang/tcl-8.4.15 )
+ usb? ( >=dev-libs/libusb-0.1.12-r1 )
+ X? ( x11-libs/libXaw )"
+
+src_compile() {
+ econf --prefix=/ \
+ $(use_enable bluetooth) \
+ $(use_enable gpm) \
+ $(use_enable iconv) \
+ $(use_enable java java-bindings) \
+ $(use_enable nls i18n) \
+ $(use_enable ocaml caml-bindings) \
+ $(use_enable python python-bindings) \
+ $(use_enable usb usb-support) \
+ $(use_enable tcl tcl-bindings) \
+ $(use_with X x) \
+ --includedir=/usr/include || die
+ emake || die
+}
+
+src_install() {
+ make INSTALL_PROGRAM="\${INSTALL_SCRIPT}" INSTALL_ROOT="${D}" install || die
+
+
+ cd Documents
+ rm *.made
+ dodoc ChangeLog README* Manual.* TODO
+ dohtml -r Manual-HTML
+ if use doc; then
+ dodoc BrlAPI.* BrlAPIref.doxy
+ dohtml -r BrlAPI-HTML BrlAPIref-HTML
+ fi
+
+ insinto /etc
+ doins brltty.conf
+ newinitd "${FILESDIR}"/brltty.rc brltty
+
+ libdir="$(get_libdir)"
+ mkdir -p "${D}"/usr/${libdir}/
+ mv "${D}"/${libdir}/*.a "${D}"/usr/${libdir}/
+ gen_usr_ldscript libbrlapi.so
+# TMPDIR=../../Programs scanelf -RBXr "${D}" -o /dev/null
+}
+
+pkg_postinst() {
+ elog
+ elog please be sure "${ROOT}"etc/brltty.conf is correct for your system.
+ elog
+ elog To make brltty start on boot, type this command as root:
+ elog
+ elog rc-update add brltty boot
+}
diff --git a/app-accessibility/brltty/files/brltty.rc b/app-accessibility/brltty/files/brltty.rc
index 414f9e948481..81ab32222ec9 100644
--- a/app-accessibility/brltty/files/brltty.rc
+++ b/app-accessibility/brltty/files/brltty.rc
@@ -1,11 +1,13 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/files/brltty.rc,v 1.1 2007/03/28 04:03:22 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/files/brltty.rc,v 1.2 2008/01/05 22:46:50 williamh Exp $
depend() {
- need localmount
- after bootmisc
+ if [ -z $svcdir ]; then
+ before *
+ fi
+ after clock
}
start() {
diff --git a/app-accessibility/brltty/files/digest-brltty-3.9 b/app-accessibility/brltty/files/digest-brltty-3.9
new file mode 100644
index 000000000000..0298b8792598
--- /dev/null
+++ b/app-accessibility/brltty/files/digest-brltty-3.9
@@ -0,0 +1,3 @@
+MD5 7ce54ba2d38b7c220870e8c781f36743 brltty-3.9.tar.gz 1869403
+RMD160 dedbd6fb268edab076c453015c43f9db242c62f1 brltty-3.9.tar.gz 1869403
+SHA256 d6889e11ef303c41ab599415771d550ef585de6c87842e56557e081651acbe89 brltty-3.9.tar.gz 1869403