summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-03-03 22:19:31 +0000
committerMike Gilbert <floppym@gentoo.org>2014-03-03 22:19:31 +0000
commitf672066045403ddcc22998e91b863d165df8c411 (patch)
tree32b71fabd344174d7f80f4ab8f1e7710f7e5bfed
parentStable for AMD64 x86 too. (diff)
downloadgentoo-2-f672066045403ddcc22998e91b863d165df8c411.tar.gz
gentoo-2-f672066045403ddcc22998e91b863d165df8c411.tar.bz2
gentoo-2-f672066045403ddcc22998e91b863d165df8c411.zip
Pass --with-rootprefix if the ROOTPREFIX envvar is set. This should be considered experimental and is a convenience for developers only.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
-rw-r--r--sys-apps/systemd/ChangeLog7
-rw-r--r--sys-apps/systemd/systemd-210.9999.ebuild10
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild10
3 files changed, 24 insertions, 3 deletions
diff --git a/sys-apps/systemd/ChangeLog b/sys-apps/systemd/ChangeLog
index 151aaa4c125d..c158e3bcaa6e 100644
--- a/sys-apps/systemd/ChangeLog
+++ b/sys-apps/systemd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/systemd
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.235 2014/03/02 16:51:29 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.236 2014/03/03 22:19:31 floppym Exp $
+
+ 03 Mar 2014; Mike Gilbert <floppym@gentoo.org> systemd-210.9999.ebuild,
+ systemd-9999.ebuild:
+ Pass --with-rootprefix if the ROOTPREFIX envvar is set. This should be
+ considered experimental and is a convenience for developers only.
02 Mar 2014; Michał Górny <mgorny@gentoo.org> systemd-210.9999.ebuild,
systemd-210.ebuild, systemd-9999.ebuild:
diff --git a/sys-apps/systemd/systemd-210.9999.ebuild b/sys-apps/systemd/systemd-210.9999.ebuild
index 42e069e3f34f..5a34553feb08 100644
--- a/sys-apps/systemd/systemd-210.9999.ebuild
+++ b/sys-apps/systemd/systemd-210.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-210.9999.ebuild,v 1.3 2014/03/02 16:51:29 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-210.9999.ebuild,v 1.4 2014/03/03 22:19:31 floppym Exp $
EAPI=5
@@ -222,6 +222,14 @@ multilib_src_configure() {
)
fi
+ # Added for testing; this is UNSUPPORTED by the Gentoo systemd team!
+ if [[ -n ${ROOTPREFIX+set} ]]; then
+ myeconfargs+=(
+ --with-rootprefix="${ROOTPREFIX}"
+ --with-rootlibdir="${ROOTPREFIX}/$(get_libdir)"
+ )
+ fi
+
if ! multilib_is_native_abi; then
myeconfargs+=(
ac_cv_search_cap_init=
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 73529c356f09..b84df853aa66 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-9999.ebuild,v 1.99 2014/03/02 16:51:29 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-9999.ebuild,v 1.100 2014/03/03 22:19:31 floppym Exp $
EAPI=5
@@ -221,6 +221,14 @@ multilib_src_configure() {
)
fi
+ # Added for testing; this is UNSUPPORTED by the Gentoo systemd team!
+ if [[ -n ${ROOTPREFIX+set} ]]; then
+ myeconfargs+=(
+ --with-rootprefix="${ROOTPREFIX}"
+ --with-rootlibdir="${ROOTPREFIX}/$(get_libdir)"
+ )
+ fi
+
if ! multilib_is_native_abi; then
myeconfargs+=(
ac_cv_search_cap_init=