summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-10-22 21:03:02 +0000
committerMike Gilbert <floppym@gentoo.org>2014-10-22 21:03:02 +0000
commitf396ce8c2946415bfaa506df36c8c129f67784a0 (patch)
treec5a0b1d1c4d5815e986764278eae48521e8dcfae
parentStable on ppc and ppc64, bug #516152 (diff)
downloadgentoo-2-f396ce8c2946415bfaa506df36c8c129f67784a0.tar.gz
gentoo-2-f396ce8c2946415bfaa506df36c8c129f67784a0.tar.bz2
gentoo-2-f396ce8c2946415bfaa506df36c8c129f67784a0.zip
Use test-flags-CC instead of gcc-version check, thanks to vapier.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
-rw-r--r--sys-boot/grub/ChangeLog6
-rw-r--r--sys-boot/grub/grub-2.02_beta2-r2.ebuild8
-rw-r--r--sys-boot/grub/grub-9999-r1.ebuild8
3 files changed, 11 insertions, 11 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 25163d2e484d..f912156755c2 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.324 2014/10/22 16:59:39 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.325 2014/10/22 21:03:02 floppym Exp $
+
+ 22 Oct 2014; Mike Gilbert <floppym@gentoo.org> grub-2.02_beta2-r2.ebuild,
+ grub-9999-r1.ebuild:
+ Use test-flags-CC instead of gcc-version check, thanks to vapier.
22 Oct 2014; Ian Stakenvicius (_AxS_) <axs@gentoo.org> grub-0.97-r14.ebuild:
grub:0 - Only apply -fuse-ld=bfd when gcc is new enough to support it, bug
diff --git a/sys-boot/grub/grub-2.02_beta2-r2.ebuild b/sys-boot/grub/grub-2.02_beta2-r2.ebuild
index 54af5a3c96b0..4f66eb5360d4 100644
--- a/sys-boot/grub/grub-2.02_beta2-r2.ebuild
+++ b/sys-boot/grub/grub-2.02_beta2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r2.ebuild,v 1.3 2014/09/24 21:12:02 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r2.ebuild,v 1.4 2014/10/22 21:03:02 floppym Exp $
EAPI=5
@@ -135,7 +135,7 @@ QA_PRESTRIPPED="
pkg_pretend() {
if [[ ${MERGE_TYPE} != binary ]]; then
# Bug 439082
- if ! version_is_at_least 4.8 "$(gcc-version)" &&
+ if ! test-flags-CC -fuse-ld=bfd > /dev/null &&
$(tc-getLD) --version | grep -q "GNU gold"; then
eerror "GRUB does not function correctly when built with the gold linker."
eerror "Please select the bfd linker with binutils-config."
@@ -249,9 +249,7 @@ src_configure() {
use static && HOST_LDFLAGS+=" -static"
- if version_is_at_least 4.8 "$(gcc-version)"; then
- export TARGET_LDFLAGS+=" -fuse-ld=bfd"
- fi
+ export TARGET_LDFLAGS+=" $(test-flags-CC -fuse-ld=bfd)"
tc-export CC NM OBJCOPY STRIP
export TARGET_CC=${TARGET_CC:-${CC}}
diff --git a/sys-boot/grub/grub-9999-r1.ebuild b/sys-boot/grub/grub-9999-r1.ebuild
index f9a86a280ea8..96e755c845fd 100644
--- a/sys-boot/grub/grub-9999-r1.ebuild
+++ b/sys-boot/grub/grub-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999-r1.ebuild,v 1.21 2014/10/19 01:51:58 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999-r1.ebuild,v 1.22 2014/10/22 21:03:02 floppym Exp $
EAPI=5
@@ -137,7 +137,7 @@ QA_PRESTRIPPED="
pkg_pretend() {
if [[ ${MERGE_TYPE} != binary ]]; then
# Bug 439082
- if ! version_is_at_least 4.8 "$(gcc-version)" &&
+ if ! test-flags-CC -fuse-ld=bfd > /dev/null &&
$(tc-getLD) --version | grep -q "GNU gold"; then
eerror "GRUB does not function correctly when built with the gold linker."
eerror "Please select the bfd linker with binutils-config."
@@ -246,9 +246,7 @@ src_configure() {
use static && HOST_LDFLAGS+=" -static"
- if version_is_at_least 4.8 "$(gcc-version)"; then
- export TARGET_LDFLAGS+=" -fuse-ld=bfd"
- fi
+ export TARGET_LDFLAGS+=" $(test-flags-CC -fuse-ld=bfd)"
tc-export CC NM OBJCOPY STRIP
export TARGET_CC=${TARGET_CC:-${CC}}