summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-27 08:18:03 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-27 08:18:03 +0000
commiteda9985650078b9acb2ef686772e7272c22335dd (patch)
treeb93d7958d03d9c9128a4e1014d800b25c899c847
parentIUSE (Manifest recommit) (diff)
downloadgentoo-2-eda9985650078b9acb2ef686772e7272c22335dd.tar.gz
gentoo-2-eda9985650078b9acb2ef686772e7272c22335dd.tar.bz2
gentoo-2-eda9985650078b9acb2ef686772e7272c22335dd.zip
dont access $CC
-rw-r--r--app-emulation/xtrs/xtrs-4.9.ebuild12
-rw-r--r--app-i18n/qkc/qkc-1.00.ebuild17
2 files changed, 16 insertions, 13 deletions
diff --git a/app-emulation/xtrs/xtrs-4.9.ebuild b/app-emulation/xtrs/xtrs-4.9.ebuild
index ff738d0b3905..8da5f801088d 100644
--- a/app-emulation/xtrs/xtrs-4.9.ebuild
+++ b/app-emulation/xtrs/xtrs-4.9.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xtrs/xtrs-4.9.ebuild,v 1.11 2004/03/19 03:37:06 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xtrs/xtrs-4.9.ebuild,v 1.12 2004/04/27 08:17:31 vapier Exp $
-inherit eutils
+inherit eutils gcc
DESCRIPTION="RadioShack TRS80 Emulator, inc. FreeWare ROM & LDOS Image"
HOMEPAGE="http://www.tim-mann.org/trs80.html"
@@ -10,15 +10,15 @@ SRC_URI="http://home.gwi.net/~plemon/sources/${P}.tar.gz
http://home.gwi.net/~plemon/support/disks/xtrs/ld4-631.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="x86"
SLOT="0"
+KEYWORDS="x86"
IUSE=""
DEPEND="sys-libs/ncurses
sys-libs/readline
virtual/x11"
-src_unpack () {
+src_unpack() {
### make doesn't play nicely with the usual ${PREFIX} behaviour, but relies
### on an external Makefile.local to set compiletime options, and default
### behavious. we'll patch it here, to make our install sane.
@@ -28,10 +28,10 @@ src_unpack () {
}
src_compile() {
- emake DEBUG="${CFLAGS}" CC="${CC}" || die "emake failed"
+ emake DEBUG="${CFLAGS}" CC="$(gcc-getCC)" || die "emake failed"
}
-src_install () {
+src_install() {
dodir /usr/bin /usr/share/xtrs/disks /usr/share/man/man1
make install || die "make install failed"
dodoc README xtrsrom4p.README
diff --git a/app-i18n/qkc/qkc-1.00.ebuild b/app-i18n/qkc/qkc-1.00.ebuild
index 0f03a95c46d1..22b2feeb7ea4 100644
--- a/app-i18n/qkc/qkc-1.00.ebuild
+++ b/app-i18n/qkc/qkc-1.00.ebuild
@@ -1,27 +1,30 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/qkc/qkc-1.00.ebuild,v 1.6 2004/01/18 01:47:36 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/qkc/qkc-1.00.ebuild,v 1.7 2004/04/27 08:18:03 vapier Exp $
+
+inherit gcc
MY_P="${PN}c${PV/./}"
DESCRIPTION="Quick KANJI code Converter"
-SRC_URI="http://hp.vector.co.jp/authors/VA000501/${MY_P}.zip"
HOMEPAGE="http://hp.vector.co.jp/authors/VA000501/"
-SLOT="0"
+SRC_URI="http://hp.vector.co.jp/authors/VA000501/${MY_P}.zip"
+
LICENSE="freedist"
+SLOT="0"
KEYWORDS="x86 alpha ppc sparc amd64"
IUSE=""
DEPEND="virtual/glibc
app-arch/unzip"
+
S=${WORKDIR}
src_compile() {
-
- make CC="${CC}" CFLAGS="${CFLAGS}" || die
+ make CC="$(gcc-getCC)" CFLAGS="${CFLAGS}" || die
}
-src_install () {
- dobin qkc
+src_install() {
+ dobin qkc || die
dodoc qkc.doc
doman qkc.1
}