summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-09-05 09:47:10 +0000
committerMichael Januszewski <spock@gentoo.org>2004-09-05 09:47:10 +0000
commite5ce70e77abb52fcafea0681d403916cda6c5478 (patch)
treefd70cca7d5e662482a41afbea830fb4f671db0e1
parentFixed ChangeLog header. (Manifest recommit) (diff)
downloadgentoo-2-e5ce70e77abb52fcafea0681d403916cda6c5478.tar.gz
gentoo-2-e5ce70e77abb52fcafea0681d403916cda6c5478.tar.bz2
gentoo-2-e5ce70e77abb52fcafea0681d403916cda6c5478.zip
Version bump.
-rw-r--r--media-gfx/splashutils/ChangeLog10
-rw-r--r--media-gfx/splashutils/files/digest-splashutils-0.9_pre085
-rw-r--r--media-gfx/splashutils/splashutils-0.9_pre08.ebuild99
3 files changed, 113 insertions, 1 deletions
diff --git a/media-gfx/splashutils/ChangeLog b/media-gfx/splashutils/ChangeLog
index 130ae961958c..442ee73956c9 100644
--- a/media-gfx/splashutils/ChangeLog
+++ b/media-gfx/splashutils/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-gfx/splashutils
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.3 2004/08/30 14:55:23 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.4 2004/09/05 09:47:10 spock Exp $
+
+*splashutils-0.9_pre08 (05 Sep 2004)
+
+ 05 Sep 2004; Michal Januszewski <spock@gentoo.org>
+ +splashutils-0.9_pre08.ebuild:
+ Version bump. Added a new theme 'gentoo' and fixed the 'emergence' theme. For
+ a full ChangeLog for splashutils check http://dev.gentoo.org/~spock/. Closes
+ bugs #61341, #61478, #61960 and possibly #61678.
30 Aug 2004; Michal Januszewski <spock@gentoo.org>
splashutils-0.9_pre07.ebuild:
diff --git a/media-gfx/splashutils/files/digest-splashutils-0.9_pre08 b/media-gfx/splashutils/files/digest-splashutils-0.9_pre08
new file mode 100644
index 000000000000..0b7ad699477e
--- /dev/null
+++ b/media-gfx/splashutils/files/digest-splashutils-0.9_pre08
@@ -0,0 +1,5 @@
+MD5 ded2c7c1690523de1eac7e22d6b63d42 splashutils-0.9-pre08.tar.bz2 1572610
+MD5 71f85c661c144665ff5d4a8bbef1936e miscsplashutils-0.1.2.tar.bz2 91301
+MD5 87dae255b315fc4eb60197d9ac1387f4 splashutils-gentoo-0.1.1.tar.bz2 3677
+MD5 c6afab93416bc4c8fe8bc328d4e432a0 fbsplash-theme-emergence-r1.tar.bz2 4842542
+MD5 ea206196d3cee32007ae1e8eab5a0b10 fbsplash-theme-gentoo.tar.bz2 5878006
diff --git a/media-gfx/splashutils/splashutils-0.9_pre08.ebuild b/media-gfx/splashutils/splashutils-0.9_pre08.ebuild
new file mode 100644
index 000000000000..45668e62d91a
--- /dev/null
+++ b/media-gfx/splashutils/splashutils-0.9_pre08.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-0.9_pre08.ebuild,v 1.1 2004/09/05 09:47:10 spock Exp $
+
+MISCSPLASH="miscsplashutils-0.1.2"
+GENTOOSPLASH="splashutils-gentoo-0.1.1"
+
+DESCRIPTION="Framebuffer splash utilities."
+HOMEPAGE="http://dev.gentoo.org/~spock/"
+SRC_URI="mirror://gentoo/${P/_/-}.tar.bz2
+ mirror://gentoo/${MISCSPLASH}.tar.bz2
+ mirror://gentoo/${GENTOOSPLASH}.tar.bz2
+ mirror://gentoo/fbsplash-theme-emergence-r1.tar.bz2
+ mirror://gentoo/fbsplash-theme-gentoo.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=media-libs/freetype-2
+ media-libs/libpng
+ media-libs/jpeg
+ >=sys-apps/baselayout-1.10.4
+ !media-gfx/bootsplash"
+
+S="${WORKDIR}/${P/_/-}"
+SM="${WORKDIR}/${MISCSPLASH}"
+SG="${WORKDIR}/${GENTOOSPLASH}"
+
+src_unpack() {
+ unpack ${A}
+ ln -s /usr/src/linux ${S}/linux
+ if [ ! -e /usr/src/linux/include/linux/console_splash.h ]; then
+ eerror "Your kernel in /usr/src/linux has not been patched with a compatible version"
+ eerror "of fbsplash. Please download the latest patch from http://dev.gentoo.org/~spock/"
+ eerror "and patch your kernel."
+ die "Fbsplash not found"
+ fi
+
+ if [ ! -e /usr/src/linux/include/asm ]; then
+
+ t=$(readlink /usr/src/linux)
+
+ if [ -z "${KBUILD_OUTPUT_PREFIX}" ] ||
+ [ ! -e "${KBUILD_OUTPUT_PREFIX}/${t/linux-}/include/asm" ]; then
+ eerror "It appears that your kernel has not been configured. Please run at least"
+ eerror "\`make prepare\` before merging splashutils."
+ die "Kernel not configured"
+ else
+ t2=$(readlink ${KBUILD_OUTPUT_PREFIX}/${t/linux-}/include/asm)
+ ln -s /usr/src/linux/include/${t2} ${T}/asm
+ sed -e "s@#CHANGEME#@${T}/@" -i ${S}/libs/klibc-0.159/klibc/makeerrlist.pl
+ fi
+ fi
+}
+
+src_compile() {
+
+ local miscincs
+
+ if [ -n "${KBUILD_OUTPUT_PREFIX}" ]; then
+ t=$(readlink /usr/src/linux)
+ miscincs="-I${T} -I${KBUILD_OUTPUT_PREFIX}/${t/linux-}/include"
+ fi
+
+ emake -j1 MISCINCS="${miscincs}"
+
+ cd ${SM}
+ emake
+}
+
+src_install() {
+ cd ${SM}
+ make DESTDIR=${D} install || die
+
+ cd ${S}
+ make DESTDIR=${D} install || die
+
+ exeinto /sbin
+ doexe ${SG}/splash
+
+ exeinto /etc/init.d
+ newexe ${SG}/init-splash splash
+
+ insinto /sbin
+ doins ${SG}/splash-functions.sh
+
+ insinto /etc/conf.d
+ newins ${SG}/splash.conf splash
+
+ dodir /etc/splash/{emergence,gentoo}
+ cp -pR ${WORKDIR}/{emergence,gentoo} ${D}/etc/splash
+ ln -s emergence ${D}/etc/splash/default
+ dodoc docs/* README AUTHORS
+
+ if [ ! -e ${ROOT}/etc/splash/default ]; then
+ dosym /etc/splash/emergence /etc/splash/default
+ fi
+}