summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-03-05 02:34:20 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-03-05 02:34:20 +0000
commitdf59ffacf79e548bd9a72a3f6eaeb1a021a677a5 (patch)
tree705005b86c10c8e3b2e664df2d0039a3270d1855
parent2.2.0_alpha166 version bump. This includes all of the fixes in 2.1.11.55. (diff)
downloadgentoo-2-df59ffacf79e548bd9a72a3f6eaeb1a021a677a5.tar.gz
gentoo-2-df59ffacf79e548bd9a72a3f6eaeb1a021a677a5.tar.bz2
gentoo-2-df59ffacf79e548bd9a72a3f6eaeb1a021a677a5.zip
Version bump
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
-rw-r--r--net-misc/tinc/ChangeLog9
-rw-r--r--net-misc/tinc/tinc-1.0.20.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/net-misc/tinc/ChangeLog b/net-misc/tinc/ChangeLog
index a0d01c9ec687..c73828ec2222 100644
--- a/net-misc/tinc/ChangeLog
+++ b/net-misc/tinc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/tinc
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/ChangeLog,v 1.37 2012/06/26 13:59:16 blueness Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/ChangeLog,v 1.38 2013/03/05 02:34:20 blueness Exp $
+
+*tinc-1.0.20 (05 Mar 2013)
+
+ 05 Mar 2013; Anthony G. Basile <blueness@gentoo.org> +tinc-1.0.20.ebuild:
+ Version bump
26 Jun 2012; Anthony G. Basile <blueness@gentoo.org> -tinc-1.0.16-r4.ebuild,
-tinc-1.0.17.ebuild, -files/fix-compile-vde-uml.patch,
diff --git a/net-misc/tinc/tinc-1.0.20.ebuild b/net-misc/tinc/tinc-1.0.20.ebuild
new file mode 100644
index 000000000000..786bac18876b
--- /dev/null
+++ b/net-misc/tinc/tinc-1.0.20.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/tinc-1.0.20.ebuild,v 1.1 2013/03/05 02:34:20 blueness Exp $
+
+EAPI="5"
+
+DESCRIPTION="tinc is an easy to configure VPN implementation"
+HOMEPAGE="http://www.tinc-vpn.org/"
+SRC_URI="http://www.tinc-vpn.org/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+lzo uml vde +zlib"
+
+DEPEND=">=dev-libs/openssl-0.9.7
+ lzo? ( dev-libs/lzo:2 )
+ zlib? ( >=sys-libs/zlib-1.1.4 )"
+RDEPEND="${DEPEND}
+ vde? ( net-misc/vde )"
+
+src_configure() {
+ econf \
+ --enable-jumbograms \
+ --disable-tunemu \
+ $(use_enable lzo) \
+ $(use_enable uml) \
+ $(use_enable vde) \
+ $(use_enable zlib)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodir /etc/tinc
+ dodoc AUTHORS NEWS README THANKS
+ newinitd "${FILESDIR}"/tincd.1 tincd
+ newinitd "${FILESDIR}"/tincd.lo.1 tincd.lo
+ doconfd "${FILESDIR}"/tinc.networks
+ newconfd "${FILESDIR}"/tincd.conf.1 tincd
+}
+
+pkg_postinst() {
+ elog "This package requires the tun/tap kernel device."
+ elog "Look at http://www.tinc-vpn.org/ for how to configure tinc"
+}