summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2010-04-02 14:57:43 +0000
committerChristian Ruppert <idl0r@gentoo.org>2010-04-02 14:57:43 +0000
commitdde20f91608bbc154e326ebc3f1350089dfeb325 (patch)
tree5cad55ce5dfe473483093b5cf63a55953e170e1c
parentdepend vs. rdepend confusion wrt #312591 by Diego E. 'Flameeyes' Pettenò. (diff)
downloadgentoo-2-dde20f91608bbc154e326ebc3f1350089dfeb325.tar.gz
gentoo-2-dde20f91608bbc154e326ebc3f1350089dfeb325.tar.bz2
gentoo-2-dde20f91608bbc154e326ebc3f1350089dfeb325.zip
Fix rsync mirror selection, bug 312753, thanks to Donald Wallace Rouse II <gentoo-user-0d329vjsd8@dwr2.org>
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--app-portage/mirrorselect/ChangeLog12
-rw-r--r--app-portage/mirrorselect/files/0001-Fix-rsync-mirror-selectection.patch27
-rw-r--r--app-portage/mirrorselect/mirrorselect-2.1.0-r1.ebuild (renamed from app-portage/mirrorselect/mirrorselect-2.1.0.ebuild)11
3 files changed, 45 insertions, 5 deletions
diff --git a/app-portage/mirrorselect/ChangeLog b/app-portage/mirrorselect/ChangeLog
index 7bd1fdee7c11..26dab9986723 100644
--- a/app-portage/mirrorselect/ChangeLog
+++ b/app-portage/mirrorselect/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-portage/mirrorselect
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/mirrorselect/ChangeLog,v 1.88 2009/12/08 04:53:44 idl0r Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/mirrorselect/ChangeLog,v 1.89 2010/04/02 14:57:43 idl0r Exp $
+
+*mirrorselect-2.1.0-r1 (02 Apr 2010)
+
+ 02 Apr 2010; Christian Ruppert <idl0r@gentoo.org>
+ +files/0001-Fix-rsync-mirror-selectection.patch,
+ -mirrorselect-2.1.0.ebuild, +mirrorselect-2.1.0-r1.ebuild:
+ Fix rsync mirror selection, bug 312753, thanks to Donald Wallace Rouse II
+ <gentoo-user-0d329vjsd8@dwr2.org>
*mirrorselect-2.1.0 (08 Dec 2009)
diff --git a/app-portage/mirrorselect/files/0001-Fix-rsync-mirror-selectection.patch b/app-portage/mirrorselect/files/0001-Fix-rsync-mirror-selectection.patch
new file mode 100644
index 000000000000..a612ffe81ba7
--- /dev/null
+++ b/app-portage/mirrorselect/files/0001-Fix-rsync-mirror-selectection.patch
@@ -0,0 +1,27 @@
+From daad8a5e5ea2dac503513f6ab114184dd427db01 Mon Sep 17 00:00:00 2001
+From: Christian Ruppert <idl0r@gentoo.org>
+Date: Fri, 2 Apr 2010 16:44:14 +0200
+Subject: [PATCH] Fix rsync mirror selectection
+
+Append /gentoo-portage to the rsync mirror url if necessary, bug 312753,
+ thanks to Donald Wallace Rouse II <gentoo-user-0d329vjsd8@dwr2.org>
+---
+ main.py | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/main.py b/main.py
+index 367e8d4..dd3386e 100755
+--- a/main.py
++++ b/main.py
+@@ -608,6 +608,8 @@ class Interactive(object):
+
+ for (url, args) in sorted(hosts, key = lambda x: (x[1]['country'].lower(), x[1]['name'].lower()) ):
+ marker = ""
++ if options.rsync and not url.endswith("/gentoo-portage"):
++ url+="/gentoo-portage"
+ if (not options.ipv6 and not options.ipv4) and args['ipv6'] == 'y':
+ marker = "* "
+ if options.ipv6 and ( args['ipv6'] == 'n' ): continue
+--
+1.7.0.4
+
diff --git a/app-portage/mirrorselect/mirrorselect-2.1.0.ebuild b/app-portage/mirrorselect/mirrorselect-2.1.0-r1.ebuild
index f23e3547f51d..77d5d27c36fc 100644
--- a/app-portage/mirrorselect/mirrorselect-2.1.0.ebuild
+++ b/app-portage/mirrorselect/mirrorselect-2.1.0-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/mirrorselect/mirrorselect-2.1.0.ebuild,v 1.1 2009/12/08 04:53:44 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/mirrorselect/mirrorselect-2.1.0-r1.ebuild,v 1.1 2010/04/02 14:57:43 idl0r Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
-inherit python
+inherit eutils python
DESCRIPTION="Tool to help select distfiles mirrors for Gentoo"
HOMEPAGE="http://www.gentoo.org/"
@@ -22,6 +22,11 @@ RDEPEND="dev-lang/python[xml]
RESTRICT_PYTHON_ABIS="3*"
+src_prepare() {
+ # bug 312753
+ epatch "${FILESDIR}/0001-Fix-rsync-mirror-selectection.patch"
+}
+
src_install() {
newsbin main.py ${PN} || die