summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-11-23 16:16:06 +0000
committerUlrich Müller <ulm@gentoo.org>2007-11-23 16:16:06 +0000
commitcf7bcec356509ebac55b19d54d6ad805dfbb418c (patch)
tree9362e6bc6da97e5433442c9d8a5c017b0e46bd17
parentWe need pkgconfig. (diff)
downloadgentoo-2-cf7bcec356509ebac55b19d54d6ad805dfbb418c.tar.gz
gentoo-2-cf7bcec356509ebac55b19d54d6ad805dfbb418c.tar.bz2
gentoo-2-cf7bcec356509ebac55b19d54d6ad805dfbb418c.zip
Move data files from site-lisp to etc directory. Other minor changes.
(Portage version: 2.1.3.19)
-rw-r--r--app-emacs/auctex/ChangeLog10
-rw-r--r--app-emacs/auctex/auctex-11.84-r3.ebuild99
-rw-r--r--app-emacs/auctex/files/50auctex-gentoo.el8
-rw-r--r--app-emacs/auctex/files/digest-auctex-11.84-r11
-rw-r--r--app-emacs/auctex/files/digest-auctex-11.84-r21
-rw-r--r--app-emacs/auctex/files/digest-auctex-11.84-r33
6 files changed, 121 insertions, 1 deletions
diff --git a/app-emacs/auctex/ChangeLog b/app-emacs/auctex/ChangeLog
index 91d0c92f8f20..98d9b2de9214 100644
--- a/app-emacs/auctex/ChangeLog
+++ b/app-emacs/auctex/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emacs/auctex
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/ChangeLog,v 1.69 2007/11/21 12:06:29 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/ChangeLog,v 1.70 2007/11/23 16:16:06 ulm Exp $
+
+*auctex-11.84-r3 (23 Nov 2007)
+
+ 23 Nov 2007; Ulrich Mueller <ulm@gentoo.org> +files/50auctex-gentoo.el,
+ +auctex-11.84-r3.ebuild:
+ Move data files from site-lisp to etc directory. Use "emake install" for
+ installation and remove ${D} from configure options. Don't use auctex.el
+ wrapper for startup, but require tex-site directly.
21 Nov 2007; Raúl Porcel <armin76@gentoo.org> auctex-11.84-r2.ebuild:
sparc stable wrt #199765
diff --git a/app-emacs/auctex/auctex-11.84-r3.ebuild b/app-emacs/auctex/auctex-11.84-r3.ebuild
new file mode 100644
index 000000000000..9bb3b5027807
--- /dev/null
+++ b/app-emacs/auctex/auctex-11.84-r3.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/auctex-11.84-r3.ebuild,v 1.1 2007/11/23 16:16:06 ulm Exp $
+
+inherit elisp eutils latex-package
+
+DESCRIPTION="An extensible package that supports writing and formatting TeX files"
+HOMEPAGE="http://www.gnu.org/software/auctex/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="preview-latex"
+
+DEPEND="virtual/tetex
+ preview-latex? ( !dev-tex/preview-latex
+ app-text/dvipng
+ virtual/ghostscript )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # skip XEmacs detection. this is a workaround for emacs23
+ epatch "${FILESDIR}/${P}-configure.diff"
+ # allow compilation of Japanese TeX files, fixed in upstream's CVS
+ # not needed for next release (>=11.85)
+ epatch "${FILESDIR}/${P}-japanes.patch"
+}
+
+src_compile() {
+ # Don't install in the main tree, as this causes file collisions
+ # with app-text/tetex, see bug #155944
+ if use preview-latex; then
+ local TEXMFPATH="$(kpsewhich -var-value=TEXMFSITE)"
+ local TEXMFCONFIGFILE="$(kpsewhich texmf.cnf)"
+
+ if [ -z "${TEXMFPATH}" ]; then
+ eerror "You haven't defined the TEXMFSITE variable in your TeX config."
+ eerror "Please do so in the file ${TEXMFCONFIGFILE:-/var/lib/texmf/web2c/texmf.cnf}"
+ die "Define TEXMFSITE in TeX configuration!"
+ else
+ # go through the colon separated list of directories (maybe only one) provided in the variable
+ # TEXMFPATH (generated from TEXMFSITE from TeX's config) and choose only the first entry.
+ # All entries are separated by colons, even when defined with semi-colons, kpsewhich changes
+ # the output to a generic format, so IFS has to be redefined.
+ local IFS="${IFS}:"
+
+ for strippedpath in ${TEXMFPATH}
+ do
+ if [ -d ${strippedpath} ]; then
+ local PREVIEW_TEXMFDIR="${strippedpath}"
+ break
+ fi
+ done
+
+ # verify if an existing path was chosen to prevent from installing into the wrong directory
+ if [ -z ${PREVIEW_TEXMFDIR} ]; then
+ eerror "TEXMFSITE does not contain any existing directory."
+ eerror "Please define an existing directory in your TeX config file"
+ eerror "${TEXMFCONFIGFILE:-/var/lib/texmf/web2c/texmf.cnf} or create at least one of the there specified directories"
+ die "TEXMFSITE variable did not contain an existing directory"
+ fi
+
+ dodir "${PREVIEW_TEXMFDIR}"
+ fi
+ fi
+
+ econf --disable-build-dir-test \
+ --with-auto-dir="/var/lib/auctex" \
+ --with-lispdir="${SITELISP}/${PN}" \
+ --with-packagelispdir="${SITELISP}/${PN}" \
+ --with-packagedatadir="/usr/share/emacs/etc/${PN}" \
+ --with-texmf-dir="${PREVIEW_TEXMFDIR}" \
+ $(use_enable preview-latex preview) || die "econf failed"
+ emake || die "emake failed"
+ cd doc; emake tex-ref.pdf || die "creation of tex-ref.pdf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el" || die
+ if use preview-latex; then
+ elisp-site-file-install "${FILESDIR}/60${PN}-gentoo.el" || die
+ fi
+ dodoc ChangeLog CHANGES README RELEASE TODO FAQ INSTALL* doc/tex-ref.pdf
+}
+
+pkg_postinst() {
+ # rebuild TeX-inputfiles-database
+ use preview-latex && latex-package_pkg_postinst
+ elisp-site-regen
+}
+
+pkg_postrm(){
+ use preview-latex && latex-package_pkg_postrm
+ elisp-site-regen
+}
diff --git a/app-emacs/auctex/files/50auctex-gentoo.el b/app-emacs/auctex/files/50auctex-gentoo.el
new file mode 100644
index 000000000000..ad4377967194
--- /dev/null
+++ b/app-emacs/auctex/files/50auctex-gentoo.el
@@ -0,0 +1,8 @@
+
+;;; auctex site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(require 'tex-site)
+
+;; detect needed steps after rebuild
+(setq TeX-parse-self t)
diff --git a/app-emacs/auctex/files/digest-auctex-11.84-r1 b/app-emacs/auctex/files/digest-auctex-11.84-r1
index 1c658d33b342..c88a621c6913 100644
--- a/app-emacs/auctex/files/digest-auctex-11.84-r1
+++ b/app-emacs/auctex/files/digest-auctex-11.84-r1
@@ -1,2 +1,3 @@
+MD5 73970c51221524442c11cde13d0584e9 auctex-11.84.tar.gz 927517
RMD160 305f5327eac1bfe7f2770deb6617a50926c65f4f auctex-11.84.tar.gz 927517
SHA256 3f25e99ddecc21422bbddf27ecbfcab49b187eb00f69788aaba1cf818fe557d1 auctex-11.84.tar.gz 927517
diff --git a/app-emacs/auctex/files/digest-auctex-11.84-r2 b/app-emacs/auctex/files/digest-auctex-11.84-r2
index 1c658d33b342..c88a621c6913 100644
--- a/app-emacs/auctex/files/digest-auctex-11.84-r2
+++ b/app-emacs/auctex/files/digest-auctex-11.84-r2
@@ -1,2 +1,3 @@
+MD5 73970c51221524442c11cde13d0584e9 auctex-11.84.tar.gz 927517
RMD160 305f5327eac1bfe7f2770deb6617a50926c65f4f auctex-11.84.tar.gz 927517
SHA256 3f25e99ddecc21422bbddf27ecbfcab49b187eb00f69788aaba1cf818fe557d1 auctex-11.84.tar.gz 927517
diff --git a/app-emacs/auctex/files/digest-auctex-11.84-r3 b/app-emacs/auctex/files/digest-auctex-11.84-r3
new file mode 100644
index 000000000000..c88a621c6913
--- /dev/null
+++ b/app-emacs/auctex/files/digest-auctex-11.84-r3
@@ -0,0 +1,3 @@
+MD5 73970c51221524442c11cde13d0584e9 auctex-11.84.tar.gz 927517
+RMD160 305f5327eac1bfe7f2770deb6617a50926c65f4f auctex-11.84.tar.gz 927517
+SHA256 3f25e99ddecc21422bbddf27ecbfcab49b187eb00f69788aaba1cf818fe557d1 auctex-11.84.tar.gz 927517