summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2006-06-18 16:55:35 +0000
committerSven Wegener <swegener@gentoo.org>2006-06-18 16:55:35 +0000
commitce75792146332e756096bb7d7f7d11384804e758 (patch)
tree56f170c728d585a79f072dff0666cef601b9217c
parentStable on ia64. (diff)
downloadgentoo-2-ce75792146332e756096bb7d7f7d11384804e758.tar.gz
gentoo-2-ce75792146332e756096bb7d7f7d11384804e758.tar.bz2
gentoo-2-ce75792146332e756096bb7d7f7d11384804e758.zip
Revision bump, without the included recursor component. Use net-dns/pdns-recursor from now on.
(Portage version: 2.1.1_pre1-r1)
-rw-r--r--net-dns/pdns/ChangeLog8
-rw-r--r--net-dns/pdns/files/digest-pdns-2.9.20-r13
-rw-r--r--net-dns/pdns/pdns-2.9.20-r1.ebuild104
3 files changed, 114 insertions, 1 deletions
diff --git a/net-dns/pdns/ChangeLog b/net-dns/pdns/ChangeLog
index 00629a4fb231..eccddfda78c5 100644
--- a/net-dns/pdns/ChangeLog
+++ b/net-dns/pdns/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/pdns
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/ChangeLog,v 1.31 2006/06/01 21:22:25 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/ChangeLog,v 1.32 2006/06/18 16:55:35 swegener Exp $
+
+*pdns-2.9.20-r1 (18 Jun 2006)
+
+ 18 Jun 2006; Sven Wegener <swegener@gentoo.org> +pdns-2.9.20-r1.ebuild:
+ Revision bump, without the included recursor component. Use
+ net-dns/pdns-recursor from now on.
01 Jun 2006; Sven Wegener <swegener@gentoo.org>
+files/2.9.20-ldap-deprecated.patch, pdns-2.9.20.ebuild:
diff --git a/net-dns/pdns/files/digest-pdns-2.9.20-r1 b/net-dns/pdns/files/digest-pdns-2.9.20-r1
new file mode 100644
index 000000000000..6d87ffaaad65
--- /dev/null
+++ b/net-dns/pdns/files/digest-pdns-2.9.20-r1
@@ -0,0 +1,3 @@
+MD5 33b20ef1b767f93297101f2aa09e99ed pdns-2.9.20.tar.gz 867520
+RMD160 15d433bc29e7d60549d9296fca573724574614fc pdns-2.9.20.tar.gz 867520
+SHA256 28984207c78bc5d40542d40366d74f6695a9cf3a7ec4f431d908966d4fc35e3d pdns-2.9.20.tar.gz 867520
diff --git a/net-dns/pdns/pdns-2.9.20-r1.ebuild b/net-dns/pdns/pdns-2.9.20-r1.ebuild
new file mode 100644
index 000000000000..e3bea8a5dd59
--- /dev/null
+++ b/net-dns/pdns/pdns-2.9.20-r1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/pdns-2.9.20-r1.ebuild,v 1.1 2006/06/18 16:55:35 swegener Exp $
+
+inherit multilib eutils autotools
+
+DESCRIPTION="The PowerDNS Daemon"
+SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.gz"
+HOMEPAGE="http://www.powerdns.com/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc ldap mysql postgres sqlite static tdb"
+
+DEPEND="mysql? ( >=dev-db/mysql-3.23.54a )
+ postgres? ( >=dev-cpp/libpqpp-4.0-r1 )
+ ldap? ( >=net-nds/openldap-2.0.27-r4 )
+ sqlite? ( =dev-db/sqlite-2.8* )
+ tdb? ( dev-libs/tdb )
+ >=dev-libs/boost-1.31"
+
+RDEPEND="${DEPEND}"
+
+DEPEND="${DEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/2.9.18-default-mysql-options.patch
+ epatch "${FILESDIR}"/2.9.20-ldap-deprecated.patch
+
+ eautoreconf
+}
+
+src_compile() {
+ local modules="pipe geo" myconf=""
+
+ use mysql && modules="${modules} gmysql"
+ use postgres && modules="${modules} gpgsql"
+ use sqlite && modules="${modules} gsqlite"
+ use ldap && modules="${modules} ldap"
+ use tdb && modules="${modules} xdb"
+ use debug && myconf="${myconf} --enable-verbose-logging"
+
+ econf \
+ --sysconfdir=/etc/powerdns \
+ --disable-recursor \
+ --with-modules= \
+ --with-dynmodules="${modules}" \
+ --with-pgsql-includes=/usr/include \
+ --with-pgsql-lib=/usr/$(get_libdir) \
+ --with-mysql-lib=/usr/$(get_libdir) \
+ --with-sqlite-lib=/usr/$(get_libdir) \
+ $(use_enable static static-binaries) \
+ ${myconf} \
+ || die "econf failed"
+ emake -j1 || die "emake failed"
+
+ if use doc
+ then
+ emake -C codedocs codedocs || die "emake codedocs failed"
+ fi
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ mv "${D}"/etc/powerdns/pdns.conf{-dist,}
+
+ # set defaults: setuid=pdns, setgid=pdns
+ sed -i -e 's/^# set\([ug]\)id=$/set\1id=pdns/g' \
+ "${D}"/etc/powerdns/pdns.conf
+
+ doinitd "${FILESDIR}"/pdns
+
+ dodoc ChangeLog README TODO
+ use doc && dohtml -r codedocs/html/.
+}
+
+pkg_preinst() {
+ enewgroup pdns
+ enewuser pdns -1 -1 /var/empty pdns
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "ATTENTION: The config files have moved from /etc to /etc/powerdns!"
+ ewarn
+ ewarn "ATTENTION: The recursor component has been split out to net-dns(pdns-recursor!"
+ ewarn
+ einfo
+ einfo "pdns now provides multiple instances support. You can create more instances"
+ einfo "by symlinking the pdns init script to another name."
+ einfo
+ einfo "The name must be in the format pdns-<suffix> and PowerDNS will use the"
+ einfo "/etc/powerdns/pdns-<suffix>.conf configuration file instead of the default."
+ einfo
+ einfo "Also all backends, except the bind and random backends, are now compiled as"
+ einfo "loadable modules and must be loaded with load-modules= in the configuration"
+ einfo "file."
+ einfo
+}