summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2013-09-11 15:46:19 +0000
committerMichael Palimaka <kensington@gentoo.org>2013-09-11 15:46:19 +0000
commitba88dd99b77b15025eb2982e81b4c42bc8221607 (patch)
tree502a6568fe98738c1f0a401cd184bb81a6362745
parentadded prefix support (bug #484140) (diff)
downloadgentoo-2-ba88dd99b77b15025eb2982e81b4c42bc8221607.tar.gz
gentoo-2-ba88dd99b77b15025eb2982e81b4c42bc8221607.tar.bz2
gentoo-2-ba88dd99b77b15025eb2982e81b4c42bc8221607.zip
Fix failing patch wrt bug #484092. Tidy ebuild.
(Portage version: 2.2.2/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
-rw-r--r--kde-misc/kanyremote/ChangeLog5
-rw-r--r--kde-misc/kanyremote/kanyremote-6.2.ebuild16
2 files changed, 15 insertions, 6 deletions
diff --git a/kde-misc/kanyremote/ChangeLog b/kde-misc/kanyremote/ChangeLog
index f822cc741b24..701e08d33e82 100644
--- a/kde-misc/kanyremote/ChangeLog
+++ b/kde-misc/kanyremote/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for kde-misc/kanyremote
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/ChangeLog,v 1.37 2013/09/11 15:21:14 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/ChangeLog,v 1.38 2013/09/11 15:46:19 kensington Exp $
+
+ 11 Sep 2013; Michael Palimaka <kensington@gentoo.org> kanyremote-6.2.ebuild:
+ Fix failing patch wrt bug #484092. Tidy ebuild.
11 Sep 2013; Michael Palimaka <kensington@gentoo.org> kanyremote-6.2.ebuild:
Improve python support - enforce USE dependencies, allow the package to work
diff --git a/kde-misc/kanyremote/kanyremote-6.2.ebuild b/kde-misc/kanyremote/kanyremote-6.2.ebuild
index 5211c7b08e5b..4dad478e82f2 100644
--- a/kde-misc/kanyremote/kanyremote-6.2.ebuild
+++ b/kde-misc/kanyremote/kanyremote-6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/kanyremote-6.2.ebuild,v 1.3 2013/09/11 15:21:14 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/kanyremote-6.2.ebuild,v 1.4 2013/09/11 15:46:19 kensington Exp $
EAPI=5
@@ -32,14 +32,20 @@ src_prepare() {
# using gettextize no-interactive example from dev-util/bless package
cp $(type -p gettextize) "${T}"/
sed -i -e 's:read dummy < /dev/tty::' "${T}/gettextize"
+ "${T}"/gettextize -f --no-changelog > /dev/null
+
+ # remove deprecated entry
sed -e "/Encoding=UTF-8/d" \
-i kanyremote.desktop || die "fixing .desktop file failed"
- "${T}"/gettextize -f --no-changelog > /dev/null
- #fix documentation directory wrt bug #316087
+
+ # fix documentation directory wrt bug #316087
sed -i "s/doc\/${PN}/doc\/${PF}/g" Makefile.am
eautoreconf
- # workaround to bluetooth check when bluetooth use flag is disabled
- ! use bluetooth && epatch "${FILESDIR}/disable_bluetooth.patch"
+
+ # disable bluetooth check to avoid errors
+ if ! use bluetooth ; then
+ sed -e "s/usepybluez = True/usepybluez = False/" -i kanyremote || die
+ fi
}
src_install() {