summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2005-08-02 21:40:30 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2005-08-02 21:40:30 +0000
commitb9ffb5d9030c0f29d244cc7e0bc2d10c5154e8f9 (patch)
treeaea5e12a513a2f9e6fecc32524d9b062bd107add
parentVersion Bump. (diff)
downloadgentoo-2-b9ffb5d9030c0f29d244cc7e0bc2d10c5154e8f9.tar.gz
gentoo-2-b9ffb5d9030c0f29d244cc7e0bc2d10c5154e8f9.tar.bz2
gentoo-2-b9ffb5d9030c0f29d244cc7e0bc2d10c5154e8f9.zip
Ebuild clean up, bug #82747
(Portage version: 2.0.51.22-r2)
-rw-r--r--media-libs/libwmf/ChangeLog16
-rw-r--r--media-libs/libwmf/files/digest-libwmf-0.2.8.3-r11
-rw-r--r--media-libs/libwmf/libwmf-0.2.8.3-r1.ebuild82
3 files changed, 98 insertions, 1 deletions
diff --git a/media-libs/libwmf/ChangeLog b/media-libs/libwmf/ChangeLog
index 0e1d51384cab..b627b5464962 100644
--- a/media-libs/libwmf/ChangeLog
+++ b/media-libs/libwmf/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for media-libs/libwmf
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libwmf/ChangeLog,v 1.26 2005/07/12 05:33:35 smithj Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libwmf/ChangeLog,v 1.27 2005/08/02 21:40:30 sekretarz Exp $
+
+*libwmf-0.2.8.3-r1 (02 Aug 2005)
+
+ 02 Aug 2005; <sekretarz@gentoo.org> +libwmf-0.2.8.3-r1.ebuild:
+ Ebuild clean up, added buildtime dependency on pkgconfig, as it's used.
+ Changed the way X and jpeg useflags are passed to configure, using use_with
+ instead of outer conditionals on . Added pic useflag. Added xml and xml2
+ useflags: they are used to request if we are going to use expat or libxml2.
+ If both are used, it defaults to expat, as the automatic ./configure do. It
+ also make optional dependency on them (before both where dependency, also if
+ only expat was used!). Added a debug useflag passed to configure. Added a
+ gtk useflag which makes it possible to avoid building gdk-pixbuf plugins
+ (and fixes the unlinked dependency on gtk2 of the old ebuild). Thanks
+ Flameeyes in bug #82747
*libwmf-0.2.8.3 (12 Jul 2005)
diff --git a/media-libs/libwmf/files/digest-libwmf-0.2.8.3-r1 b/media-libs/libwmf/files/digest-libwmf-0.2.8.3-r1
new file mode 100644
index 000000000000..627f3406bbe1
--- /dev/null
+++ b/media-libs/libwmf/files/digest-libwmf-0.2.8.3-r1
@@ -0,0 +1 @@
+MD5 3b058327bb14d2373260a74beb7f3e2f libwmf-0.2.8.3.tar.gz 1750358
diff --git a/media-libs/libwmf/libwmf-0.2.8.3-r1.ebuild b/media-libs/libwmf/libwmf-0.2.8.3-r1.ebuild
new file mode 100644
index 000000000000..03a30f748269
--- /dev/null
+++ b/media-libs/libwmf/libwmf-0.2.8.3-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libwmf/libwmf-0.2.8.3-r1.ebuild,v 1.1 2005/08/02 21:40:30 sekretarz Exp $
+
+inherit libtool
+
+#The configure script finds the 5.50 ghostscript Fontmap file while run.
+#This will probably work, especially since the real one (6.50) in this case
+#is empty. However beware in case there is any trouble
+
+DESCRIPTION="library for converting WMF files"
+HOMEPAGE="http://wvware.sourceforge.net/"
+SRC_URI="mirror://sourceforge/wvware/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~amd64 ~hppa ~sparc ~ia64 ~mips ~ppc64"
+IUSE="jpeg X pic xml xml2 debug doc gtk"
+
+RDEPEND="virtual/ghostscript
+ xml2? ( !xml? ( dev-libs/libxml2 ) )
+ xml? ( dev-libs/expat )
+ >=media-libs/freetype-2.0.1
+ sys-libs/zlib
+ media-libs/libpng
+ jpeg? ( media-libs/jpeg )
+ X? ( virtual/x11 )
+ gtk? ( >=x11-libs/gtk+-2.1.2 ) "
+DEPEND="$RDEPEND
+ dev-util/pkgconfig"
+# plotutils are not really supported yet, so looks like that's it
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ if ! use doc; then
+ sed -e 's:doc::' -i Makefile.am
+ automake || die "automake filed"
+ fi
+
+ if ! use gtk; then
+ sed -e 's:@LIBWMF_GDK_PIXBUF_TRUE@:#:' -i src/Makefile.in
+ fi
+}
+
+src_compile() {
+ # Have to use the reverse-deps patch to prevent libwmf from
+ # linking an older installed version of libwmflite
+ #still needed !? <vapier@gentoo.org>
+ #elibtoolize --reverse-deps
+
+ if use xml && use xml2; then
+ einfo "You can specify only one flag of xml and xml2."
+ einfo "It will be defaulted to expat (like autocheck does)."
+ myconf="${myconf} --with-expat --without-libxml2"
+ else
+ myconf="${myconf} $(use_with xml expat) $(use_with xml2 libxml2)"
+ fi
+
+ econf \
+ $(use_enable debug) \
+ $(use_with jpeg) \
+ $(use_with X x) \
+ $(use_with pic) \
+ ${myconf} \
+ --with-gsfontdir=/usr/share/ghostscript/fonts \
+ --with-fontdir=/usr/share/libwmf/fonts/ \
+ --with-docdir=/usr/share/doc/${PF} \
+ || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+ make install \
+ DESTDIR=${D} \
+ fontdir=/usr/share/libwmf/fonts \
+ wmfonedocdir=/usr/share/doc/${PF}/caolan \
+ wmfdocdir=/usr/share/doc/${PF} \
+ || die
+ dodoc README AUTHORS COPYING CREDITS ChangeLog NEWS TODO
+}