summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2009-07-16 06:11:55 +0000
committerAlin Năstac <mrness@gentoo.org>2009-07-16 06:11:55 +0000
commitb71c0ff502ea420b58661edab0fdead5b725e05c (patch)
treede1886077d21e8f60d8b23dfaa74837c14eef5d0
parentFixed test failures wrt bug #190433. Changed to EAPI 2. Added patches for py2... (diff)
downloadgentoo-2-b71c0ff502ea420b58661edab0fdead5b725e05c.tar.gz
gentoo-2-b71c0ff502ea420b58661edab0fdead5b725e05c.tar.bz2
gentoo-2-b71c0ff502ea420b58661edab0fdead5b725e05c.zip
Version bump (#277908).
(Portage version: 2.1.6.13/cvs/Linux x86_64)
-rw-r--r--net-proxy/havp/ChangeLog7
-rw-r--r--net-proxy/havp/havp-0.91.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/net-proxy/havp/ChangeLog b/net-proxy/havp/ChangeLog
index e638ff759069..13e9394e3175 100644
--- a/net-proxy/havp/ChangeLog
+++ b/net-proxy/havp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-proxy/havp
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/havp/ChangeLog,v 1.32 2009/07/05 00:29:41 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/havp/ChangeLog,v 1.33 2009/07/16 06:11:55 mrness Exp $
+
+*havp-0.91 (16 Jul 2009)
+
+ 16 Jul 2009; Alin Năstac <mrness@gentoo.org> +havp-0.91.ebuild:
+ Version bump (#277908).
*havp-0.90-r1 (05 Jul 2009)
diff --git a/net-proxy/havp/havp-0.91.ebuild b/net-proxy/havp/havp-0.91.ebuild
new file mode 100644
index 000000000000..d5481f1ce4af
--- /dev/null
+++ b/net-proxy/havp/havp-0.91.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/havp/havp-0.91.ebuild,v 1.1 2009/07/16 06:11:55 mrness Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="HTTP AntiVirus Proxy"
+HOMEPAGE="http://www.server-side.de/"
+SRC_URI="http://www.server-side.de/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="clamav ssl"
+
+DEPEND="clamav? ( app-antivirus/clamav )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup havp
+ enewuser havp -1 -1 /etc/havp havp
+}
+
+src_configure() {
+ econf --localstatedir=/var \
+ $(use_enable clamav) \
+ $(use_enable ssl ssl-tunnel) || die "configure failed"
+}
+
+src_install() {
+ exeinto /usr/sbin
+ doexe havp/havp
+
+ newinitd "${FILESDIR}/havp.initd" havp
+ insinto /etc
+ doins -r etc/havp
+
+ diropts -m 0700 -o havp -g havp
+ keepdir /var/log/havp
+
+ diropts -m 0750
+ dodir /var/run/havp /var/tmp/havp
+
+ dodoc ChangeLog
+}
+
+pkg_postinst() {
+ ewarn "/var/tmp/havp must be on a filesystem with mandatory locks!"
+ ewarn "You should add \"mand\" to the mount options on the relevant line in /etc/fstab."
+
+ if use ssl; then
+ echo
+ ewarn "Note: ssl USE flag only enable SSL pass-through, which means that"
+ ewarn " HTTPS pages will not be scanned for viruses!"
+ ewarn " It is impossible to decrypt data sent through SSL connections without knowing"
+ ewarn " the private key of the used certificate."
+ fi
+
+ if use clamav; then
+ echo
+ ewarn "If you plan to use clamav daemon, you should make sure clamav user can read"
+ ewarn "/var/tmp/havp content. This can be accomplished by enabling AllowSupplementaryGroups"
+ ewarn "in /etc/clamd.conf and adding clamav user to the havp group."
+ fi
+}