summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-16 11:36:45 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-16 11:36:45 +0000
commitb46c10db0751fce3159a05f592d28773fa46e347 (patch)
tree5bc4231e1b91f73b2fe1379bd730f923a53f70c4
parentAdded "Usage" chapter (diff)
downloadgentoo-2-b46c10db0751fce3159a05f592d28773fa46e347.tar.gz
gentoo-2-b46c10db0751fce3159a05f592d28773fa46e347.tar.bz2
gentoo-2-b46c10db0751fce3159a05f592d28773fa46e347.zip
Various install bug fixes
-rw-r--r--app-text/openjade/openjade-1.3-r1.ebuild5
-rw-r--r--app-text/sgml-common/sgml-common-0.6.1.ebuild4
-rw-r--r--media-gfx/zgv/zgv-5.3.ebuild24
-rw-r--r--media-libs/SoQt/SoQt-20010215.ebuild4
-rw-r--r--media-video/xawtv/xawtv-3.45.ebuild5
-rw-r--r--net-print/cups/cups-1.1.7.ebuild2
6 files changed, 33 insertions, 11 deletions
diff --git a/app-text/openjade/openjade-1.3-r1.ebuild b/app-text/openjade/openjade-1.3-r1.ebuild
index 3550be49eb08..a121bfe17d24 100644
--- a/app-text/openjade/openjade-1.3-r1.ebuild
+++ b/app-text/openjade/openjade-1.3-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-text/openjade/openjade-1.3-r1.ebuild,v 1.7 2001/03/19 21:00:02 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/openjade/openjade-1.3-r1.ebuild,v 1.8 2001/05/16 11:36:45 achim Exp $
P=openjade-1.3
A=${P}.tar.gz
@@ -76,13 +76,16 @@ pkg_postinst() {
install-catalog --add /etc/sgml/${P}.cat /usr/share/sgml/openjade-1.3/dsssl/catalog
install-catalog --add /etc/sgml/${P}.cat /usr/share/sgml/openjade-1.3/unicode/catalog
install-catalog --add /etc/sgml/sgml-docbook.cat /etc/sgml/${P}.cat
+ echo
}
pkg_prerm() {
+ if [ "$ROOT" ="/" ] ; then
install-catalog --remove /etc/sgml/${P}.cat /usr/share/sgml/openjade-1.3/catalog
install-catalog --remove /etc/sgml/${P}.cat /usr/share/sgml/openjade-1.3/dsssl/catalog
install-catalog --remove /etc/sgml/${P}.cat /usr/share/sgml/openjade-1.3/unicode/catalog
install-catalog --add /etc/sgml/sgml-docbook.cat /etc/sgml/${P}.cat
+ fi
}
diff --git a/app-text/sgml-common/sgml-common-0.6.1.ebuild b/app-text/sgml-common/sgml-common-0.6.1.ebuild
index 961436473e5b..e5e6c0e11eb0 100644
--- a/app-text/sgml-common/sgml-common-0.6.1.ebuild
+++ b/app-text/sgml-common/sgml-common-0.6.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-text/sgml-common/sgml-common-0.6.1.ebuild,v 1.2 2001/03/19 21:00:02 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sgml-common/sgml-common-0.6.1.ebuild,v 1.3 2001/05/16 11:36:45 achim Exp $
A=${P}.tgz
S=${WORKDIR}/${P}
@@ -33,6 +33,8 @@ pkg_postinst() {
}
pkg_prerm() {
+ if [ "$ROOT" = "/" ] ; then
install-catalog --remove /etc/sgml/sgml-ent.cat /usr/share/sgml/sgml-iso-entities-8879.1986/catalog
install-catalog --add /etc/sgml/sgml-docbook.cat /etc/sgml/sgml-ent.cat
+ fi
} \ No newline at end of file
diff --git a/media-gfx/zgv/zgv-5.3.ebuild b/media-gfx/zgv/zgv-5.3.ebuild
index 5a52f9c8f6c0..346269c346e0 100644
--- a/media-gfx/zgv/zgv-5.3.ebuild
+++ b/media-gfx/zgv/zgv-5.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Ryan Tolboom <ryan@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/zgv/zgv-5.3.ebuild,v 1.1 2001/03/29 23:43:58 ryan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/zgv/zgv-5.3.ebuild,v 1.2 2001/05/16 11:36:45 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -15,13 +15,29 @@ DEPEND=">=media-libs/svgalib-1.4.2
>=sys-libs/zlib-1.1.3
>=media-libs/tiff-3.5.5"
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src
+ cp Makefile Makefile.orig
+ sed -e "s:-O2 -fomit-frame-pointer -finline-functions:${CFLAGS}:" \
+ Makefile.orig > Makefile
+}
src_compile() {
- try make
+ try make
}
src_install() {
-
- make install
+ dodir /usr/bin /usr/share/{info,man}
+ make PREFIX=${D}/usr INFODIR=${D}/usr/share/info \
+ MANDIR=${D}/usr/share/man install
+ cd ${D}/usr/share/info
+ rm dir*
+ mv zgv zgv.info
+ for i in 1 2 3 4
+ do
+ mv zgv-$i zgv.info-$i
+ done
+ cd ${S}
dodoc AUTHORS NEWS README README.fonts SECURITY TODO
}
diff --git a/media-libs/SoQt/SoQt-20010215.ebuild b/media-libs/SoQt/SoQt-20010215.ebuild
index ce62b995da0b..991a82ebbf32 100644
--- a/media-libs/SoQt/SoQt-20010215.ebuild
+++ b/media-libs/SoQt/SoQt-20010215.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Your Name <your email>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/SoQt/SoQt-20010215.ebuild,v 1.2 2001/05/09 10:21:22 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/SoQt/SoQt-20010215.ebuild,v 1.3 2001/05/16 11:36:45 achim Exp $
A=${P}.tar.gz
@@ -24,7 +24,7 @@ src_compile() {
src_install () {
- try make prefix=${D}/usr/X11R6 install
+ try make DESTDIR=${D} install
dodoc AUTHORS COPYING ChangeLog* LICENSE* NEWS README*
docinto txt
dodoc docs/qtcomponents.doxygen
diff --git a/media-video/xawtv/xawtv-3.45.ebuild b/media-video/xawtv/xawtv-3.45.ebuild
index e7ffdaf65128..953a1a36b87e 100644
--- a/media-video/xawtv/xawtv-3.45.ebuild
+++ b/media-video/xawtv/xawtv-3.45.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-video/xawtv/xawtv-3.45.ebuild,v 1.1 2001/05/08 00:24:40 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/xawtv/xawtv-3.45.ebuild,v 1.2 2001/05/16 11:36:45 achim Exp $
A=xawtv_${PV}.tar.gz
S=${WORKDIR}/${P}
@@ -25,7 +25,8 @@ src_compile() {
src_install() {
- try make prefix=${D}/usr mandir=${D}/usr/share/man install
+ try make prefix=${D}/usr mandir=${D}/usr/share/man \
+ resdir=${D}/etc/X11/app-defaults install
dodoc COPYING Changes KNOWN_PROBLEMS Miro_gpio.txt Programming-FAQ
dodoc README* Sound-FAQ TODO Trouble-Shooting UPDATE_TO_v3.0
diff --git a/net-print/cups/cups-1.1.7.ebuild b/net-print/cups/cups-1.1.7.ebuild
index 0a2b8caaa35f..603292ebf4dc 100644
--- a/net-print/cups/cups-1.1.7.ebuild
+++ b/net-print/cups/cups-1.1.7.ebuild
@@ -48,7 +48,7 @@ src_install () {
cd ${S}
try make exec_prefix=${D}/usr prefix=${D}/ \
datadir=${D}/usr/share localstatedir=${D}/var \
- includedir=${D}/usr/include \
+ includedir=${D}/usr/include sysconfdir=${D}/etc \
MANDIR=${D}/usr/share/man PAMDIR=${D}/etc/pam.d \
INITDIR=${D}/etc/rc.d DOCDIR=${D}/usr/share/cups/doc \
install