summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-11-08 00:07:21 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-11-08 00:07:21 +0000
commita559d0c6d12c48548fa5b469990d499e9734932e (patch)
tree639170b7b7566b51680099e2da02a1b582a69237
parentNew version, thanks to Enrico for the ebuild (diff)
downloadgentoo-2-a559d0c6d12c48548fa5b469990d499e9734932e.tar.gz
gentoo-2-a559d0c6d12c48548fa5b469990d499e9734932e.tar.bz2
gentoo-2-a559d0c6d12c48548fa5b469990d499e9734932e.zip
respect ldflags bug #334863, keyword ~amd64, fix implicit functions declarations
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
-rw-r--r--dev-tex/csindex/ChangeLog12
-rw-r--r--dev-tex/csindex/csindex-2.11c-r1.ebuild37
-rw-r--r--dev-tex/csindex/files/csindex-2.11c-decl.patch25
-rw-r--r--dev-tex/csindex/files/csindex-2.11c-flags.patch16
4 files changed, 88 insertions, 2 deletions
diff --git a/dev-tex/csindex/ChangeLog b/dev-tex/csindex/ChangeLog
index bceb789ec4b4..c887527c48cc 100644
--- a/dev-tex/csindex/ChangeLog
+++ b/dev-tex/csindex/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-tex/csindex
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/csindex/ChangeLog,v 1.7 2009/09/23 17:24:26 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/csindex/ChangeLog,v 1.8 2010/11/08 00:07:21 aballier Exp $
+
+*csindex-2.11c-r1 (08 Nov 2010)
+
+ 08 Nov 2010; Alexis Ballier <aballier@gentoo.org>
+ +csindex-2.11c-r1.ebuild, +files/csindex-2.11c-decl.patch,
+ +files/csindex-2.11c-flags.patch:
+ respect ldflags bug #334863, keyword ~amd64, fix implicit functions
+ declarations
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> csindex-2.11c.ebuild:
Remove virtual/libc
diff --git a/dev-tex/csindex/csindex-2.11c-r1.ebuild b/dev-tex/csindex/csindex-2.11c-r1.ebuild
new file mode 100644
index 000000000000..d2870f54521b
--- /dev/null
+++ b/dev-tex/csindex/csindex-2.11c-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/csindex/csindex-2.11c-r1.ebuild,v 1.1 2010/11/08 00:07:21 aballier Exp $
+
+EAPI=3
+
+inherit toolchain-funcs eutils
+
+MY_P="${PN}-19980713"
+
+DESCRIPTION="Utility for creating Czech/Slovak-sorted LaTeX index-files"
+HOMEPAGE="http://math.feld.cvut.cz/olsak/cstex/"
+SRC_URI="ftp://math.feld.cvut.cz/pub/cstex/base/${MY_P}.tar.gz"
+
+LICENSE="MakeIndex"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-flags.patch" \
+ "${FILESDIR}/${P}-decl.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "make failed"
+}
+
+src_install() {
+ dobin csindex || die
+ dodoc README
+}
diff --git a/dev-tex/csindex/files/csindex-2.11c-decl.patch b/dev-tex/csindex/files/csindex-2.11c-decl.patch
new file mode 100644
index 000000000000..c02d456f181f
--- /dev/null
+++ b/dev-tex/csindex/files/csindex-2.11c-decl.patch
@@ -0,0 +1,25 @@
+Index: csindex-19980713/mkind.c
+===================================================================
+--- csindex-19980713.orig/mkind.c
++++ csindex-19980713/mkind.c
+@@ -32,6 +32,8 @@
+ #ifdef CS_INDEX
+ #include <string.h>
+ #endif
++#include <unistd.h>
++
+
+ int letter_ordering = FALSE;
+ int compress_blanks = FALSE;
+Index: csindex-19980713/mkind.h
+===================================================================
+--- csindex-19980713.orig/mkind.h
++++ csindex-19980713/mkind.h
+@@ -720,6 +720,7 @@ extern void scan_idx ARGS((void));
+ extern void scan_sty ARGS((void));
+ extern void sort_idx ARGS((void));
+ extern int strtoint ARGS((char *str));
++char *strlwr(char *a);
+
+ #if __STDC__
+ #include <stdlib.h>
diff --git a/dev-tex/csindex/files/csindex-2.11c-flags.patch b/dev-tex/csindex/files/csindex-2.11c-flags.patch
new file mode 100644
index 000000000000..f13914b2eeed
--- /dev/null
+++ b/dev-tex/csindex/files/csindex-2.11c-flags.patch
@@ -0,0 +1,16 @@
+Index: csindex-19980713/Makefile
+===================================================================
+--- csindex-19980713.orig/Makefile
++++ csindex-19980713/Makefile
+@@ -1,9 +1,9 @@
+ DEFS=-DOS_SYSV
+ OBJS=csindex.o genind.o mkind.o qsort.o scanid.o scanst.o sortid.o
+-CFLAGS= -O2 $(DEFS)
++CFLAGS+= $(DEFS)
+
+ all: csindex
+
+ csindex: $(OBJS)
+- $(CC) -o csindex $(DEFS) $(OBJS) -lm
++ $(CC) $(LDFLAGS) -o csindex $(DEFS) $(OBJS) -lm
+