summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-04-30 18:11:08 +0000
committerUlrich Müller <ulm@gentoo.org>2014-04-30 18:11:08 +0000
commita1ec0787c36cbe323f6b7a46a81ca0739ac62a63 (patch)
treeb5904efb13e46b359cc524771cf93d0b8c0adfc8
parentChangeLog (diff)
downloadgentoo-2-a1ec0787c36cbe323f6b7a46a81ca0739ac62a63.tar.gz
gentoo-2-a1ec0787c36cbe323f6b7a46a81ca0739ac62a63.tar.bz2
gentoo-2-a1ec0787c36cbe323f6b7a46a81ca0739ac62a63.zip
Make the ebuild conform better with multilib-minimal.eclass.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
-rw-r--r--x11-libs/motif/ChangeLog8
-rw-r--r--x11-libs/motif/motif-2.3.4-r2.ebuild111
2 files changed, 118 insertions, 1 deletions
diff --git a/x11-libs/motif/ChangeLog b/x11-libs/motif/ChangeLog
index add7edab232a..97f56798bb1a 100644
--- a/x11-libs/motif/ChangeLog
+++ b/x11-libs/motif/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/motif
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/motif/ChangeLog,v 1.44 2014/02/07 19:50:54 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/motif/ChangeLog,v 1.45 2014/04/30 18:11:08 ulm Exp $
+
+*motif-2.3.4-r2 (30 Apr 2014)
+
+ 30 Apr 2014; Ulrich Müller <ulm@gentoo.org> +motif-2.3.4-r2.ebuild:
+ Make the ebuild conform better with multilib-minimal.eclass. Thanks to mgorny
+ for his help.
07 Feb 2014; Ulrich Müller <ulm@gentoo.org> motif-2.3.4-r1.ebuild:
Remove alternative dependencies on emul-linux-x86-* packages.
diff --git a/x11-libs/motif/motif-2.3.4-r2.ebuild b/x11-libs/motif/motif-2.3.4-r2.ebuild
new file mode 100644
index 000000000000..c4e03b0ffdb1
--- /dev/null
+++ b/x11-libs/motif/motif-2.3.4-r2.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/motif/motif-2.3.4-r2.ebuild,v 1.1 2014/04/30 18:11:08 ulm Exp $
+
+EAPI=5
+
+inherit autotools eutils flag-o-matic multilib toolchain-funcs multilib-minimal
+
+DESCRIPTION="The Motif user interface component toolkit"
+HOMEPAGE="http://sourceforge.net/projects/motif/
+ http://motif.ics.com/"
+SRC_URI="mirror://sourceforge/project/motif/Motif%20${PV}%20Source%20Code/${P}-src.tgz
+ mirror://gentoo/${P}-patches-1.tar.xz"
+
+LICENSE="LGPL-2.1+ MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples jpeg +motif22-compatibility png static-libs unicode xft"
+
+RDEPEND="abi_x86_32? ( !app-emulation/emul-linux-x86-motif[-abi_x86_32(-)] )
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXmu[${MULTILIB_USEDEP}]
+ x11-libs/libXp[${MULTILIB_USEDEP}]
+ x11-libs/libXt[${MULTILIB_USEDEP}]
+ jpeg? ( virtual/jpeg:0=[${MULTILIB_USEDEP}] )
+ png? ( >=media-libs/libpng-1.4:0=[${MULTILIB_USEDEP}] )
+ unicode? ( virtual/libiconv[${MULTILIB_USEDEP}] )
+ xft? (
+ media-libs/fontconfig[${MULTILIB_USEDEP}]
+ x11-libs/libXft[${MULTILIB_USEDEP}]
+ )"
+
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ || ( dev-util/byacc sys-freebsd/freebsd-ubin )
+ x11-misc/xbitmaps"
+
+src_prepare() {
+ EPATCH_SUFFIX=patch epatch
+ epatch_user
+
+ # disable compilation of demo binaries
+ sed -i -e '/^SUBDIRS/{:x;/\\$/{N;bx;};s/[ \t\n\\]*demos//;}' Makefile.am
+
+ # add X.Org vendor string to aliases for virtual bindings
+ echo -e '"The X.Org Foundation"\t\t\t\t\tpc' >>bindings/xmbind.alias
+
+ AT_M4DIR=. eautoreconf
+
+ # get around some LANG problems in make (#15119)
+ LANG=C
+
+ # bug #80421
+ filter-flags -ftracer
+
+ # feel free to fix properly if you care
+ append-flags -fno-strict-aliasing
+
+ # for Solaris Xos_r.h :(
+ [[ ${CHOST} == *-solaris2.11 ]] \
+ && append-cppflags -DNEED_XOS_R_H -DHAVE_READDIR_R_3
+
+ if use !elibc_glibc && use !elibc_uclibc && use unicode; then
+ # libiconv detection in configure script doesn't always work
+ # http://bugs.motifzone.net/show_bug.cgi?id=1423
+ export LIBS="${LIBS} -liconv"
+ fi
+
+ # "bison -y" causes runtime crashes #355795
+ export YACC=byacc
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --with-x \
+ $(use_enable static-libs static) \
+ $(use_enable motif22-compatibility) \
+ $(use_enable unicode utf8) \
+ $(use_enable xft) \
+ $(use_enable jpeg) \
+ $(use_enable png)
+}
+
+multilib_src_compile() {
+ # wmluiltok is linked with libfl.a, so always build it for the host ABI
+ emake -C tools/wml CC="$(tc-getBUILD_CC)" LIBS="-lfl" wmluiltok
+ emake
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ if multilib_is_native_abi && use examples; then
+ emake -C demos DESTDIR="${D}" install-data
+ dodir /usr/share/doc/${PF}/demos
+ mv "${ED}"/usr/share/Xm/* "${ED}"/usr/share/doc/${PF}/demos || die
+ fi
+}
+
+multilib_src_install_all() {
+ # mwm default configs
+ insinto /usr/share/X11/app-defaults
+ newins "${FILESDIR}"/Mwm.defaults Mwm
+
+ # cleanup
+ rm -rf "${ED}"/usr/share/Xm
+ prune_libtool_files
+
+ dodoc BUGREPORT ChangeLog README RELEASE RELNOTES TODO
+}