summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-01-30 22:28:02 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-01-30 22:28:02 +0000
commita0a24e527a2fd4a18680c093e53d6aba7a625a9b (patch)
tree5961bd80fe8dcba77ea0f94411b730c17da8d9c3
parentold (diff)
downloadgentoo-2-a0a24e527a2fd4a18680c093e53d6aba7a625a9b.tar.gz
gentoo-2-a0a24e527a2fd4a18680c093e53d6aba7a625a9b.tar.bz2
gentoo-2-a0a24e527a2fd4a18680c093e53d6aba7a625a9b.zip
old
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--games-emulation/fceux/ChangeLog9
-rw-r--r--games-emulation/fceux/fceux-2.1.4a.ebuild57
-rw-r--r--games-emulation/fceux/files/fceux-2.1.4a-ovflfix.patch22
-rw-r--r--games-emulation/fceux/files/fceux-2.1.4a-underlink.patch12
4 files changed, 6 insertions, 94 deletions
diff --git a/games-emulation/fceux/ChangeLog b/games-emulation/fceux/ChangeLog
index b08eaea69e6d..5f1ff055efcf 100644
--- a/games-emulation/fceux/ChangeLog
+++ b/games-emulation/fceux/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/fceux
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/ChangeLog,v 1.16 2012/10/26 07:31:49 tupone Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/ChangeLog,v 1.17 2013/01/30 22:28:01 mr_bones_ Exp $
+
+ 30 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org> -fceux-2.1.4a.ebuild,
+ -files/fceux-2.1.4a-ovflfix.patch, -files/fceux-2.1.4a-underlink.patch:
+ old
26 Oct 2012; Alfredo Tupone <tupone@gentoo.org> fceux-2.1.5.ebuild,
+files/fceux-2.1.5-gcc47.patch:
@@ -65,4 +69,3 @@
29 Sep 2009; Michael Sterrett <mr_bones_@gentoo.org> +fceux-2.1.1.ebuild,
+metadata.xml:
initial commit - ebuild submitted by Denilson via bug #235860
-
diff --git a/games-emulation/fceux/fceux-2.1.4a.ebuild b/games-emulation/fceux/fceux-2.1.4a.ebuild
deleted file mode 100644
index 87d7dec1e976..000000000000
--- a/games-emulation/fceux/fceux-2.1.4a.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceux/fceux-2.1.4a.ebuild,v 1.7 2011/06/07 17:07:22 tupone Exp $
-
-EAPI=2
-inherit eutils scons-utils games
-
-DESCRIPTION="A portable Famicom/NES emulator, an evolution of the original FCE Ultra"
-HOMEPAGE="http://fceux.com/"
-SRC_URI="mirror://sourceforge/fceultra/${P}.src.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="+lua +opengl"
-
-RDEPEND="lua? ( dev-lang/lua )
- media-libs/libsdl[opengl?,video]
- opengl? ( virtual/opengl )
- x11-libs/gtk+:2
- sys-libs/zlib
- gnome-extra/zenity"
-# Note: zenity is "almost" optional. It is possible to compile and run fceux
-# without zenity, but file dialogs will not work.
-
-S=${WORKDIR}/fceu${PV}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-ovflfix.patch \
- "${FILESDIR}"/${P}-underlink.patch
- # mentioned in bug #335836
- if ! use lua ; then
- sed -i -e '/_S9XLUA_H/d' SConstruct || die
- fi
-}
-
-src_compile() {
- escons \
- CREATE_AVI=1 \
- $(use_scons opengl OPENGL) \
- $(use_scons lua LUA) \
- || die "scons failed"
-}
-
-src_install() {
- dogamesbin bin/fceux || die
-
- doman documentation/fceux.6 || die
- dodoc Authors.txt changelog.txt TODO-PROJECT
-
- # Extra documentation
- insinto "/usr/share/doc/${PF}/"
- doins -r bin/fceux.chm documentation
- rm -f "${D}/usr/share/doc/${PF}/documentation/fceux.6"
-
- prepgamesdirs
-}
diff --git a/games-emulation/fceux/files/fceux-2.1.4a-ovflfix.patch b/games-emulation/fceux/files/fceux-2.1.4a-ovflfix.patch
deleted file mode 100644
index af1b32c5e383..000000000000
--- a/games-emulation/fceux/files/fceux-2.1.4a-ovflfix.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/input/bworld.cpp.old 2010-11-29 16:36:13.000000000 +0100
-+++ src/input/bworld.cpp 2010-11-29 16:37:26.000000000 +0100
-@@ -22,7 +22,7 @@
- #include "share.h"
-
- static int seq,ptr,bit,cnt,have;
--static uint8 bdata[20];
-+static uint8 bdata[32];
-
-
- static uint8 Read(int w, uint8 ret)
---- src/drivers/common/cheat.cpp.old 2010-11-29 16:23:44.000000000 +0100
-+++ src/drivers/common/cheat.cpp 2010-11-29 16:24:24.000000000 +0100
-@@ -404,7 +404,7 @@
- clo:
-
- printf("\nSelection [%d]> ",def+1);
-- fgets(tmp,256,stdin);
-+ fgets(tmp,16,stdin);
- if(tmp[0]=='\n')
- return def;
- c=tolower(tmp[0]);
diff --git a/games-emulation/fceux/files/fceux-2.1.4a-underlink.patch b/games-emulation/fceux/files/fceux-2.1.4a-underlink.patch
deleted file mode 100644
index 96c4085c8d5d..000000000000
--- a/games-emulation/fceux/files/fceux-2.1.4a-underlink.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- SConstruct.old 2011-06-07 18:37:31.324415039 +0200
-+++ SConstruct 2011-06-07 18:42:04.804434870 +0200
-@@ -65,6 +65,9 @@
- env.Append(CCFLAGS =["-D_GTK_LITE"])
- if env['GTK_LITE']:
- env.Append(CCFLAGS =["-D_GTK_LITE"])
-+ env.Append(LIBS =["-lz"])
-+ env.Append(LIBS =["-ldl"])
-+ env.Append(LIBS =["-lX11"])
-
- ### Lua platform defines
- ### Applies to all files even though only lua needs it, but should be ok