summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2008-05-14 09:38:21 +0000
committerHanno Böck <hanno@gentoo.org>2008-05-14 09:38:21 +0000
commit853ee5fc5fd0a1ac00e3def72e0eaa915e6c2d3b (patch)
treec0ef8ab270d8645389b263245b39587d610eabd5
parentremove old/broken ktoblzcheck ebuild (diff)
downloadgentoo-2-853ee5fc5fd0a1ac00e3def72e0eaa915e6c2d3b.tar.gz
gentoo-2-853ee5fc5fd0a1ac00e3def72e0eaa915e6c2d3b.tar.bz2
gentoo-2-853ee5fc5fd0a1ac00e3def72e0eaa915e6c2d3b.zip
ktoblzcheck: don't runtime-dep on libtool
(Portage version: 2.1.5_rc10)
-rw-r--r--app-misc/ktoblzcheck/ktoblzcheck-1.14.ebuild17
-rw-r--r--app-misc/ktoblzcheck/ktoblzcheck-1.17.ebuild7
2 files changed, 13 insertions, 11 deletions
diff --git a/app-misc/ktoblzcheck/ktoblzcheck-1.14.ebuild b/app-misc/ktoblzcheck/ktoblzcheck-1.14.ebuild
index 8908f9704d92..50091d02261f 100644
--- a/app-misc/ktoblzcheck/ktoblzcheck-1.14.ebuild
+++ b/app-misc/ktoblzcheck/ktoblzcheck-1.14.ebuild
@@ -1,26 +1,27 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ktoblzcheck-1.14.ebuild,v 1.8 2007/11/16 00:33:40 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ktoblzcheck-1.14.ebuild,v 1.9 2008/05/14 09:38:21 hanno Exp $
DESCRIPTION="Library to check account numbers and bank codes of German banks"
HOMEPAGE="http://ktoblzcheck.sourceforge.net/"
-SRC_URI="mirror://sourceforge/ktoblzcheck/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
IUSE="python"
-DEPEND="sys-apps/gawk
+RDEPEND="sys-apps/gawk
sys-apps/grep
- sys-devel/libtool
python? ( || ( dev-python/ctypes >=dev-lang/python-2.5 ) )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
src_compile() {
- econf `use_enable python` || die
- emake || die
+ econf `use_enable python` || die "configure failed"
+ emake || die "make failed"
}
src_install() {
- einstall BANKDATA_PATH="${D}/usr/share/ktoblzcheck" || die
+ einstall BANKDATA_PATH="${D}/usr/share/ktoblzcheck" || die "install failed"
}
diff --git a/app-misc/ktoblzcheck/ktoblzcheck-1.17.ebuild b/app-misc/ktoblzcheck/ktoblzcheck-1.17.ebuild
index 79ab885a4c24..12dae67651a6 100644
--- a/app-misc/ktoblzcheck/ktoblzcheck-1.17.ebuild
+++ b/app-misc/ktoblzcheck/ktoblzcheck-1.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ktoblzcheck-1.17.ebuild,v 1.1 2008/04/20 20:21:36 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ktoblzcheck-1.17.ebuild,v 1.2 2008/05/14 09:38:21 hanno Exp $
DESCRIPTION="Library to check account numbers and bank codes of German banks"
HOMEPAGE="http://ktoblzcheck.sourceforge.net/"
@@ -11,10 +11,11 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="python"
-DEPEND="sys-apps/gawk
+RDEPEND="sys-apps/gawk
sys-apps/grep
- sys-devel/libtool
python? ( || ( dev-python/ctypes >=dev-lang/python-2.5 ) )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
src_compile() {
econf `use_enable python` || die "configure failed"