summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-07-17 15:41:09 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-07-17 15:41:09 +0000
commit67923484b2b5d50660543411c659007c9f92921a (patch)
tree0ff1f2bc87865e47f6addf669f1a85cdbfa8a71f
parentVersion bump, more options and video/audio HTML5 tags support (diff)
downloadgentoo-2-67923484b2b5d50660543411c659007c9f92921a.tar.gz
gentoo-2-67923484b2b5d50660543411c659007c9f92921a.tar.bz2
gentoo-2-67923484b2b5d50660543411c659007c9f92921a.zip
Version bump to 0.070
(Portage version: 2.1.6.13/cvs/Linux i686)
-rw-r--r--net-irc/znc/ChangeLog7
-rw-r--r--net-irc/znc/znc-0.070.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/net-irc/znc/ChangeLog b/net-irc/znc/ChangeLog
index e96eacdb964d..547624188d29 100644
--- a/net-irc/znc/ChangeLog
+++ b/net-irc/znc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/znc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.21 2009/02/25 20:09:26 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.22 2009/07/17 15:41:09 vostorga Exp $
+
+*znc-0.070 (17 Jul 2009)
+
+ 17 Jul 2009; Víctor Ostorga <vostorga@gentoo.org> +znc-0.070.ebuild:
+ Version bump
25 Feb 2009; Markus Meier <maekke@gentoo.org> znc-0.066.ebuild:
amd64/x86 stable, bug #260148
diff --git a/net-irc/znc/znc-0.070.ebuild b/net-irc/znc/znc-0.070.ebuild
new file mode 100644
index 000000000000..fb9d314f8a27
--- /dev/null
+++ b/net-irc/znc/znc-0.070.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/znc-0.070.ebuild,v 1.1 2009/07/17 15:41:09 vostorga Exp $
+
+DESCRIPTION="An advanced IRC Bouncer"
+HOMEPAGE="http://znc.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug ipv6 nomodules perl ssl sasl"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.7d )
+ perl? ( dev-lang/perl )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable !nomodules modules) \
+ $(use_enable perl) \
+ $(use_enable ssl openssl) \
+ $(use_enable sasl) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed."
+ dodoc AUTHORS znc.conf || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog
+ elog "Run 'znc --makeconf' as the user you want to run ZNC as"
+ elog "to make a configuration file"
+ elog "If you are using SSL you should also run 'znc --makepem'"
+ elog
+}