summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2008-09-11 09:31:16 +0000
committerCédric Krier <cedk@gentoo.org>2008-09-11 09:31:16 +0000
commit64b006ad147bce48e6f5ae52ce742fba4254238d (patch)
tree6c25a9bbb924583c65a7aeda1c72e0add495a30c
parentVersion bump (diff)
downloadgentoo-2-64b006ad147bce48e6f5ae52ce742fba4254238d.tar.gz
gentoo-2-64b006ad147bce48e6f5ae52ce742fba4254238d.tar.bz2
gentoo-2-64b006ad147bce48e6f5ae52ce742fba4254238d.zip
Version bump
(Portage version: 2.1.4.4)
-rw-r--r--x11-misc/dmenu/ChangeLog5
-rw-r--r--x11-misc/dmenu/dmenu-3.9.ebuild62
2 files changed, 66 insertions, 1 deletions
diff --git a/x11-misc/dmenu/ChangeLog b/x11-misc/dmenu/ChangeLog
index 373c6c71119f..b5b7751b1d21 100644
--- a/x11-misc/dmenu/ChangeLog
+++ b/x11-misc/dmenu/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-misc/dmenu
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/ChangeLog,v 1.45 2008/07/30 18:34:27 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/ChangeLog,v 1.46 2008/09/11 09:31:16 cedk Exp $
+
+ 11 Sep 2008; Cédric Krier <cedk@gentoo.org> ChangeLog:
+ Version bump
30 Jul 2008; Cédric Krier <cedk@gentoo.org> -dmenu-3.2.ebuild:
Remove old
diff --git a/x11-misc/dmenu/dmenu-3.9.ebuild b/x11-misc/dmenu/dmenu-3.9.ebuild
new file mode 100644
index 000000000000..e339446de355
--- /dev/null
+++ b/x11-misc/dmenu/dmenu-3.9.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/dmenu-3.9.ebuild,v 1.1 2008/09/11 09:31:16 cedk Exp $
+
+inherit toolchain-funcs savedconfig
+
+DESCRIPTION="a generic, highly customizable, and efficient menu for the X Window System"
+HOMEPAGE="http://www.suckless.org/programs/dmenu.html"
+SRC_URI="http://code.suckless.org/dl/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="xinerama"
+
+DEPEND="x11-libs/libX11
+ xinerama? ( x11-libs/libXinerama )"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s/CFLAGS = -std=c99 -pedantic -Wall -Os/CFLAGS += -std=c99 -pedantic -Wall -g/" \
+ -e "s/LDFLAGS = -s/LDFLAGS += -g/" \
+ -e "s/XINERAMALIBS =/XINERAMALIBS ?=/" \
+ -e "s/XINERAMAFLAGS =/XINERAMAFLAGS ?=/" \
+ config.mk || die "sed failed"
+
+ if use savedconfig; then
+ restore_config config.h
+ fi
+}
+
+src_compile() {
+ local msg
+ use savedconfig && msg=", please check the configfile"
+ if use xinerama; then
+ emake CC=$(tc-getCC) || die "emake failed${msg}"
+ else
+ emake CC=$(tc-getCC) XINERAMAFLAGS="" XINERAMALIBS="" \
+ || die "emake failed${msg}"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+ insinto /usr/share/${PN}
+ newins config.h ${PF}.config.h
+
+ dodoc README
+
+ save_config config.h
+}
+
+pkg_postinst() {
+ einfo "This ebuild has support for user defined configs"
+ einfo "Please read this ebuild for more details and re-emerge as needed"
+ einfo "if you want to add or remove functionality for ${PN}"
+}