summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-12-10 11:17:26 +0000
committerIan Delaney <idella4@gentoo.org>2013-12-10 11:17:26 +0000
commit57000055fb9d7e26bfa7f0faa2780de0025cd09f (patch)
tree5f5491fcd7b4425b7e18b45fee38391e8a95b9f4
parentBump text-icu to 0.6.3.7 (diff)
downloadgentoo-2-57000055fb9d7e26bfa7f0faa2780de0025cd09f.tar.gz
gentoo-2-57000055fb9d7e26bfa7f0faa2780de0025cd09f.tar.bz2
gentoo-2-57000055fb9d7e26bfa7f0faa2780de0025cd09f.zip
A cut down clone of dev-python/subunit for python only, its need spawned by openstack packages' testsuites. The packages arguably should have always been named python-subunit
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
-rw-r--r--dev-python/python-subunit/ChangeLog11
-rw-r--r--dev-python/python-subunit/metadata.xml5
-rw-r--r--dev-python/python-subunit/python-subunit-0.0.15.ebuild32
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/python-subunit/ChangeLog b/dev-python/python-subunit/ChangeLog
new file mode 100644
index 000000000000..c90cc8454e7b
--- /dev/null
+++ b/dev-python/python-subunit/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-python/python-subunit
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-subunit/ChangeLog,v 1.1 2013/12/10 11:17:26 idella4 Exp $
+
+*python-subunit-0.0.15 (10 Dec 2013)
+
+ 10 Dec 2013; Ian Delaney <idella4@gentoo.org> +metadata.xml,
+ +python-subunit-0.0.15.ebuild:
+ A cut down clone of dev-python/subunit for python only, its need spawned by
+ openstack packages' testsuites. The packages arguably should have always been
+ named python-subunit
diff --git a/dev-python/python-subunit/metadata.xml b/dev-python/python-subunit/metadata.xml
new file mode 100644
index 000000000000..3db0a706a40e
--- /dev/null
+++ b/dev-python/python-subunit/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openstack</herd>
+</pkgmetadata>
diff --git a/dev-python/python-subunit/python-subunit-0.0.15.ebuild b/dev-python/python-subunit/python-subunit-0.0.15.ebuild
new file mode 100644
index 000000000000..3387bbe38cfb
--- /dev/null
+++ b/dev-python/python-subunit/python-subunit-0.0.15.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-subunit/python-subunit-0.0.15.ebuild,v 1.1 2013/12/10 11:17:26 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="A streaming protocol for test results for python only"
+HOMEPAGE="https://launchpad.net/subunit http://pypi.python.org/pypi/python-subunit"
+SRC_URI="http://launchpad.net/subunit/trunk/${PV}/+download/subunit-${PV}.tar.gz -> ${P}.tar.gz"
+#SRC_URI="mirror://pypi/p/python-${PN}/python-${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+#need to keyword the following in =dev-python/extras-0.0.3 then readd the keywords here
+#ia64 s390 sh sparc amd64-fbsd
+IUSE=""
+S="${WORKDIR}/subunit-${PV}"
+
+RDEPEND=">=dev-python/testtools-0.9.30[${PYTHON_USEDEP}]
+ dev-python/extras[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ !dev-python/subunit[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" all_tests.py || die
+}