summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Nelson <jnelson@gentoo.org>2002-07-29 02:24:36 +0000
committerJon Nelson <jnelson@gentoo.org>2002-07-29 02:24:36 +0000
commit544fd41a0db9baa2b4de1e54aa9e9d857a23f8e7 (patch)
tree88f8b1d95a199b40aafc69b7b426cf6473e4d6c9
parentAdded ppc to keywords. Fixed date on copyright header. (diff)
downloadgentoo-2-544fd41a0db9baa2b4de1e54aa9e9d857a23f8e7.tar.gz
gentoo-2-544fd41a0db9baa2b4de1e54aa9e9d857a23f8e7.tar.bz2
gentoo-2-544fd41a0db9baa2b4de1e54aa9e9d857a23f8e7.zip
hopefully close 5660
-rw-r--r--dev-db/mysql/ChangeLog12
-rw-r--r--dev-db/mysql/files/digest-mysql-3.23.51-r41
-rw-r--r--dev-db/mysql/mysql-3.23.51-r4.ebuild167
3 files changed, 177 insertions, 3 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index 7d26c3bc0d8b..0d493dc5de17 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,13 +1,19 @@
# ChangeLog for dev-db/mysql
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.13 2002/07/26 04:06:34 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.14 2002/07/29 02:24:36 jnelson Exp $
- 25 Jul 2002; Donny Davies <woodchip@gentoo.org> mysql-3.23.51-r3.ebuild :
+*mysql-3.23.51-r4 (28 Jul 2002)
- Fix initscript install. s/mysql.rc6/mysql.init/
+ 28 Jul 2002; Jon Nelson <jnelson@gentoo.org> mysql-3.23.51-r4.ebuild:
+
+ Add back in the tcpd patch -- seems to cause compile failure
*mysql-3.23.51-r3 (25 Jul 2002)
+ 25 Jul 2002; Donny Davies <woodchip@gentoo.org> mysql-3.23.51-r3.ebuild :
+
+ Fix initscript install. s/mysql.rc6/mysql.init/
+
25 Jul 2002; Jon Nelson <jnelson@gentoo.org> mysql-3.23.51-r3.ebuild files/digest-mysql-3.23.51-r3 files/mysql.init:
Fixed 5152 - used some fancy awk to extract the datadir from
diff --git a/dev-db/mysql/files/digest-mysql-3.23.51-r4 b/dev-db/mysql/files/digest-mysql-3.23.51-r4
new file mode 100644
index 000000000000..6b2531a6f4cf
--- /dev/null
+++ b/dev-db/mysql/files/digest-mysql-3.23.51-r4
@@ -0,0 +1 @@
+MD5 af9f2aaba408898df82cccf462766542 mysql-3.23.51.tar.gz 11203102
diff --git a/dev-db/mysql/mysql-3.23.51-r4.ebuild b/dev-db/mysql/mysql-3.23.51-r4.ebuild
new file mode 100644
index 000000000000..bd3fa314b0cf
--- /dev/null
+++ b/dev-db/mysql/mysql-3.23.51-r4.ebuild
@@ -0,0 +1,167 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.51-r4.ebuild,v 1.1 2002/07/29 02:24:36 jnelson Exp $
+
+SVER=${PV%.*}
+#normal releases:
+SDIR=MySQL-${SVER}
+#for a pre-release:
+#SDIR=MySQL-${SVER}-Pre
+
+DESCRIPTION="A fast, multi-threaded, multi-user SQL database server."
+HOMEPAGE="http://www.mysql.com/"
+SRC_URI="ftp://ftp.sunet.se/pub/unix/databases/relational/mysql/Downloads/${SDIR}/${P}.tar.gz
+ ftp://mysql.valueclick.com/pub/mysql/Downloads/${SDIR}/${P}.tar.gz"
+S=${WORKDIR}/${P}
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/glibc
+ readline? ( >=sys-libs/readline-4.1 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ >=sys-libs/zlib-1.1.3
+ sys-devel/perl
+ sys-apps/procps"
+
+RDEPEND="${DEPEND}"
+KEYWORDS="x86 ppc"
+
+# HEY!
+# the benchmark stuff in /usr/share/mysql/sql-bench and
+# the /usr/bin/mysql_setpermission script need dev-perl/DBD-mysql.
+# Can't add it here: circ depend. Emerge it either before or after
+# mysql; easier before, then it pulls in mysql.
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S} || die
+ # required for qmail-mysql
+ patch -p0 < ${FILESDIR}/mysql-3.23-nisam.h.diff || die
+ # zap startup script messages
+ patch -p1 < ${FILESDIR}/mysql-3.23-install-db-sh.diff || die
+ # zap binary distribution stuff
+ patch -p1 < ${FILESDIR}/mysql-3.23-safe-mysqld-sh.diff || die
+ # for correct hardcoded sysconf directory
+ patch -p1 < ${FILESDIR}/mysql-3.23-my-print-defaults.diff || die
+ patch -p1 < ${FILESDIR}/mysql-3.23.51-tcpd.patch || die
+}
+
+src_compile() {
+ local myconf
+ use berkdb && myconf="${myconf} --with-berkeley-db=./bdb"
+ use berkdb || myconf="${myconf} --without-berkeley-db"
+ use readline && myconf="${myconf} --with-readline"
+ use readline || myconf="${myconf} --without-readline"
+ use static && myconf="${myconf} --with-mysqld-ldflags=-all-static --disable-shared"
+ use static || myconf="${myconf} --enable-shared --enable-static"
+ use tcpd && myconf="${myconf} --with-libwrap"
+ use tcpd || myconf="${myconf} --without-libwrap"
+ use innodb && myconf="${myconf} --with-innodb"
+ use innodb || myconf="${myconf} --without-innodb"
+ [ -n "${DEBUGBUILD}" ] && myconf="${myconf} --with-debug"
+ [ -n "${DEBUGBUILD}" ] || myconf="${myconf} --without-debug"
+
+ # the compiler flags are as per their "official" spec ;-)
+ einfo "myconf is $myconf"
+ CFLAGS="${CFLAGS/-O?/} -O3" \
+ CXXFLAGS="${CXXFLAGS/-O?/} -O3 -felide-constructors -fno-exceptions -fno-rtti" \
+ econf \
+ --sysconfdir=/etc/mysql \
+ --localstatedir=/var/lib/mysql \
+ --with-raid \
+ --with-low-memory \
+ --enable-assembler \
+ --with-charset=latin1 \
+ --with-mysqld-user=mysql \
+ --with-extra-charsets=all \
+ --enable-thread-safe-client \
+ --with-client-ldflags=-lstdc++ \
+ --with-comment="Gentoo ${PF}.ebuild package" \
+ --with-unix-socket-path=/var/run/mysqld/mysqld.sock \
+ ${myconf} || die "bad ./configure"
+
+ make || die "compile problem"
+}
+
+src_install() {
+ make install DESTDIR=${D} benchdir_root=/usr/share/mysql || die
+
+ # eeek, not sure whats going on here.. are these needed by anything?
+ use innodb && insinto /usr/lib/mysql && doins ${WORKDIR}/../libs/*
+
+ # move client libs, install a couple of missing headers
+ mv ${D}/usr/lib/mysql/libmysqlclient*.so* ${D}/usr/lib
+ dosym ../libmysqlclient.so /usr/lib/mysql/libmysqlclient.so
+ dosym ../libmysqlclient_r.so /usr/lib/mysql/libmysqlclient_r.so
+ insinto /usr/include/mysql ; doins include/{my_config.h,my_dir.h}
+
+ # convenience links
+ dosym /usr/bin/mysqlcheck /usr/bin/mysqlanalyze
+ dosym /usr/bin/mysqlcheck /usr/bin/mysqlrepair
+ dosym /usr/bin/mysqlcheck /usr/bin/mysqloptimize
+
+ # while my broom gently sweeps...
+ rm -f ${D}/usr/share/mysql/binary-configure
+ rm -f ${D}/usr/share/mysql/mysql.server
+ rm -f ${D}/usr/share/mysql/make_binary_distribution
+ rm -f ${D}/usr/share/mysql/mi_test_all*
+ rm -f ${D}/usr/share/mysql/mysql-log-rotate
+ rm -f ${D}/usr/share/mysql/mysql*.spec
+ rm -f ${D}/usr/share/mysql/my-*.cnf
+
+ dodoc README COPYING COPYING.LIB MIRRORS \
+ Docs/{manual.ps,manual.txt}
+ docinto conf-samples
+ dodoc support-files/my-*.cnf
+ dohtml -r Docs/*
+
+ insinto /etc/mysql
+ doins ${FILESDIR}/my.cnf scripts/mysqlaccess.conf
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/mysql.init mysql
+}
+
+pkg_config() {
+ if [ ! -d ${ROOT}/var/lib/mysql/mysql ] ; then
+ einfo "Press ENTER to create the mysql database and set proper"
+ einfo "permissions on it, or Control-C to abort now..."
+ read
+ ${ROOT}/usr/bin/mysql_install_db #>>/var/log/mysql/mysql.err 2>&1
+ else
+ einfo "Hmm, it appears as though you already have the mysql"
+ einfo "database in place. If you are having problems trying"
+ einfo "to start mysqld, perhaps you need to manually run"
+ einfo "/usr/bin/mysql_install_db and/or check your config"
+ einfo "file(s) and/or database(s) and/or logfile(s)."
+ fi
+}
+
+pkg_preinst() {
+ if ! groupmod mysql; then
+ groupadd -g 60 mysql || die "problem adding group mysql"
+ fi
+
+ if ! id mysql; then
+ useradd -g mysql -s /dev/null -d /var/lib/mysql -c "mysql" mysql
+ assert "problem adding user mysql"
+ fi
+}
+
+pkg_postinst() {
+ # empty dirs...
+ install -d -m0755 -o mysql -g mysql ${ROOT}/var/lib/mysql
+ install -d -m0755 -o mysql -g mysql ${ROOT}/var/run/mysqld
+ install -d -m0755 -o mysql -g mysql ${ROOT}/var/log/mysql
+
+ # secure the logfiles... does this bother anybody?
+ touch ${ROOT}/var/log/mysql/mysql.{log,err}
+ chown mysql.mysql ${ROOT}/var/log/mysql/mysql.{log,err}
+ chmod 0660 ${ROOT}/var/log/mysql/mysql.{log,err}
+
+ # your friendly public service announcement...
+ einfo
+ einfo "You might want to run:"
+ einfo "\"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ einfo "if this is a new install."
+ einfo
+}