summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-07-06 21:10:35 +0000
committerSven Wegener <swegener@gentoo.org>2004-07-06 21:10:35 +0000
commit30aeaef0657dc8013072e6af374864e2af45db88 (patch)
tree5b70a972990130025797539a5629561d5022759e
parent-sparc (Manifest recommit) (diff)
downloadgentoo-2-30aeaef0657dc8013072e6af374864e2af45db88.tar.gz
gentoo-2-30aeaef0657dc8013072e6af374864e2af45db88.tar.bz2
gentoo-2-30aeaef0657dc8013072e6af374864e2af45db88.zip
Added fix for tab completion bug. Thanks to Martin Wienold <LLoydBates@gmx.de> for reporting it in bug #56272.
-rw-r--r--net-irc/xchat/ChangeLog9
-rw-r--r--net-irc/xchat/Manifest3
-rw-r--r--net-irc/xchat/files/digest-xchat-2.0.10-r11
-rw-r--r--net-irc/xchat/files/xc2010-fixtabcomp.diff24
-rw-r--r--net-irc/xchat/xchat-2.0.10-r1.ebuild95
5 files changed, 131 insertions, 1 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index 290bbe99f918..5459be4ce35c 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/xchat
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.106 2004/07/02 22:17:29 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.107 2004/07/06 21:10:35 swegener Exp $
+
+*xchat-2.0.10-r1 (06 Jul 2004)
+
+ 06 Jul 2004; Sven Wegener <swegener@gentoo.org>
+ +files/xc2010-fixtabcomp.diff, +xchat-2.0.10-r1.ebuild:
+ Added fix for tab completion bug. Thanks to Martin Wienold <LLoydBates@gmx.de>
+ for reporting it in bug #56272.
*xchat-2.0.10 (03 Jul 2004)
diff --git a/net-irc/xchat/Manifest b/net-irc/xchat/Manifest
index c482d6b60b75..da10c9c12dc5 100644
--- a/net-irc/xchat/Manifest
+++ b/net-irc/xchat/Manifest
@@ -6,6 +6,7 @@ MD5 548285e3c87cbd6dba10827e0e306b4e xchat-2.0.8-r1.ebuild 2072
MD5 c8531ae956e5932d14719e420d762b71 xchat-2.0.9.ebuild 2132
MD5 fcd1eb1efa64a7337e203bca5832e7ac xchat-2.0.10.ebuild 2124
MD5 c78487bfea171a839d3c39adcc24767e ChangeLog 15851
+MD5 ae25eb0825ac090d0dbd68551b7a0e9e xchat-2.0.10-r1.ebuild 2215
MD5 e2b99b2d2dfc54ba96e560c0ed8392df files/digest-xchat-1.8.11 65
MD5 e2b99b2d2dfc54ba96e560c0ed8392df files/digest-xchat-1.8.11-r1 65
MD5 15dadb9b77f7536f6c7769689fc883c9 files/digest-xchat-2.0.7-r1 64
@@ -14,3 +15,5 @@ MD5 2effc9c4c2a5454c5abba3817894e865 files/digest-xchat-2.0.9 126
MD5 a8f607d224408d4a27777d2ffce8beac files/xc1811fixststint.diff 422
MD5 31de685eff3d16d9466416434c9fd6c3 files/xc208-fixsocks5.diff 688
MD5 cadc31076541d914ac76a6b556bc4fb6 files/digest-xchat-2.0.10 66
+MD5 181879489fb6c5d1607d85d099f36ec7 files/xc2010-fixtabcomp.diff 721
+MD5 cadc31076541d914ac76a6b556bc4fb6 files/digest-xchat-2.0.10-r1 66
diff --git a/net-irc/xchat/files/digest-xchat-2.0.10-r1 b/net-irc/xchat/files/digest-xchat-2.0.10-r1
new file mode 100644
index 000000000000..71b7e42a086e
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-2.0.10-r1
@@ -0,0 +1 @@
+MD5 968bc5f074fd7c202a8d63758bd5b62d xchat-2.0.10.tar.bz2 1113265
diff --git a/net-irc/xchat/files/xc2010-fixtabcomp.diff b/net-irc/xchat/files/xc2010-fixtabcomp.diff
new file mode 100644
index 000000000000..602479104ea4
--- /dev/null
+++ b/net-irc/xchat/files/xc2010-fixtabcomp.diff
@@ -0,0 +1,24 @@
+# Fixes two tab-nick-completion bugs:
+# 1. Crash when you type space-tab
+# 2. Critical glib warning when completion in a dialog-tab.
+--- xchat-2.0.10/src/fe-gtk/fkeys.c 2004-07-01 18:28:43.000000000 +0200
++++ xchat-2.0.10p1/src/fe-gtk/fkeys.c 2004-07-05 12:19:56.000000000 +0200
+@@ -1394,7 +1394,7 @@
+ skip_len++;
+ }
+ else
+- cursor_pos = g_utf8_pointer_to_offset(text, g_utf8_offset_to_pointer(ch, 1));
++ return 2;
+ }
+
+ comp = skip_len;
+@@ -1599,7 +1599,8 @@
+ gtk_entry_set_text (GTK_ENTRY (t), buf);
+ gtk_editable_set_position (GTK_EDITABLE (t), g_utf8_pointer_to_offset(buf, buf + cursor_pos));
+ }
+- g_completion_free(gcomp);
++ if (gcomp)
++ g_completion_free(gcomp);
+ return 2;
+ }
+ #undef COMP_BUF
diff --git a/net-irc/xchat/xchat-2.0.10-r1.ebuild b/net-irc/xchat/xchat-2.0.10-r1.ebuild
new file mode 100644
index 000000000000..3ac09ab8d9f1
--- /dev/null
+++ b/net-irc/xchat/xchat-2.0.10-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.0.10-r1.ebuild,v 1.1 2004/07/06 21:10:35 swegener Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Graphical IRC client"
+SRC_URI="http://www.xchat.org/files/source/2.0/${P}.tar.bz2"
+HOMEPAGE="http://www.xchat.org/"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~x86 ~sparc ~hppa ~ppc ~alpha ~amd64 ~ia64 ~mips"
+IUSE="perl tcltk python ssl mmx ipv6 nls"
+# Local use flag for the text frontend (bug #26427)
+IUSE="${IUSE} xchattext xchatnogtk"
+
+# Added for to fix a sparc seg fault issue by Jason Wever <weeve@gentoo.org>
+if [ ${ARCH} = "sparc" ]
+then
+ replace-flags "-O3" "-O2"
+fi
+
+RDEPEND=">=dev-libs/glib-2.0.3
+ !xchatnogtk? ( >=x11-libs/gtk+-2.0.3 )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ python? ( dev-lang/python )
+ tcltk? ( dev-lang/tcl )
+ nls? ( sys-devel/gettext )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.7
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/xc2010-fixtabcomp.diff
+}
+
+src_compile() {
+
+ # xchat's configure script uses sys.path to find library path
+ # instead of python-config (#25943)
+ unset PYTHONPATH
+
+ # test for local usage of xchatnogtk
+ local gtkconf
+ use xchatnogtk \
+ && gtkconf="--disable-gtkfe" \
+ || gtkconf="--enable-gtkfe"
+
+ econf \
+ ${gtkconf} \
+ `use_enable ssl openssl` \
+ `use_enable perl` \
+ `use_enable python` \
+ `use_enable tcltk tcl` \
+ `use_enable mmx` \
+ `use_enable ipv6` \
+ `use_enable nls` \
+ `use_enable xchattext textfe` \
+ --program-suffix=-2 \
+ || die "Configure failed"
+
+ emake || die "Compile failed"
+
+}
+
+src_install() {
+
+ # some magic to create a menu entry for xchat 2
+ sed -i \
+ -e "s:^Exec=xchat$:Exec=xchat-2:" \
+ -e "s:Name=XChat IRC:Name=XChat 2 IRC:" \
+ xchat.desktop
+
+ make DESTDIR=${D} install || die "Install failed"
+
+ # install plugin development header
+ insinto /usr/include/xchat
+ doins src/common/xchat-plugin.h
+
+ dodoc ChangeLog README*
+
+}
+
+pkg_postinst() {
+ einfo
+ einfo "With this release the tab completion behaviour has changed."
+ einfo "See http://forum.xchat.org/viewtopic.php?p=653 for more info."
+ einfo
+}