summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-09-21 11:52:00 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-09-21 11:52:00 +0000
commit2e42d4a1354f54c97fdab41147fc6f9d313637c0 (patch)
treeda8e7d7cdc835ccc89c25e1b5f4bd9f409abbfd9
parentupdate git url (diff)
downloadgentoo-2-2e42d4a1354f54c97fdab41147fc6f9d313637c0.tar.gz
gentoo-2-2e42d4a1354f54c97fdab41147fc6f9d313637c0.tar.bz2
gentoo-2-2e42d4a1354f54c97fdab41147fc6f9d313637c0.zip
remove old
(Portage version: 2.2.0_alpha130/cvs/Linux x86_64)
-rw-r--r--media-plugins/live/ChangeLog6
-rw-r--r--media-plugins/live/live-2012.04.04.ebuild116
-rw-r--r--media-plugins/live/live-2012.04.21.ebuild126
-rw-r--r--media-plugins/live/live-2012.06.26.ebuild126
4 files changed, 5 insertions, 369 deletions
diff --git a/media-plugins/live/ChangeLog b/media-plugins/live/ChangeLog
index 3e03de54f66c..1f608b1c564b 100644
--- a/media-plugins/live/ChangeLog
+++ b/media-plugins/live/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-plugins/live
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/live/ChangeLog,v 1.158 2012/08/22 15:25:16 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/live/ChangeLog,v 1.159 2012/09/21 11:52:00 aballier Exp $
+
+ 21 Sep 2012; Alexis Ballier <aballier@gentoo.org> -live-2012.04.04.ebuild,
+ -live-2012.04.21.ebuild, -live-2012.06.26.ebuild:
+ remove old
*live-2012.08.20 (22 Aug 2012)
diff --git a/media-plugins/live/live-2012.04.04.ebuild b/media-plugins/live/live-2012.04.04.ebuild
deleted file mode 100644
index cbdc38f474bf..000000000000
--- a/media-plugins/live/live-2012.04.04.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/live/live-2012.04.04.ebuild,v 1.1 2012/04/05 12:32:44 aballier Exp $
-
-EAPI=3
-inherit flag-o-matic eutils toolchain-funcs multilib
-
-DESCRIPTION="Source-code libraries for standards-based RTP/RTCP/RTSP multimedia streaming, suitable for embedded and/or low-cost streaming applications"
-HOMEPAGE="http://www.live555.com/"
-SRC_URI="http://www.live555.com/liveMedia/public/${P/-/.}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE=""
-
-S="${WORKDIR}"
-
-# Alexis Ballier <aballier@gentoo.org>
-# Be careful, bump this everytime you bump the package and the ABI has changed.
-# If you don't know, ask someone.
-LIVE_ABI_VERSION=5
-
-src_prepare() {
- cd "${WORKDIR}"
- epatch "${FILESDIR}/${PN}-recursive.patch"
-
- cp -pPR live live-shared
- mv live live-static
-
- cp "${FILESDIR}/config.gentoo" live-static
- cp "${FILESDIR}/config.gentoo-so-r1" live-shared
-
- case ${CHOST} in
- *-solaris*)
- sed -i \
- -e '/^COMPILE_OPTS /s/$/ -DSOLARIS/' \
- -e '/^LIBS_FOR_CONSOLE_APPLICATION /s/$/ -lsocket -lnsl/' \
- live-static/config.gentoo \
- live-shared/config.gentoo-so-r1 \
- || die
- ;;
- *-darwin*)
- sed -i \
- -e '/^COMPILE_OPTS /s/$/ -DBSD=1 -DHAVE_SOCKADDR_LEN=1/' \
- -e '/^LINK /s/$/ /' \
- -e '/^LIBRARY_LINK /s/$/ /' \
- -e '/^LIBRARY_LINK_OPTS /s/-Bstatic//' \
- live-static/config.gentoo \
- || die static
- sed -i \
- -e '/^COMPILE_OPTS /s/$/ -DBSD=1 -DHAVE_SOCKADDR_LEN=1/' \
- -e '/^LINK /s/$/ /' \
- -e '/^LIBRARY_LINK /s/=.*$/= $(CXX) -o /' \
- -e '/^LIBRARY_LINK_OPTS /s:-shared.*$:-undefined suppress -flat_namespace -dynamiclib -install_name '"${EPREFIX}/usr/$(get_libdir)/"'$@:' \
- live-shared/config.gentoo-so-r1 \
- || die shared
- ;;
- esac
-}
-
-src_configure() { :; }
-
-src_compile() {
- tc-export CC CXX LD
-
- # Still build the old synchronous interface as mplayer still needs it.
- # Please drop me at some point!
- append-flags '-DRTSPCLIENT_SYNCHRONOUS_INTERFACE'
-
- cd "${WORKDIR}/live-static"
-
- einfo "Beginning static library build"
- ./genMakefiles gentoo
- emake -j1 LINK_OPTS="-L. $(raw-ldflags)" || die "failed to build static libraries"
-
- einfo "Beginning programs build"
- cd "${WORKDIR}/live-static/testProgs"
- emake LINK_OPTS="-L. ${LDFLAGS}" || die "failed to build test programs"
- cd "${WORKDIR}/live-static/mediaServer"
- emake LINK_OPTS="-L. ${LDFLAGS}" || die "failed to build the mediaserver"
-
- cd "${WORKDIR}/live-shared"
- einfo "Beginning shared library build"
- ./genMakefiles gentoo-so-r1
- local suffix=$(get_libname ${LIVE_ABI_VERSION})
- emake -j1 LINK_OPTS="-L. ${LDFLAGS}" LIB_SUFFIX="${suffix#.}" || die "failed to build shared libraries"
-}
-
-src_install() {
- for library in UsageEnvironment liveMedia BasicUsageEnvironment groupsock; do
- dolib.a live-static/${library}/lib${library}.a
- dolib.so live-shared/${library}/lib${library}$(get_libname ${LIVE_ABI_VERSION})
- dosym lib${library}$(get_libname ${LIVE_ABI_VERSION}) /usr/$(get_libdir)/lib${library}$(get_libname)
-
- insinto /usr/include/${library}
- doins live-shared/${library}/include/*h
- done
-
- # Should we really install these?
- find live-static/testProgs -type f -perm +111 -print0 | \
- xargs -0 dobin
-
- #install included live555MediaServer aplication
- dobin live-static/mediaServer/live555MediaServer
-
- # install docs
- dodoc live-static/README
-}
-
-pkg_postinst() {
- ewarn "If you are upgrading from a version prior to live-2008.02.08"
- ewarn "Please make sure to rebuild applications built against ${PN}"
- ewarn "like vlc or mplayer. ${PN} may have had ABI changes and ${PN}"
- ewarn "support might be broken."
-}
diff --git a/media-plugins/live/live-2012.04.21.ebuild b/media-plugins/live/live-2012.04.21.ebuild
deleted file mode 100644
index c3b5fa297853..000000000000
--- a/media-plugins/live/live-2012.04.21.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/live/live-2012.04.21.ebuild,v 1.4 2012/06/15 15:11:46 mr_bones_ Exp $
-
-EAPI=3
-inherit flag-o-matic eutils toolchain-funcs multilib
-
-DESCRIPTION="Source-code libraries for standards-based RTP/RTCP/RTSP multimedia streaming, suitable for embedded and/or low-cost streaming applications"
-HOMEPAGE="http://www.live555.com/"
-SRC_URI="http://www.live555.com/liveMedia/public/${P/-/.}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="examples static-libs"
-
-S="${WORKDIR}"
-
-# Alexis Ballier <aballier@gentoo.org>
-# Be careful, bump this everytime you bump the package and the ABI has changed.
-# If you don't know, ask someone.
-LIVE_ABI_VERSION=6
-
-src_prepare() {
- cd "${WORKDIR}"
- epatch "${FILESDIR}/${PN}-recursive2.patch"
-
- if use static-libs ; then
- cp -pPR live live-shared
- mv live live-static
- else
- mv live live-shared
- fi
-
- use static-libs && cp "${FILESDIR}/config.gentoo" live-static
- cp "${FILESDIR}/config.gentoo-so-r1" live-shared
-
- case ${CHOST} in
- *-solaris*)
- use static-libs && { sed -i \
- -e '/^COMPILE_OPTS /s/$/ -DSOLARIS -DXLOCALE_NOT_USED/' \
- -e '/^LIBS_FOR_CONSOLE_APPLICATION /s/$/ -lsocket -lnsl/' \
- live-static/config.gentoo \
- || die ; }
- sed -i \
- -e '/^COMPILE_OPTS /s/$/ -DSOLARIS -DXLOCALE_NOT_USED/' \
- -e '/^LIBS_FOR_CONSOLE_APPLICATION /s/$/ -lsocket -lnsl/' \
- live-shared/config.gentoo-so-r1 \
- || die
- ;;
- *-darwin*)
- use static-libs && { sed -i \
- -e '/^COMPILE_OPTS /s/$/ -DBSD=1 -DHAVE_SOCKADDR_LEN=1/' \
- -e '/^LINK /s/$/ /' \
- -e '/^LIBRARY_LINK /s/$/ /' \
- -e '/^LIBRARY_LINK_OPTS /s/-Bstatic//' \
- live-static/config.gentoo \
- || die static ; }
- sed -i \
- -e '/^COMPILE_OPTS /s/$/ -DBSD=1 -DHAVE_SOCKADDR_LEN=1/' \
- -e '/^LINK /s/$/ /' \
- -e '/^LIBRARY_LINK /s/=.*$/= $(CXX) -o /' \
- -e '/^LIBRARY_LINK_OPTS /s:-shared.*$:-undefined suppress -flat_namespace -dynamiclib -install_name '"${EPREFIX}/usr/$(get_libdir)/"'$@:' \
- -e '/^LIB_SUFFIX /s/so/dylib/' \
- live-shared/config.gentoo-so-r1 \
- || die shared
- ;;
- esac
-}
-
-src_configure() { :; }
-
-src_compile() {
- tc-export CC CXX LD
-
- # Still build the old synchronous interface as mplayer still needs it.
- # Please drop me at some point!
- append-flags '-DRTSPCLIENT_SYNCHRONOUS_INTERFACE'
-
- if use static-libs ; then
- cd "${WORKDIR}/live-static"
-
- einfo "Beginning static library build"
- ./genMakefiles gentoo
- emake -j1 LINK_OPTS="-L. $(raw-ldflags)" || die "failed to build static libraries"
- fi
-
- cd "${WORKDIR}/live-shared"
- einfo "Beginning shared library build"
- ./genMakefiles gentoo-so-r1
- local suffix=$(get_libname ${LIVE_ABI_VERSION})
- emake -j1 LINK_OPTS="-L. ${LDFLAGS}" LIB_SUFFIX="${suffix#.}" || die "failed to build shared libraries"
-
- for i in liveMedia groupsock UsageEnvironment BasicUsageEnvironment ; do
- pushd "${WORKDIR}/live-shared/${i}" > /dev/null
- ln -s lib${i}.${suffix#.} lib${i}$(get_libname) || die
- popd > /dev/null
- done
-
- einfo "Beginning programs build"
- for i in $(use examples && echo "testProgs") proxyServer mediaServer ; do
- cd "${WORKDIR}/live-shared/${i}"
- emake LINK_OPTS="-L. ${LDFLAGS}" || die "failed to build test programs"
- done
-}
-
-src_install() {
- for library in UsageEnvironment liveMedia BasicUsageEnvironment groupsock; do
- use static-libs && dolib.a live-static/${library}/lib${library}.a
- dolib.so live-shared/${library}/lib${library}$(get_libname ${LIVE_ABI_VERSION})
- dosym lib${library}$(get_libname ${LIVE_ABI_VERSION}) /usr/$(get_libdir)/lib${library}$(get_libname)
-
- insinto /usr/include/${library}
- doins live-shared/${library}/include/*h
- done
-
- # Should we really install these?
- use examples && find live-shared/testProgs -type f -perm +111 -print0 | \
- xargs -0 dobin
-
- dobin live-shared/mediaServer/live555MediaServer
- dobin live-shared/proxyServer/live555ProxyServer
-
- # install docs
- dodoc live-shared/README
-}
diff --git a/media-plugins/live/live-2012.06.26.ebuild b/media-plugins/live/live-2012.06.26.ebuild
deleted file mode 100644
index c99ec62c2602..000000000000
--- a/media-plugins/live/live-2012.06.26.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/live/live-2012.06.26.ebuild,v 1.1 2012/07/01 19:08:34 aballier Exp $
-
-EAPI=3
-inherit flag-o-matic eutils toolchain-funcs multilib
-
-DESCRIPTION="Source-code libraries for standards-based RTP/RTCP/RTSP multimedia streaming, suitable for embedded and/or low-cost streaming applications"
-HOMEPAGE="http://www.live555.com/"
-SRC_URI="http://www.live555.com/liveMedia/public/${P/-/.}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="examples static-libs"
-
-S="${WORKDIR}"
-
-# Alexis Ballier <aballier@gentoo.org>
-# Be careful, bump this everytime you bump the package and the ABI has changed.
-# If you don't know, ask someone.
-LIVE_ABI_VERSION=6
-
-src_prepare() {
- cd "${WORKDIR}"
- epatch "${FILESDIR}/${PN}-recursive2.patch"
-
- if use static-libs ; then
- cp -pPR live live-shared
- mv live live-static
- else
- mv live live-shared
- fi
-
- use static-libs && cp "${FILESDIR}/config.gentoo" live-static
- cp "${FILESDIR}/config.gentoo-so-r1" live-shared
-
- case ${CHOST} in
- *-solaris*)
- use static-libs && { sed -i \
- -e '/^COMPILE_OPTS /s/$/ -DSOLARIS -DXLOCALE_NOT_USED/' \
- -e '/^LIBS_FOR_CONSOLE_APPLICATION /s/$/ -lsocket -lnsl/' \
- live-static/config.gentoo \
- || die ; }
- sed -i \
- -e '/^COMPILE_OPTS /s/$/ -DSOLARIS -DXLOCALE_NOT_USED/' \
- -e '/^LIBS_FOR_CONSOLE_APPLICATION /s/$/ -lsocket -lnsl/' \
- live-shared/config.gentoo-so-r1 \
- || die
- ;;
- *-darwin*)
- use static-libs && { sed -i \
- -e '/^COMPILE_OPTS /s/$/ -DBSD=1 -DHAVE_SOCKADDR_LEN=1/' \
- -e '/^LINK /s/$/ /' \
- -e '/^LIBRARY_LINK /s/$/ /' \
- -e '/^LIBRARY_LINK_OPTS /s/-Bstatic//' \
- live-static/config.gentoo \
- || die static ; }
- sed -i \
- -e '/^COMPILE_OPTS /s/$/ -DBSD=1 -DHAVE_SOCKADDR_LEN=1/' \
- -e '/^LINK /s/$/ /' \
- -e '/^LIBRARY_LINK /s/=.*$/= $(CXX) -o /' \
- -e '/^LIBRARY_LINK_OPTS /s:-shared.*$:-undefined suppress -flat_namespace -dynamiclib -install_name '"${EPREFIX}/usr/$(get_libdir)/"'$@:' \
- -e '/^LIB_SUFFIX /s/so/dylib/' \
- live-shared/config.gentoo-so-r1 \
- || die shared
- ;;
- esac
-}
-
-src_configure() { :; }
-
-src_compile() {
- tc-export CC CXX LD
-
- # Still build the old synchronous interface as mplayer still needs it.
- # Please drop me at some point!
- append-flags '-DRTSPCLIENT_SYNCHRONOUS_INTERFACE'
-
- if use static-libs ; then
- cd "${WORKDIR}/live-static"
-
- einfo "Beginning static library build"
- ./genMakefiles gentoo
- emake -j1 LINK_OPTS="-L. $(raw-ldflags)" || die "failed to build static libraries"
- fi
-
- cd "${WORKDIR}/live-shared"
- einfo "Beginning shared library build"
- ./genMakefiles gentoo-so-r1
- local suffix=$(get_libname ${LIVE_ABI_VERSION})
- emake -j1 LINK_OPTS="-L. ${LDFLAGS}" LIB_SUFFIX="${suffix#.}" || die "failed to build shared libraries"
-
- for i in liveMedia groupsock UsageEnvironment BasicUsageEnvironment ; do
- pushd "${WORKDIR}/live-shared/${i}" > /dev/null
- ln -s lib${i}.${suffix#.} lib${i}$(get_libname) || die
- popd > /dev/null
- done
-
- einfo "Beginning programs build"
- for i in $(use examples && echo "testProgs") proxyServer mediaServer ; do
- cd "${WORKDIR}/live-shared/${i}"
- emake LINK_OPTS="-L. ${LDFLAGS}" || die "failed to build test programs"
- done
-}
-
-src_install() {
- for library in UsageEnvironment liveMedia BasicUsageEnvironment groupsock; do
- use static-libs && dolib.a live-static/${library}/lib${library}.a
- dolib.so live-shared/${library}/lib${library}$(get_libname ${LIVE_ABI_VERSION})
- dosym lib${library}$(get_libname ${LIVE_ABI_VERSION}) /usr/$(get_libdir)/lib${library}$(get_libname)
-
- insinto /usr/include/${library}
- doins live-shared/${library}/include/*h
- done
-
- # Should we really install these?
- use examples && find live-shared/testProgs -type f -perm +111 -print0 | \
- xargs -0 dobin
-
- dobin live-shared/mediaServer/live555MediaServer
- dobin live-shared/proxyServer/live555ProxyServer
-
- # install docs
- dodoc live-shared/README
-}