summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-08-02 13:33:37 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-08-02 13:33:37 +0000
commit2b67cea6ecca2742fae03d05375312e896f66c51 (patch)
tree26d06e81c71366af7e8131793e230d7465038c95
parentVersion bump (diff)
downloadgentoo-2-2b67cea6ecca2742fae03d05375312e896f66c51.tar.gz
gentoo-2-2b67cea6ecca2742fae03d05375312e896f66c51.tar.bz2
gentoo-2-2b67cea6ecca2742fae03d05375312e896f66c51.zip
Version bumps to provide more options. bug #451718
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)
-rw-r--r--app-emulation/kvm-kmod/ChangeLog13
-rw-r--r--app-emulation/kvm-kmod/kvm-kmod-3.10.1.ebuild (renamed from app-emulation/kvm-kmod/kvm-kmod-2.6.32.27.ebuild)4
-rw-r--r--app-emulation/kvm-kmod/kvm-kmod-3.6.ebuild68
-rw-r--r--app-emulation/kvm-kmod/kvm-kmod-3.8.ebuild68
4 files changed, 148 insertions, 5 deletions
diff --git a/app-emulation/kvm-kmod/ChangeLog b/app-emulation/kvm-kmod/ChangeLog
index 8ea1af27e31c..077b9f79899e 100644
--- a/app-emulation/kvm-kmod/ChangeLog
+++ b/app-emulation/kvm-kmod/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/kvm-kmod
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/ChangeLog,v 1.24 2012/06/14 05:26:46 cardoe Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/ChangeLog,v 1.25 2013/08/02 13:33:37 cardoe Exp $
+
+*kvm-kmod-3.10.1 (02 Aug 2013)
+*kvm-kmod-3.6 (02 Aug 2013)
+*kvm-kmod-3.8 (02 Aug 2013)
+
+ 02 Aug 2013; Doug Goldstein <cardoe@gentoo.org> +kvm-kmod-3.10.1.ebuild,
+ +kvm-kmod-3.6.ebuild, +kvm-kmod-3.8.ebuild, -kvm-kmod-2.6.32.27.ebuild:
+ Version bumps to provide more options. bug #451718
*kvm-kmod-3.4 (13 Jun 2012)
*kvm-kmod-3.3.6 (13 Jun 2012)
@@ -143,4 +151,3 @@
28 Apr 2009; Daniel Gryniewicz <dang@gentoo.org> +metadata.xml,
+kvm-kmod-85.ebuild:
New kvm modules package; upstream split them up
-
diff --git a/app-emulation/kvm-kmod/kvm-kmod-2.6.32.27.ebuild b/app-emulation/kvm-kmod/kvm-kmod-3.10.1.ebuild
index 0d41dd9ac045..b681cac18f81 100644
--- a/app-emulation/kvm-kmod/kvm-kmod-2.6.32.27.ebuild
+++ b/app-emulation/kvm-kmod/kvm-kmod-3.10.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/kvm-kmod-2.6.32.27.ebuild,v 1.1 2011/05/25 14:56:34 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/kvm-kmod-3.10.1.ebuild,v 1.1 2013/08/02 13:33:37 cardoe Exp $
EAPI="2"
diff --git a/app-emulation/kvm-kmod/kvm-kmod-3.6.ebuild b/app-emulation/kvm-kmod/kvm-kmod-3.6.ebuild
new file mode 100644
index 000000000000..cd6f90042525
--- /dev/null
+++ b/app-emulation/kvm-kmod/kvm-kmod-3.6.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/kvm-kmod-3.6.ebuild,v 1.1 2013/08/02 13:33:37 cardoe Exp $
+
+EAPI="2"
+
+inherit eutils linux-mod
+
+SRC_URI="mirror://sourceforge/kvm/${P}.tar.bz2"
+
+DESCRIPTION="Kernel-based Virtual Machine kernel modules"
+HOMEPAGE="http://www.linux-kvm.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ linux_config_exists || die "Your kernel sources are unconfigured"
+
+ if ! linux_chkconfig_present KVM; then
+ eerror "KVM now needs CONFIG_KVM built into your kernel, even"
+ eerror "if you're using the external modules from this package."
+ eerror "Please enable KVM support in your kernel, found at:"
+ eerror
+ eerror " Virtualization"
+ eerror " Kernel-based Virtual Machine (KVM) support"
+ eerror
+ die "KVM support not detected!"
+ fi
+ BUILD_TARGETS="all"
+ MODULE_NAMES="kvm(kernel/arch/x86/kvm/:${S}:${S}/x86)"
+ MODULE_NAMES="${MODULE_NAMES} kvm-intel(kernel/arch/x86/kvm/:${S}:${S}/x86)"
+ MODULE_NAMES="${MODULE_NAMES} kvm-amd(kernel/arch/x86/kvm/:${S}:${S}/x86)"
+}
+
+src_configure() {
+ local conf_opts
+
+ conf_opts="--kerneldir=$KV_DIR"
+
+ if has_multilib_profile && [[ "${DEFAULT_ABI}" == "x86" ]] ; then
+ conf_opts="$conf_opts --arch=x86"
+ fi
+
+ ./configure ${conf_opts} || die "configure failed"
+}
+
+src_compile() {
+ linux-mod_src_compile
+}
+
+src_install() {
+ linux-mod_src_install
+}
+
+pkg_preinst() {
+ find /lib/modules/${KV_FULL} -name 'kvm*.ko' -type f -delete
+
+ linux-mod_pkg_preinst
+}
diff --git a/app-emulation/kvm-kmod/kvm-kmod-3.8.ebuild b/app-emulation/kvm-kmod/kvm-kmod-3.8.ebuild
new file mode 100644
index 000000000000..3bf91892e00e
--- /dev/null
+++ b/app-emulation/kvm-kmod/kvm-kmod-3.8.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/kvm-kmod-3.8.ebuild,v 1.1 2013/08/02 13:33:37 cardoe Exp $
+
+EAPI="2"
+
+inherit eutils linux-mod
+
+SRC_URI="mirror://sourceforge/kvm/${P}.tar.bz2"
+
+DESCRIPTION="Kernel-based Virtual Machine kernel modules"
+HOMEPAGE="http://www.linux-kvm.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ linux_config_exists || die "Your kernel sources are unconfigured"
+
+ if ! linux_chkconfig_present KVM; then
+ eerror "KVM now needs CONFIG_KVM built into your kernel, even"
+ eerror "if you're using the external modules from this package."
+ eerror "Please enable KVM support in your kernel, found at:"
+ eerror
+ eerror " Virtualization"
+ eerror " Kernel-based Virtual Machine (KVM) support"
+ eerror
+ die "KVM support not detected!"
+ fi
+ BUILD_TARGETS="all"
+ MODULE_NAMES="kvm(kernel/arch/x86/kvm/:${S}:${S}/x86)"
+ MODULE_NAMES="${MODULE_NAMES} kvm-intel(kernel/arch/x86/kvm/:${S}:${S}/x86)"
+ MODULE_NAMES="${MODULE_NAMES} kvm-amd(kernel/arch/x86/kvm/:${S}:${S}/x86)"
+}
+
+src_configure() {
+ local conf_opts
+
+ conf_opts="--kerneldir=$KV_DIR"
+
+ if has_multilib_profile && [[ "${DEFAULT_ABI}" == "x86" ]] ; then
+ conf_opts="$conf_opts --arch=x86"
+ fi
+
+ ./configure ${conf_opts} || die "configure failed"
+}
+
+src_compile() {
+ linux-mod_src_compile
+}
+
+src_install() {
+ linux-mod_src_install
+}
+
+pkg_preinst() {
+ find /lib/modules/${KV_FULL} -name 'kvm*.ko' -type f -delete
+
+ linux-mod_pkg_preinst
+}