summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-04-20 03:16:02 +0000
committerMike Frysinger <vapier@gentoo.org>2006-04-20 03:16:02 +0000
commit26f5c815be807b253bcf6167fb18b6b9516c9d36 (patch)
tree5e42b5c80a3cb97c3bdbaec4efa48f7a5c55f98a
parentBump to latest test version from upstream. (diff)
downloadgentoo-2-26f5c815be807b253bcf6167fb18b6b9516c9d36.tar.gz
gentoo-2-26f5c815be807b253bcf6167fb18b6b9516c9d36.tar.bz2
gentoo-2-26f5c815be807b253bcf6167fb18b6b9516c9d36.zip
New initscript by Radek Podgorny #128918.
(Portage version: 2.1_pre9)
-rw-r--r--sys-process/runit/ChangeLog6
-rwxr-xr-xsys-process/runit/files/3-1.414
-rw-r--r--sys-process/runit/runit-1.4.1.ebuild5
3 files changed, 22 insertions, 3 deletions
diff --git a/sys-process/runit/ChangeLog b/sys-process/runit/ChangeLog
index e54cf012dbe7..343693e445b6 100644
--- a/sys-process/runit/ChangeLog
+++ b/sys-process/runit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-process/runit
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/runit/ChangeLog,v 1.8 2006/03/29 00:42:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/runit/ChangeLog,v 1.9 2006/04/20 03:16:02 vapier Exp $
+
+ 20 Apr 2006; Mike Frysinger <vapier@gentoo.org> +files/3-1.4,
+ runit-1.4.1.ebuild:
+ New initscript by Radek Podgorny #128918.
*runit-1.4.1 (29 Mar 2006)
diff --git a/sys-process/runit/files/3-1.4 b/sys-process/runit/files/3-1.4
new file mode 100755
index 000000000000..f143f5f46011
--- /dev/null
+++ b/sys-process/runit/files/3-1.4
@@ -0,0 +1,14 @@
+#!/bin/sh
+exec >/dev/console 2>&1
+PATH=/sbin:/usr/sbin:/bin:/usr/bin
+
+echo 'Waiting for getties to stop...'
+sv shutdown -w 10 /var/service/getty-*
+
+echo 'Waiting for services to stop...'
+sv shutdown -w 300 /var/service/*
+
+echo 'Shutdown...'
+test -x /etc/runit/reboot && LAST=6 || LAST=0
+test -x /etc/runit/reboot && RC=reboot || RC=shutdown
+RUNLEVEL=$LAST /sbin/rc $RC
diff --git a/sys-process/runit/runit-1.4.1.ebuild b/sys-process/runit/runit-1.4.1.ebuild
index dd88f45c3f8e..8a1717818e96 100644
--- a/sys-process/runit/runit-1.4.1.ebuild
+++ b/sys-process/runit/runit-1.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/runit/runit-1.4.1.ebuild,v 1.1 2006/03/29 00:42:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/runit/runit-1.4.1.ebuild,v 1.2 2006/04/20 03:16:02 vapier Exp $
inherit toolchain-funcs flag-o-matic
@@ -51,7 +51,8 @@ src_install() {
doman man/*.[18]
exeinto /etc/runit
- doexe "${FILESDIR}"/{1,2,3,ctrlaltdel} || die
+ doexe "${FILESDIR}"/{1,2,ctrlaltdel} || die
+ newexe "${FILESDIR}"/3-1.4 3 || die
for tty in tty1 tty2 tty3 tty4 tty5 tty6; do
exeinto /etc/runit/runsvdir/all/getty-$tty/
for script in run finish; do