summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-06-28 07:52:26 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-06-28 07:52:26 +0000
commit229157e34601e5afee112f6df2380d95dce6d76a (patch)
treecc47a0a2379b05dd7260409c254cd5ca83589301
parentBump (diff)
downloadgentoo-2-229157e34601e5afee112f6df2380d95dce6d76a.tar.gz
gentoo-2-229157e34601e5afee112f6df2380d95dce6d76a.tar.bz2
gentoo-2-229157e34601e5afee112f6df2380d95dce6d76a.zip
Bump
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
-rw-r--r--dev-python/webpy/ChangeLog8
-rw-r--r--dev-python/webpy/webpy-0.37.ebuild41
2 files changed, 47 insertions, 2 deletions
diff --git a/dev-python/webpy/ChangeLog b/dev-python/webpy/ChangeLog
index 172412097540..334792b806c4 100644
--- a/dev-python/webpy/ChangeLog
+++ b/dev-python/webpy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/webpy
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webpy/ChangeLog,v 1.24 2012/02/24 15:21:11 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webpy/ChangeLog,v 1.25 2012/06/28 07:52:26 patrick Exp $
+
+*webpy-0.37 (28 Jun 2012)
+
+ 28 Jun 2012; Patrick Lauer <patrick@gentoo.org> +webpy-0.37.ebuild:
+ Bump
24 Feb 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> webpy-0.36.ebuild:
x86 stable wrt bug #400341
@@ -91,4 +96,3 @@
19 Jan 2007; <wrobel@gentoo.org> +metadata.xml, +webpy-0.2.ebuild:
Added web.py-0.2 to the tree.
-
diff --git a/dev-python/webpy/webpy-0.37.ebuild b/dev-python/webpy/webpy-0.37.ebuild
new file mode 100644
index 000000000000..01bba8783363
--- /dev/null
+++ b/dev-python/webpy/webpy-0.37.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webpy/webpy-0.37.ebuild,v 1.1 2012/06/28 07:52:26 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-*"
+
+inherit distutils
+
+MY_PN="web.py"
+
+DESCRIPTION="A small and simple web framework for Python"
+HOMEPAGE="http://www.webpy.org http://pypi.python.org/pypi/web.py"
+SRC_URI="http://www.webpy.org/static/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/web.py-${PV}"
+
+PYTHON_MODNAME="web"
+
+src_test() {
+ testing() {
+ local return_status="0" test tests="db http net template utils"
+ for test in ${tests}; do
+ echo "Running doctests in ${test}.py..."
+ "$(PYTHON)" web/${test}.py || return_status="$?"
+ done
+
+ return "${return_status}"
+ }
+ python_execute_function testing
+}