summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-08-17 20:30:54 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-08-17 20:30:54 +0000
commit1ca50d300cd113e558b5c581f532c3c55db3eb7b (patch)
treed75e1cd9e7d759b8cfdfaaccdd13e0636c031b79
parentNow even modify device-mapper.rules to be sure to keep the file, else unmerge... (diff)
downloadgentoo-2-1ca50d300cd113e558b5c581f532c3c55db3eb7b.tar.gz
gentoo-2-1ca50d300cd113e558b5c581f532c3c55db3eb7b.tar.bz2
gentoo-2-1ca50d300cd113e558b5c581f532c3c55db3eb7b.zip
Version bump as per bug 187869.
(Portage version: 2.1.3.5)
-rw-r--r--app-text/hunspell/ChangeLog8
-rw-r--r--app-text/hunspell/files/digest-hunspell-1.1.93
-rw-r--r--app-text/hunspell/hunspell-1.1.9.ebuild78
3 files changed, 88 insertions, 1 deletions
diff --git a/app-text/hunspell/ChangeLog b/app-text/hunspell/ChangeLog
index 41770399b77c..60f68acf81e5 100644
--- a/app-text/hunspell/ChangeLog
+++ b/app-text/hunspell/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/hunspell
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/hunspell/ChangeLog,v 1.26 2007/05/24 09:43:59 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/hunspell/ChangeLog,v 1.27 2007/08/17 20:30:54 philantrop Exp $
+
+*hunspell-1.1.9 (17 Aug 2007)
+
+ 17 Aug 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +hunspell-1.1.9.ebuild:
+ Version bump as per bug 187869.
21 May 2007; Kevin F. Quinn <kevquinn@gentoo.org> hunspell-1.1.5.ebuild:
Yet more brokenness in the install (bug #179285)
diff --git a/app-text/hunspell/files/digest-hunspell-1.1.9 b/app-text/hunspell/files/digest-hunspell-1.1.9
new file mode 100644
index 000000000000..2a12820551ab
--- /dev/null
+++ b/app-text/hunspell/files/digest-hunspell-1.1.9
@@ -0,0 +1,3 @@
+MD5 ff56cf42ebf13dd3b8437194f43c6c7a hunspell-1.1.9.tar.gz 684426
+RMD160 e49782df2ada58762036acc3c904a8ace6b19a0a hunspell-1.1.9.tar.gz 684426
+SHA256 c36ed98189da373f3f24e7be97425454e6706cc3e0d07ff39f8c1bcd6689d543 hunspell-1.1.9.tar.gz 684426
diff --git a/app-text/hunspell/hunspell-1.1.9.ebuild b/app-text/hunspell/hunspell-1.1.9.ebuild
new file mode 100644
index 000000000000..51e99afc700f
--- /dev/null
+++ b/app-text/hunspell/hunspell-1.1.9.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/hunspell/hunspell-1.1.9.ebuild,v 1.1 2007/08/17 20:30:54 philantrop Exp $
+
+inherit eutils multilib autotools
+
+DESCRIPTION="Hunspell spell checker - an improved replacement for myspell in OOo."
+SUBREL=""
+SRC_URI="mirror://sourceforge/${PN}/${P}${SUBREL}.tar.gz"
+HOMEPAGE="http://hunspell.sourceforge.net/"
+
+SLOT="0"
+LICENSE="MPL-1.1 GPL-2 LGPL-2.1"
+IUSE="ncurses readline"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="readline? ( sys-libs/readline )
+ ncurses? ( sys-libs/ncurses )
+ sys-devel/gettext"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e 's:tail +:tail -n +:' ${S}/tests/test.sh ||\
+ die "Failed to fix-up tail for POSIX compliance"
+ # Upstream package creates executables 'example', 'munch'
+ # and 'unmunch' which are too generic to be placed in
+ # /usr/bin - this patch prefixes them with 'hunspell-'.
+ # It modifies a Makefile.am file, hence autoreconf.
+ epatch ${FILESDIR}/hunspell-1.1.5-renameexes.patch
+ # Would do eautoreconf - but until bug #142787 is fixed, eautoreconf
+ # isn't enough.
+ libtoolize --copy --force
+ autoreconf -f
+}
+
+src_compile() {
+ # I wanted to put the include files in /usr/include/hunspell
+ # but this means the openoffice build won't find them.
+ econf \
+ $(use_with readline readline) \
+ $(use_with ncurses ui) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO license.hunspell || die "installing docs failed"
+ # hunspell is derived from myspell
+ dodoc AUTHORS.myspell README.myspell license.myspell || die "installing myspell docs failed"
+
+ # Upstream install has a few problems - rather than try to figure out
+ # what's broken in the build system, just fix things up manually.
+
+ # These are included by hunspell.hxx, but aren't installed by the install
+ # script.
+ insinto /usr/include/hunspell/
+ doins license.myspell license.hunspell config.h
+
+ # These are in the wrong place.
+ mv ${D}/usr/include/munch.h ${D}/usr/include/hunspell/munch.h
+ mv ${D}/usr/include/unmunch.h ${D}/usr/include/hunspell/unmunch.h
+
+ # Libraries include the version in their name, so make a sensible
+ # default symlink. They should probably be libhunspell.so.1.1 etc.
+ dodir /usr/$(get_libdir)
+ cd ${D}/usr/$(get_libdir)
+ ln -s libhunspell-1.1.so.0.0.0 libhunspell.so
+}
+
+pkg_postinst() {
+ elog "To use this package you will also need a dictionary."
+ elog "Hunspell uses myspell format dictionaries; find them"
+ elog "in the app-dicts category as myspell-<LANG>."
+}