summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-24 15:01:35 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-24 15:01:35 +0000
commit182ad8d070ec69cd592cd003efad59a7d1a0a816 (patch)
treee7d535d74e8bb95cc12074256f2630a9bbef05ed
parentVersion bump (but not finished yet). (diff)
downloadgentoo-2-182ad8d070ec69cd592cd003efad59a7d1a0a816.tar.gz
gentoo-2-182ad8d070ec69cd592cd003efad59a7d1a0a816.tar.bz2
gentoo-2-182ad8d070ec69cd592cd003efad59a7d1a0a816.zip
Add patch to build with GCC 4.3.
(Portage version: 2.1.5_rc6)
-rw-r--r--games-puzzle/pingus/ChangeLog8
-rw-r--r--games-puzzle/pingus/files/pingus-0.7.2+gcc-4.3.patch12
-rw-r--r--games-puzzle/pingus/pingus-0.7.2.ebuild5
3 files changed, 21 insertions, 4 deletions
diff --git a/games-puzzle/pingus/ChangeLog b/games-puzzle/pingus/ChangeLog
index 9f1ad3be43cd..9a24e20ccca7 100644
--- a/games-puzzle/pingus/ChangeLog
+++ b/games-puzzle/pingus/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/pingus
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/ChangeLog,v 1.16 2007/11/01 04:26:48 mr_bones_ Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/ChangeLog,v 1.17 2008/04/24 15:01:34 flameeyes Exp $
+
+ 24 Apr 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +files/pingus-0.7.2+gcc-4.3.patch, pingus-0.7.2.ebuild:
+ Add patch to build with GCC 4.3.
*pingus-0.7.2 (01 Nov 2007)
diff --git a/games-puzzle/pingus/files/pingus-0.7.2+gcc-4.3.patch b/games-puzzle/pingus/files/pingus-0.7.2+gcc-4.3.patch
new file mode 100644
index 000000000000..69e6f49fcaee
--- /dev/null
+++ b/games-puzzle/pingus/files/pingus-0.7.2+gcc-4.3.patch
@@ -0,0 +1,12 @@
+Index: pingus-0.7.2/src/input/evdev_device.cpp
+===================================================================
+--- pingus-0.7.2.orig/src/input/evdev_device.cpp
++++ pingus-0.7.2/src/input/evdev_device.cpp
+@@ -25,6 +25,7 @@
+ #include <stdexcept>
+ #include <iostream>
+ #include <errno.h>
++#include <cstring>
+
+ #include "evdev_device.hpp"
+
diff --git a/games-puzzle/pingus/pingus-0.7.2.ebuild b/games-puzzle/pingus/pingus-0.7.2.ebuild
index 645f62c03410..f07ffc5c2620 100644
--- a/games-puzzle/pingus/pingus-0.7.2.ebuild
+++ b/games-puzzle/pingus/pingus-0.7.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/pingus-0.7.2.ebuild,v 1.1 2007/11/01 04:26:48 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/pingus-0.7.2.ebuild,v 1.2 2008/04/24 15:01:34 flameeyes Exp $
inherit eutils toolchain-funcs games
@@ -25,6 +25,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-paths.patch
+ epatch "${FILESDIR}/${P}+gcc-4.3.patch"
sed -i \
-e "s:GENTOO_BINDIR:${GAMES_BINDIR}:" \
-e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}:" \