summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-04-10 19:44:04 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-04-10 19:44:04 +0000
commit13f7729c69e02c9c7f788f15ef0ff4f521c3e43a (patch)
tree60829db9230a7edb36650ebff952a3a99c2aea30
parentUpdate Unicode file to version 6.1.0. (diff)
downloadgentoo-2-13f7729c69e02c9c7f788f15ef0ff4f521c3e43a.tar.gz
gentoo-2-13f7729c69e02c9c7f788f15ef0ff4f521c3e43a.tar.bz2
gentoo-2-13f7729c69e02c9c7f788f15ef0ff4f521c3e43a.zip
Version bump wrt security #411493 (Graphics Renderer and XBM Decoder Vulnerabilities). Missing %u in Exec= line to pass links to links -g, see http://standards.freedesktop.org/desktop-entry-spec/desktop-entry-spec-latest.html#exec-variables. USE="deprecated" as first step to get rid of the deprecated links2 compability symlink which is enabled by default for now.
(Portage version: 2.2.0_alpha99/cvs/Linux x86_64)
-rw-r--r--www-client/links/ChangeLog12
-rw-r--r--www-client/links/links-2.6.ebuild119
-rw-r--r--www-client/links/metadata.xml3
3 files changed, 133 insertions, 1 deletions
diff --git a/www-client/links/ChangeLog b/www-client/links/ChangeLog
index 7447a2f8476f..f1e5df298784 100644
--- a/www-client/links/ChangeLog
+++ b/www-client/links/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for www-client/links
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/links/ChangeLog,v 1.165 2012/04/06 20:34:22 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/links/ChangeLog,v 1.166 2012/04/10 19:44:04 ssuominen Exp $
+
+*links-2.6 (10 Apr 2012)
+
+ 10 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> +links-2.6.ebuild,
+ metadata.xml:
+ Version bump wrt security #411493 (Graphics Renderer and XBM Decoder
+ Vulnerabilities). Missing %u in Exec= line to pass links to links -g, see
+ http://standards.freedesktop.org/desktop-entry-spec/desktop-entry-spec-latest
+ .html#exec-variables. USE="deprecated" as first step to get rid of the
+ deprecated links2 compability symlink which is enabled by default for now.
06 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> links-2.5.ebuild:
Only apply x-scheme-handler/https; to MimeType -line of the desktop file when
diff --git a/www-client/links/links-2.6.ebuild b/www-client/links/links-2.6.ebuild
new file mode 100644
index 000000000000..dcdd4086ffbd
--- /dev/null
+++ b/www-client/links/links-2.6.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/links/links-2.6.ebuild,v 1.1 2012/04/10 19:44:04 ssuominen Exp $
+
+EAPI=4
+inherit autotools eutils fdo-mime
+
+DESCRIPTION="A fast and lightweight web browser running in both graphics and text mode"
+HOMEPAGE="http://links.twibright.com/"
+SRC_URI="http://${PN}.twibright.com/download/${P}.tar.bz2
+ mirror://debian/pool/main/${PN:0:1}/${PN}2/${PN}2_2.5-1.debian.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 +deprecated directfb fbcon gpm jpeg livecd lzma ssl suid svga tiff unicode X zlib"
+
+GRAPHICS_DEPEND=">=media-libs/libpng-1.2:0" #75685
+
+RDEPEND=">=sys-libs/ncurses-5.7-r7
+ bzip2? ( app-arch/bzip2 )
+ directfb? ( dev-libs/DirectFB )
+ fbcon? ( ${GRAPHICS_DEPEND} )
+ gpm? ( sys-libs/gpm )
+ jpeg? ( virtual/jpeg )
+ livecd? ( ${GRAPHICS_DEPEND} )
+ lzma? ( app-arch/xz-utils )
+ ssl? ( dev-libs/openssl:0 )
+ svga? (
+ ${GRAPHICS_DEPEND}
+ >=media-libs/svgalib-1.4.3
+ )
+ tiff? ( media-libs/tiff:0 )
+ X? (
+ ${GRAPHICS_DEPEND}
+ x11-libs/libXext
+ )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+GRAPHICS_USE="jpeg gpm"
+
+REQUIRED_USE="fbcon? ( ${GRAPHICS_USE} )
+ livecd? ( ${GRAPHICS_USE} )
+ svga? ( suid )"
+
+DOCS=( AUTHORS BRAILLE_HOWTO ChangeLog KEYS NEWS README SITES )
+
+src_prepare() {
+ epatch "${WORKDIR}"/debian/patches/verify-ssl-certs-510417.diff
+
+ if use unicode; then
+ pushd intl >/dev/null
+ ./gen-intl || die
+ ./synclang || die
+ popd >/dev/null
+ fi
+
+ # error: conditional "am__fastdepCXX" was never defined (for eautoreconf)
+ sed -i -e '/AC_PROG_CXX/s:#::' configure.in || die
+
+ # Upstream configure produced by broken autoconf-2.13. This also fixes
+ # toolchain detection.
+ eautoreconf #131440 and #103483#c23
+}
+
+src_configure() {
+ export ac_cv_lib_gpm_Gpm_Open=$(usex gpm)
+
+ local myconf
+
+ if use X || use fbcon || use directfb || use svga || use livecd; then
+ myconf+=' --enable-graphics'
+ fi
+
+ if use fbcon || use livecd; then
+ myconf+=' --with-fb'
+ else
+ myconf+=' --without-fb'
+ fi
+
+ econf \
+ $(use_with ssl) \
+ $(use_with zlib) \
+ $(use_with bzip2) \
+ $(use_with lzma) \
+ $(use_with svga svgalib) \
+ $(use_with X x) \
+ $(use_with directfb) \
+ $(use_with jpeg libjpeg) \
+ $(use_with tiff libtiff) \
+ ${myconf}
+}
+
+src_install() {
+ default
+
+ if use X; then
+ newicon Links_logo.png links.png
+ make_desktop_entry 'links -g %u' Links links 'Network;WebBrowser'
+ local d="${ED}"/usr/share/applications
+ echo 'MimeType=x-scheme-handler/http;' >> "${d}"/*.desktop
+ use ssl && sed -i -e 's:x-scheme-handler/http;:&x-scheme-handler/https;:' \
+ "${d}"/*.desktop
+ fi
+
+ nonfatal dohtml doc/links_cal/*
+ use deprecated && dosym links /usr/bin/links2
+ use suid && fperms 4755 /usr/bin/links
+}
+
+pkg_postinst() {
+ use X && fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ use X && fdo-mime_desktop_database_update
+}
diff --git a/www-client/links/metadata.xml b/www-client/links/metadata.xml
index 29e773eb58b1..c7d4d84cd646 100644
--- a/www-client/links/metadata.xml
+++ b/www-client/links/metadata.xml
@@ -9,4 +9,7 @@
<email>ssuominen@gentoo.org</email>
<name>Samuli Suominen</name>
</maintainer>
+ <use>
+ <flag name='deprecated'>Install deprecated 'links2 -> links' symlink for compability reasons temporarily</flag>
+ </use>
</pkgmetadata>