summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-11 01:34:14 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-11 01:34:14 +0000
commit0e5cbc3a98a2b462b7b5fee4ac36e5573bfd5bf2 (patch)
tree491e02b546a1d0f34a5f377d41b9206b1925b99f
parentVersion bump #77407 by Michael Cramer. (Manifest recommit) (diff)
downloadgentoo-2-0e5cbc3a98a2b462b7b5fee4ac36e5573bfd5bf2.tar.gz
gentoo-2-0e5cbc3a98a2b462b7b5fee4ac36e5573bfd5bf2.tar.bz2
gentoo-2-0e5cbc3a98a2b462b7b5fee4ac36e5573bfd5bf2.zip
stabilize
-rw-r--r--sys-apps/memtest86/files/digest-memtest86-3.1a1
-rw-r--r--sys-apps/memtest86/files/memtest86-3.1a-test-pic.patch20
-rw-r--r--sys-apps/memtest86/memtest86-3.1a.ebuild78
-rw-r--r--sys-apps/memtest86/memtest86-3.2.ebuild4
4 files changed, 2 insertions, 101 deletions
diff --git a/sys-apps/memtest86/files/digest-memtest86-3.1a b/sys-apps/memtest86/files/digest-memtest86-3.1a
deleted file mode 100644
index f632ca0c636d..000000000000
--- a/sys-apps/memtest86/files/digest-memtest86-3.1a
+++ /dev/null
@@ -1 +0,0 @@
-MD5 6c43d4aba3fdfa135c462a02b3ae5b39 memtest86-3.1a.tar.gz 142729
diff --git a/sys-apps/memtest86/files/memtest86-3.1a-test-pic.patch b/sys-apps/memtest86/files/memtest86-3.1a-test-pic.patch
deleted file mode 100644
index 9c76ef536886..000000000000
--- a/sys-apps/memtest86/files/memtest86-3.1a-test-pic.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- Makefile.orig 2004-11-12 07:52:39.000000000 -0500
-+++ Makefile 2004-11-12 07:52:02.000000000 -0500
-@@ -12,7 +12,7 @@
- #
- # gcc compiler options, these settings should suffice
- #
--CCFLAGS=-Wall -march=i486 -Os -fomit-frame-pointer -fno-builtin -ffreestanding
-+CCFLAGS=-Wall -march=i486 -Os -fomit-frame-pointer -fno-builtin -ffreestanding -fno-stack-protector
-
- AS=as -k
-
-@@ -26,7 +26,7 @@
- $(CC) -S $(CCFLAGS) -fPIC reloc.c
-
- test.o: test.c test.h defs.h config.h
-- $(CC) -c $(CCFLAGS) test.c
-+ $(CC) -c $(CCFLAGS) -fno-PIC test.c
-
- main.o: main.c test.h defs.h
- $(CC) -c $(CCFLAGS) -fPIC main.c
diff --git a/sys-apps/memtest86/memtest86-3.1a.ebuild b/sys-apps/memtest86/memtest86-3.1a.ebuild
deleted file mode 100644
index e7342b2d0c9b..000000000000
--- a/sys-apps/memtest86/memtest86-3.1a.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/memtest86-3.1a.ebuild,v 1.3 2005/01/02 19:15:26 chainsaw Exp $
-
-inherit mount-boot eutils
-
-DESCRIPTION="A stand alone memory test for x86 computers"
-HOMEPAGE="http://www.memtest86.com/"
-SRC_URI="http://www.memtest86.com/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* x86"
-IUSE="serial"
-
-DEPEND="virtual/libc"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- # bug 66630
- epatch ${FILESDIR}/${P}-test-pic.patch
-
- sed -i -e '/DISCARD/d' memtest_shared.lds
-
- if use serial ; then
- sed -i \
- -e 's/#define SERIAL_CONSOLE_DEFAULT 0/#define SERIAL_CONSOLE_DEFAULT 1/' \
- config.h \
- || die
- fi
-}
-
-src_compile() {
- emake || die
-}
-
-src_install() {
- insinto /boot/memtest86
- doins memtest.bin || die
- dodoc README README.build-process
-}
-
-pkg_postinst() {
- einfo
- einfo "memtest.bin has been installed in /boot/memtest86/"
- einfo "You may wish to update your bootloader configs"
- einfo "by adding these lines:"
- einfo " - For grub:"
- einfo " > title=Memtest86"
-
- # a little magic to make users' life as easy as possible ;)
- bootpart=0
- root="(hd0,0)"
- res=`cat /etc/fstab | grep /boot | grep -v "^#" | awk '{print $1}' | grep '/dev/hd[a-z0-9]\+'`
- if [ -n "${res}" ] ; then
- bootpart=1
- else
- res=`cat /etc/fstab | grep -v '^#' | grep -e '/dev/hd[a-z0-9]\+[[:space:]]\+\/[[:space:]]\+' | awk '{print $1}'`
- fi
-
- if [ -n "${res}" ] ; then
- root=`echo ${res} | grep -o '[a-z][0-9]' | tr -t a-z 0123456789 | sed -e 's/\([0-9]\)\([0-9]\)/\1 \2/' | awk '{print "(hd" $1 "," $2-1 ")" }'`
- fi
-
- einfo " > root ${root}"
- if [ "${bootpart}" -eq 1 ] ; then
- einfo " > kernel /memtest86/memtest.bin"
- else
- einfo " > kernel /boot/memtest86/memtest.bin"
- fi
-
- einfo " - For lilo:"
- einfo " > image = /boot/memtest86/memtest.bin"
- einfo " > label = Memtest86"
- einfo
-}
diff --git a/sys-apps/memtest86/memtest86-3.2.ebuild b/sys-apps/memtest86/memtest86-3.2.ebuild
index 0806d8e35a41..15d3c2fa897a 100644
--- a/sys-apps/memtest86/memtest86-3.2.ebuild
+++ b/sys-apps/memtest86/memtest86-3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/memtest86-3.2.ebuild,v 1.1 2005/01/02 19:15:26 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/memtest86-3.2.ebuild,v 1.2 2005/01/11 01:34:14 vapier Exp $
inherit mount-boot eutils
@@ -10,7 +10,7 @@ SRC_URI="http://www.memtest86.com/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="-* ~x86"
+KEYWORDS="-* x86"
IUSE="serial"
DEPEND="virtual/libc"