summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-11-02 22:53:22 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-11-02 22:53:22 +0000
commit0cb7f2955f2a68fe2c488f398a987b0ab8d594c0 (patch)
tree7f9c0e57257822db1a6d59ff9336c46141b5897f
parentWhitespace change. (diff)
downloadgentoo-2-0cb7f2955f2a68fe2c488f398a987b0ab8d594c0.tar.gz
gentoo-2-0cb7f2955f2a68fe2c488f398a987b0ab8d594c0.tar.bz2
gentoo-2-0cb7f2955f2a68fe2c488f398a987b0ab8d594c0.zip
Added license checking.
(Portage version: 2.0.53_rc6)
-rw-r--r--games-rpg/nwn-data/ChangeLog7
-rw-r--r--games-rpg/nwn-data/nwn-data-1.29.ebuild8
2 files changed, 11 insertions, 4 deletions
diff --git a/games-rpg/nwn-data/ChangeLog b/games-rpg/nwn-data/ChangeLog
index 6f2a8dacf749..65d986647c84 100644
--- a/games-rpg/nwn-data/ChangeLog
+++ b/games-rpg/nwn-data/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-rpg/nwn-data
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwn-data/ChangeLog,v 1.5 2005/11/01 20:04:30 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwn-data/ChangeLog,v 1.6 2005/11/02 22:53:22 wolf31o2 Exp $
+
+ 02 Nov 2005; Chris Gianelloni <wolf31o2@gentoo.org> nwn-data-1.29.ebuild:
+ Added license checking.
01 Nov 2005; Chris Gianelloni <wolf31o2@gentoo.org> nwn-data-1.29.ebuild:
Fixed installation when not using USE=nowin.
@@ -20,6 +23,6 @@
+metadata.xml, +nwn-data-1.29.ebuild:
Initial import. Ebuild by me. This is the first ebuild for breaking up
Neverwinter Nights into 2 ebuilds. This ebuild also adds support for
- installing the Shadows of Undrentide and Hourdes of the Underdark expansion
+ installing the Shadows of Undrentide and Hordes of the Underdark expansion
packs from CD using USE=sou and USE=hou respectively.
diff --git a/games-rpg/nwn-data/nwn-data-1.29.ebuild b/games-rpg/nwn-data/nwn-data-1.29.ebuild
index 279865bcdc76..68ec38cb7cdd 100644
--- a/games-rpg/nwn-data/nwn-data-1.29.ebuild
+++ b/games-rpg/nwn-data/nwn-data-1.29.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwn-data/nwn-data-1.29.ebuild,v 1.6 2005/11/01 20:05:34 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwn-data/nwn-data-1.29.ebuild,v 1.7 2005/11/02 22:53:22 wolf31o2 Exp $
inherit eutils games
@@ -34,10 +34,13 @@ RDEPEND="virtual/x11
amd64? ( app-emulation/emul-linux-x86-baselibs )"
S=${WORKDIR}/nwn
+
+GAMES_LICENSE_CHECK="yes"
dir=${GAMES_PREFIX_OPT}/nwn
Ddir=${D}/${dir}
pkg_setup() {
+ games_pkg_setup
if use sou && use hou
then
echo "You will need the SoU and HoU CDs for this installation."
@@ -64,7 +67,8 @@ src_unpack() {
rm -rf override/*
# the following is so ugly, please pretend it doesnt exist
declare -a Aarray=(${A})
- use nowin && if [ "${#Aarray[*]}" == "3" ]; then
+ use nowin && if [ "${#Aarray[*]}" == "3" ]
+ then
unpack ${Aarray[1]}
fi
if use sou