summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-04-29 16:16:54 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-04-29 16:16:54 +0000
commit0c4d41c11c393c83880803a7c7a3ac08f5e8761e (patch)
tree111a4c9bf19503b735a3b4c2282d78bb598d42f7
parentremove old ebuild (diff)
downloadgentoo-2-0c4d41c11c393c83880803a7c7a3ac08f5e8761e.tar.gz
gentoo-2-0c4d41c11c393c83880803a7c7a3ac08f5e8761e.tar.bz2
gentoo-2-0c4d41c11c393c83880803a7c7a3ac08f5e8761e.zip
added patch to fix compilation with the gcc3.4.x. thanks to Alex Rostovtsev <tetromino@gmail.com> for the contribution. fixes #90561. also added ~amd64 to KEYWORDS and did some cleanup.
(Portage version: 2.0.51.20-r5)
-rw-r--r--media-sound/synaesthesia/ChangeLog9
-rw-r--r--media-sound/synaesthesia/Manifest17
-rw-r--r--media-sound/synaesthesia/files/digest-synaesthesia-2.11
-rw-r--r--media-sound/synaesthesia/files/synaesthesia-2.2-gcc3.4.patch29
-rw-r--r--media-sound/synaesthesia/synaesthesia-2.1.ebuild30
-rw-r--r--media-sound/synaesthesia/synaesthesia-2.2.ebuild9
6 files changed, 47 insertions, 48 deletions
diff --git a/media-sound/synaesthesia/ChangeLog b/media-sound/synaesthesia/ChangeLog
index 5b3df6dfd41f..64c4346563c5 100644
--- a/media-sound/synaesthesia/ChangeLog
+++ b/media-sound/synaesthesia/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/synaesthesia
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/synaesthesia/ChangeLog,v 1.8 2005/04/27 07:55:56 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/synaesthesia/ChangeLog,v 1.9 2005/04/29 16:16:54 luckyduck Exp $
+
+ 29 Apr 2005; Jan Brinkmann <luckyduck@gentoo.org>
+ +files/synaesthesia-2.2-gcc3.4.patch, -synaesthesia-2.1.ebuild,
+ synaesthesia-2.2.ebuild:
+ added patch to fix compilation with the gcc3.4.x. thanks to Alex Rostovtsev
+ <tetromino@gmail.com> for the contribution. fixes #90561. also added ~amd64
+ to KEYWORDS and did some cleanup.
27 Apr 2005; Jeremy Huddleston <eradicator@gentoo.org>
synaesthesia-2.1.ebuild, synaesthesia-2.2.ebuild:
diff --git a/media-sound/synaesthesia/Manifest b/media-sound/synaesthesia/Manifest
index e9690a779376..c064a5464ae1 100644
--- a/media-sound/synaesthesia/Manifest
+++ b/media-sound/synaesthesia/Manifest
@@ -1,16 +1,5 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 ae4f4e52f618a5cba56e12dc64d898c1 ChangeLog 1095
+MD5 b7966d5ccb095fd3f221c9a9f22e7c89 synaesthesia-2.2.ebuild 914
+MD5 ec6634ea5419c8c271e61dc981a0f698 ChangeLog 1433
MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
-MD5 1a1a838bd0246cf5800cac7091b6275f synaesthesia-2.1.ebuild 830
-MD5 f47c6e920796f7410a3edeff5f6108a6 synaesthesia-2.2.ebuild 851
-MD5 a7c23dfe64d4d66b7748b6948a9ac8e8 files/digest-synaesthesia-2.1 68
MD5 8406064a7b709f1db47d6ae809de7820 files/digest-synaesthesia-2.2 68
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCb0WeArHZZzCEUG0RAufFAJ9TlB5NG5sG9SMa7h4g/MbmPwMcjQCeISlP
-LXCkHl6f481nm8/mYPwXngY=
-=T8f3
------END PGP SIGNATURE-----
+MD5 022bf47ca583065960cdf36ef20e94b3 files/synaesthesia-2.2-gcc3.4.patch 900
diff --git a/media-sound/synaesthesia/files/digest-synaesthesia-2.1 b/media-sound/synaesthesia/files/digest-synaesthesia-2.1
deleted file mode 100644
index 22b95c9cb7a4..000000000000
--- a/media-sound/synaesthesia/files/digest-synaesthesia-2.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 5bc166deb369a3c71efd61e1ad5e5475 synaesthesia-2.1.tar.gz 129209
diff --git a/media-sound/synaesthesia/files/synaesthesia-2.2-gcc3.4.patch b/media-sound/synaesthesia/files/synaesthesia-2.2-gcc3.4.patch
new file mode 100644
index 000000000000..a981154d9187
--- /dev/null
+++ b/media-sound/synaesthesia/files/synaesthesia-2.2-gcc3.4.patch
@@ -0,0 +1,29 @@
+diff -ru synaesthesia-2.2.orig/polygon.h synaesthesia-2.2/polygon.h
+--- synaesthesia-2.2.orig/polygon.h 2005-04-26 19:37:57.000000000 -0400
++++ synaesthesia-2.2/polygon.h 2005-04-26 19:52:42.000000000 -0400
+@@ -28,8 +28,8 @@
+ #define super (1<<superSampleShift)
+ void apply(Pixel *dest) {
+ Pixel sum=0;
+- int count = width*height;
+- Pixel *src = data;
++ int count = this->width*this->height;
++ Pixel *src = this->data;
+ while(count--) {
+ sum += *(src++);
+ if (sum)
+@@ -40,10 +40,10 @@
+
+ void add(Pixel color,int x,int y) {
+ if (y < 0) return;
+- if (y >= height) return;
++ if (y >= this->height) return;
+ if (x < 0) x = 0;
+- if (x > width) x = width;
+- data[x+y*width] += color;
++ if (x > this->width) x = this->width;
++ this->data[x+y*this->width] += color;
+ }
+
+ /* Color is char[layers] */
+Only in synaesthesia-2.2: .polygon.h.swp
diff --git a/media-sound/synaesthesia/synaesthesia-2.1.ebuild b/media-sound/synaesthesia/synaesthesia-2.1.ebuild
deleted file mode 100644
index 7b3300072f7b..000000000000
--- a/media-sound/synaesthesia/synaesthesia-2.1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/synaesthesia/synaesthesia-2.1.ebuild,v 1.14 2005/04/27 07:55:56 eradicator Exp $
-
-IUSE="sdl svga esd alsa"
-
-DESCRIPTION="a program that represents music graphically in real time as coruscating field of fog and glowing lines"
-HOMEPAGE="http://www.logarithmic.net/pfh/synaesthesia"
-SRC_URI="http://www.logarithmic.net/pfh-files/synaesthesia/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86"
-
-DEPEND="virtual/x11
- esd? ( >=media-sound/esound-0.2.22 )
- sdl? ( >=media-libs/libsdl-1.2.0 )
- alsa? ( >=media-libs/alsa-lib-0.5.10 )
- svga? ( >=media-libs/svgalib-1.4.3 )"
-
-src_compile() {
- econf || die
- emake || die
-}
-
-
-src_install() {
- dobin synaesthesia
- dodoc README COPYING
-}
diff --git a/media-sound/synaesthesia/synaesthesia-2.2.ebuild b/media-sound/synaesthesia/synaesthesia-2.2.ebuild
index e3282eca486d..f3788b919dcb 100644
--- a/media-sound/synaesthesia/synaesthesia-2.2.ebuild
+++ b/media-sound/synaesthesia/synaesthesia-2.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/synaesthesia/synaesthesia-2.2.ebuild,v 1.6 2005/04/27 07:55:56 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/synaesthesia/synaesthesia-2.2.ebuild,v 1.7 2005/04/29 16:16:54 luckyduck Exp $
+
+inherit eutils
DESCRIPTION="a nice graphical accompaniment to music"
HOMEPAGE="http://www.logarithmic.net/pfh/synaesthesia"
@@ -8,7 +10,7 @@ SRC_URI="http://www.logarithmic.net/pfh-files/synaesthesia/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86"
+KEYWORDS="x86 ~amd64"
IUSE="sdl svga esd"
DEPEND="virtual/x11
@@ -19,11 +21,14 @@ DEPEND="virtual/x11
src_unpack() {
unpack ${A}
cd ${S}
+
sed -i \
-e "/CFLAGS=/s:-O4:${CFLAGS}:" \
-e "/CXXFLAGS=/s:-O4:${CXXFLAGS}:" \
configure
sed -i 's:void inline:inline void:' syna.h
+
+ epatch ${FILESDIR}/${P}-gcc3.4.patch
}
src_install() {