summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2005-02-18 23:22:31 +0000
committerHeinrich Wendel <lanius@gentoo.org>2005-02-18 23:22:31 +0000
commit01055e3955b7869a241719817a4456f18ed7693d (patch)
treea3a55dd621f66c1cea6a042629b8dc10bf803150
parentstable on amd64 (diff)
downloadgentoo-2-01055e3955b7869a241719817a4456f18ed7693d.tar.gz
gentoo-2-01055e3955b7869a241719817a4456f18ed7693d.tar.bz2
gentoo-2-01055e3955b7869a241719817a4456f18ed7693d.zip
fix libdir
(Portage version: 2.0.51-r15)
-rwxr-xr-xx11-libs/motif-config/files/motif-config-0.125
-rw-r--r--x11-libs/motif-config/motif-config-0.1.ebuild3
2 files changed, 9 insertions, 19 deletions
diff --git a/x11-libs/motif-config/files/motif-config-0.1 b/x11-libs/motif-config/files/motif-config-0.1
index 124abb72e212..b0f46dccb217 100755
--- a/x11-libs/motif-config/files/motif-config-0.1
+++ b/x11-libs/motif-config/files/motif-config-0.1
@@ -10,18 +10,7 @@ source /etc/init.d/functions.sh || {
}
umask 022
-# functions.sh returns a wrong libdir on multilib architectures
-#source /etc/make.profile/make.defaults || {
-# echo "$0: Could not source /etc/make.profile/make.defaults!"
-# exit 1
-#}
-#get_libdir() {
-# libdirvar="LIBDIR_${DEFAULT_ABI}"
-# echo ${!libdirvar}
-#}
-
-LIBDIR=$(get_libdir)
-PROFILE_PATH=/usr/$LIBDIR/motif
+PROFILE_PATH=/usr/@@LIBDIR@@/motif
CONFIG_FILE=${PROFILE_PATH}/current
usage() {
@@ -68,8 +57,8 @@ _activate_profile() {
new=${1}
# libs
- for file in `ls /usr/$LIBDIR/${new}/`; do
- ln -s /usr/$LIBDIR/${new}/${file} /usr/$LIBDIR/${file}
+ for file in `ls /usr/@@LIBDIR@@/${new}/`; do
+ ln -s /usr/@@LIBDIR@@/${new}/${file} /usr/@@LIBDIR@@/${file}
done
# includes
for file in `ls /usr/include/${new}/`; do
@@ -102,8 +91,8 @@ _deactivate_profile() {
fi
# libs
- for file in `ls /usr/$LIBDIR/${current}/`; do
- rm -f /usr/$LIBDIR/${file}
+ for file in `ls /usr/@@LIBDIR@@/${current}/`; do
+ rm -f /usr/@@LIBDIR@@/${file}
done
# includes
for file in `ls /usr/include/${current}/`; do
@@ -181,7 +170,7 @@ get_lib_path() {
if [ $? -eq 1 ]; then
eerror "$0: No such profile: $profile"
else
- echo "/usr/$LIBDIR/${name}/"
+ echo "/usr/@@LIBDIR@@/${name}/"
exit 0
fi
}
@@ -226,7 +215,7 @@ get_libs() {
if [ $? -eq 1 ]; then
eerror "$0: No such profile: $profile"
else
- echo "-L/usr/$LIBDIR/${name}/"
+ echo "-L/usr/@@LIBDIR@@/${name}/"
exit 0
fi
}
diff --git a/x11-libs/motif-config/motif-config-0.1.ebuild b/x11-libs/motif-config/motif-config-0.1.ebuild
index de0f308f2cc3..0cbb740c0679 100644
--- a/x11-libs/motif-config/motif-config-0.1.ebuild
+++ b/x11-libs/motif-config/motif-config-0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/motif-config/motif-config-0.1.ebuild,v 1.4 2005/02/16 14:02:24 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/motif-config/motif-config-0.1.ebuild,v 1.5 2005/02/18 23:22:31 lanius Exp $
inherit multilib
@@ -28,6 +28,7 @@ src_compile() {
src_install () {
exeinto /usr/bin
newexe ${FILESDIR}/motif-config-0.1 motif-config
+ dosed "s:@@LIBDIR@@:$(get_libdir):" /usr/bin/motif-config
# for profile
dodir /usr/$(get_libdir)/motif