summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-06-01 23:08:02 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-06-01 23:08:02 +0000
commit1340b5c408e7cff5e080f6743352235c006a7b24 (patch)
treefe10a1c1ccc97a9a13ce901b5dec9a7350bbb538 /src
parentremoved redundant incorrect paragraphs by request of remi on IRC (diff)
downloadgentoo-1340b5c408e7cff5e080f6743352235c006a7b24.tar.gz
gentoo-1340b5c408e7cff5e080f6743352235c006a7b24.tar.bz2
gentoo-1340b5c408e7cff5e080f6743352235c006a7b24.zip
Add various patches: gcc 4.3 and endianness typo ported from debian by Peter Alfredsen <loki_val@gentoo.org>, bug #219438, another one to shut up autofoo warnings and a last one to fix build with new libtools
Diffstat (limited to 'src')
-rw-r--r--src/patchsets/rezound/0.12.3_beta/080_all_endian_typo.patch11
-rw-r--r--src/patchsets/rezound/0.12.3_beta/090_all_gcc_4.3.patch451
-rw-r--r--src/patchsets/rezound/0.12.3_beta/100_all_reconf_warnings.patch37
-rw-r--r--src/patchsets/rezound/0.12.3_beta/110_all_libtool.patch43
-rw-r--r--src/patchsets/rezound/0.12.3_beta/series4
5 files changed, 546 insertions, 0 deletions
diff --git a/src/patchsets/rezound/0.12.3_beta/080_all_endian_typo.patch b/src/patchsets/rezound/0.12.3_beta/080_all_endian_typo.patch
new file mode 100644
index 0000000000..4e33af0670
--- /dev/null
+++ b/src/patchsets/rezound/0.12.3_beta/080_all_endian_typo.patch
@@ -0,0 +1,11 @@
+--- rezound-0.12.2beta.orig/src/backend/COSSSoundPlayer.cpp 2007-01-28 13:39:58.039273892 +0100
++++ rezound-0.12.2beta/src/backend/COSSSoundPlayer.cpp 2007-01-28 13:40:04.931273892 +0100
+@@ -83,7 +83,7 @@
+ int sampleSize=0;
+ string sSampleFormat="none";
+ #warning need to change this to try several formats for a supported implementation because float is being reduced to 16bit right now
+-#ifndef WORDS_BIGENDIN
++#ifndef WORDS_BIGENDIAN
+ // little endian platform
+ #if defined(SAMPLE_TYPE_S16)
+ sampleFormat=AFMT_S16_LE;
diff --git a/src/patchsets/rezound/0.12.3_beta/090_all_gcc_4.3.patch b/src/patchsets/rezound/0.12.3_beta/090_all_gcc_4.3.patch
new file mode 100644
index 0000000000..e6434bd294
--- /dev/null
+++ b/src/patchsets/rezound/0.12.3_beta/090_all_gcc_4.3.patch
@@ -0,0 +1,451 @@
+diff -Naur rezound-0.12.3beta~/src/backend/ALFO.h rezound-0.12.3beta/src/backend/ALFO.h
+--- rezound-0.12.3beta~/src/backend/ALFO.h 2008-03-18 22:20:36.000000000 -0400
++++ rezound-0.12.3beta/src/backend/ALFO.h 2008-03-18 22:30:06.000000000 -0400
+@@ -21,6 +21,16 @@
+ #ifndef __ALFO_H__
+ #define __ALFO_H__
+
++#ifndef GCC_VERSION
++#define GCC_VERSION (__GNUC__ * 100 + __GNUC_MINOR__)
++#endif
++
++#if GCC_VERSION >= 403
++# define STATIC
++#else
++# define STATIC static
++#endif
++
+ #include "../../config/common.h"
+
+ #include "CSound_defs.h"
+@@ -94,7 +104,7 @@
+ };
+
+ #include <CNestedDataFile/anytype.h>
+-template<> static const CLFODescription string_to_anytype<CLFODescription>(const string &str,CLFODescription &ret)
++template<> STATIC const CLFODescription string_to_anytype<CLFODescription>(const string &str,CLFODescription &ret)
+ {
+ CNestedDataFile f;
+ f.parseString(s2at::remove_surrounding_quotes(str));
+@@ -102,7 +112,7 @@
+ return ret;
+ }
+
+-template<> static const string anytype_to_string<CLFODescription>(const CLFODescription &any)
++template<> STATIC const string anytype_to_string<CLFODescription>(const CLFODescription &any)
+ {
+ CNestedDataFile f; any.writeToFile(&f,"");
+ return "\""+s2at::escape_chars(istring(f.asString()).searchAndReplace("\n"," ",true))+"\"";
+diff -Naur rezound-0.12.3beta~/src/backend/CGraphParamValueNode.h rezound-0.12.3beta/src/backend/CGraphParamValueNode.h
+--- rezound-0.12.3beta~/src/backend/CGraphParamValueNode.h 2008-03-18 22:20:36.000000000 -0400
++++ rezound-0.12.3beta/src/backend/CGraphParamValueNode.h 2008-03-18 22:33:30.000000000 -0400
+@@ -21,6 +21,15 @@
+ #ifndef __CGraphParamValueNode_H__
+ #define __CGraphParamValueNode_H__
+
++#ifndef GCC_VERSION
++#define GCC_VERSION (__GNUC__ * 100 + __GNUC_MINOR__)
++#endif
++
++#if GCC_VERSION >= 403
++# define STATIC
++#else
++# define STATIC static
++#endif
+
+ #include "../../config/common.h"
+
+@@ -45,7 +54,7 @@
+ typedef vector<CGraphParamValueNode> CGraphParamValueNodeList;
+
+ #include <CNestedDataFile/anytype.h>
+-template<> static const CGraphParamValueNode string_to_anytype<CGraphParamValueNode>(const string &_str,CGraphParamValueNode &ret)
++template<> STATIC const CGraphParamValueNode string_to_anytype<CGraphParamValueNode>(const string &_str,CGraphParamValueNode &ret)
+ {
+ const string str=s2at::remove_surrounding_quotes(_str);
+ const size_t pos=str.find("|");
+@@ -56,7 +65,7 @@
+ return ret;
+ }
+
+-template<> static const string anytype_to_string<CGraphParamValueNode>(const CGraphParamValueNode &any)
++template<> STATIC const string anytype_to_string<CGraphParamValueNode>(const CGraphParamValueNode &any)
+ {
+ return "\""+anytype_to_string<double>(any.x)+"|"+anytype_to_string<double>(any.y)+"\"";
+ }
+diff -Naur rezound-0.12.3beta~/src/backend/CPluginMapping.h rezound-0.12.3beta/src/backend/CPluginMapping.h
+--- rezound-0.12.3beta~/src/backend/CPluginMapping.h 2008-03-18 22:20:36.000000000 -0400
++++ rezound-0.12.3beta/src/backend/CPluginMapping.h 2008-03-18 22:30:22.000000000 -0400
+@@ -21,6 +21,16 @@
+ #ifndef __CPluginMapping_H__
+ #define __CPluginMapping_H__
+
++#ifndef GCC_VERSION
++#define GCC_VERSION (__GNUC__ * 100 + __GNUC_MINOR__)
++#endif
++
++#if GCC_VERSION >= 403
++# define STATIC
++#else
++# define STATIC static
++#endif
++
+ #include "../../config/common.h"
+
+ #include <string>
+@@ -215,7 +225,7 @@
+ };
+
+ #include <CNestedDataFile/anytype.h>
+-template<> static const CPluginMapping string_to_anytype<CPluginMapping>(const string &str,CPluginMapping &ret)
++template<> STATIC const CPluginMapping string_to_anytype<CPluginMapping>(const string &str,CPluginMapping &ret)
+ {
+ CNestedDataFile f;
+ f.parseString(s2at::remove_surrounding_quotes(str));
+@@ -223,7 +233,7 @@
+ return ret;
+ }
+
+-template<> static const string anytype_to_string<CPluginMapping>(const CPluginMapping &any)
++template<> STATIC const string anytype_to_string<CPluginMapping>(const CPluginMapping &any)
+ {
+ CNestedDataFile f;
+ any.writeToFile(&f,"");
+diff -Naur rezound-0.12.3beta~/src/backend/CSound_defs.h rezound-0.12.3beta/src/backend/CSound_defs.h
+--- rezound-0.12.3beta~/src/backend/CSound_defs.h 2008-03-18 22:20:36.000000000 -0400
++++ rezound-0.12.3beta/src/backend/CSound_defs.h 2008-03-18 22:31:38.000000000 -0400
+@@ -21,6 +21,16 @@
+ #ifndef __CSound_defs_H__
+ #define __CSound_defs_H__
+
++#ifndef GCC_VERSION
++#define GCC_VERSION (__GNUC__ * 100 + __GNUC_MINOR__)
++#endif
++
++#if GCC_VERSION >= 403
++# define STATIC
++#else
++# define STATIC static
++#endif
++
+ #include "../../config/common.h"
+
+ class CSound;
+@@ -161,10 +171,10 @@
+
+ // int8_t -> ...
+ // int8_t -> int8_t
+- template<> static inline const int8_t convert_sample<int8_t,int8_t>(const register int8_t sample) { return sample; }
++ template<> STATIC inline const int8_t convert_sample<int8_t,int8_t>(const register int8_t sample) { return sample; }
+
+ // int8_t -> int16_t
+- template<> static inline const int16_t convert_sample<int8_t,int16_t>(const register int8_t sample) { return sample*256; }
++ template<> STATIC inline const int16_t convert_sample<int8_t,int16_t>(const register int8_t sample) { return sample*256; }
+
+ // int8_t -> int24_t
+ //template<> static inline const int24_t convert_sample<int8_t,int24_t>(const register int8_t sample) { }
+@@ -173,7 +183,7 @@
+ //template<> static inline const int32_t convert_sample<int8_t,int32_t>(const register int8_t sample) { }
+
+ // int8_t -> float
+- template<> static inline const float convert_sample<int8_t,float>(const register int8_t sample) { return ((float)sample)/127.0f; }
++ template<> STATIC inline const float convert_sample<int8_t,float>(const register int8_t sample) { return ((float)sample)/127.0f; }
+
+ // int8_t -> double
+ //template<> static inline const double convert_sample<int8_t,double>(const register int8_t sample) { }
+@@ -181,22 +191,22 @@
+
+ // int16_t -> ...
+ // int16_t -> int8_t
+- template<> static inline const int8_t convert_sample<int16_t,int8_t>(const register int16_t sample) { return sample/256; }
++ template<> STATIC inline const int8_t convert_sample<int16_t,int8_t>(const register int16_t sample) { return sample/256; }
+
+ // int16_t -> int16_t
+- template<> static inline const int16_t convert_sample<int16_t,int16_t>(const register int16_t sample) { return sample; }
++ template<> STATIC inline const int16_t convert_sample<int16_t,int16_t>(const register int16_t sample) { return sample; }
+
+ // int16_t -> int24_t
+- template<> static inline const int24_t convert_sample<int16_t,int24_t>(const register int16_t sample) { int24_t r; r.set(sample*256); return r; }
++ template<> STATIC inline const int24_t convert_sample<int16_t,int24_t>(const register int16_t sample) { int24_t r; r.set(sample*256); return r; }
+
+ // int16_t -> int32_t
+- template<> static inline const int32_t convert_sample<int16_t,int32_t>(const register int16_t sample) { return sample*65536; }
++ template<> STATIC inline const int32_t convert_sample<int16_t,int32_t>(const register int16_t sample) { return sample*65536; }
+
+ // int16_t -> float
+- template<> static inline const float convert_sample<int16_t,float>(const register int16_t sample) { return (float)sample/32767.0f; }
++ template<> STATIC inline const float convert_sample<int16_t,float>(const register int16_t sample) { return (float)sample/32767.0f; }
+
+ // int16_t -> double
+- template<> static inline const double convert_sample<int16_t,double>(const register int16_t sample) { return (double)sample/32767.0; }
++ template<> STATIC inline const double convert_sample<int16_t,double>(const register int16_t sample) { return (double)sample/32767.0; }
+
+
+ // int24_t -> ...
+@@ -204,16 +214,16 @@
+ //template<> static inline const int8_t convert_sample<int24_t,int8_t>(const int24_t sample) { }
+
+ // int24_t -> int16_t
+- template<> static inline const int16_t convert_sample<int24_t,int16_t>(const int24_t sample) { return sample.get()>>8; }
++ template<> STATIC inline const int16_t convert_sample<int24_t,int16_t>(const int24_t sample) { return sample.get()>>8; }
+
+ // int24_t -> int24_t
+- template<> static inline const int24_t convert_sample<int24_t,int24_t>(const int24_t sample) { return sample; }
++ template<> STATIC inline const int24_t convert_sample<int24_t,int24_t>(const int24_t sample) { return sample; }
+
+ // int24_t -> int32_t
+ //template<> static inline const int32_t convert_sample<int24_t,int32_t>(const int24_t sample) { }
+
+ // int24_t -> float
+- template<> static inline const float convert_sample<int24_t,float>(const int24_t sample) { return sample.get()/8388607.0f; }
++ template<> STATIC inline const float convert_sample<int24_t,float>(const int24_t sample) { return sample.get()/8388607.0f; }
+
+ // int24_t -> double
+ //template<> static inline const double convert_sample<int24_t,double>(const int24_t sample) { }
+@@ -224,16 +234,16 @@
+ //template<> static inline const int8_t convert_sample<int32_t,int8_t>(const register int32_t sample) { }
+
+ // int32_t -> int16_t
+- template<> static inline const int16_t convert_sample<int32_t,int16_t>(const register int32_t sample) { return sample/65536; }
++ template<> STATIC inline const int16_t convert_sample<int32_t,int16_t>(const register int32_t sample) { return sample/65536; }
+
+ // int32_t -> int24_t
+ //template<> static inline const int24_t convert_sample<int32_t,int24_t>(const register int32_t sample) { }
+
+ // int32_t -> int32_t
+- template<> static inline const int32_t convert_sample<int32_t,int32_t>(const register int32_t sample) { return sample; }
++ template<> STATIC inline const int32_t convert_sample<int32_t,int32_t>(const register int32_t sample) { return sample; }
+
+ // int32_t -> float
+- template<> static inline const float convert_sample<int32_t,float>(const register int32_t sample) { return ((double)sample)/2147483647.0; }
++ template<> STATIC inline const float convert_sample<int32_t,float>(const register int32_t sample) { return ((double)sample)/2147483647.0; }
+
+ // int32_t -> double
+ //template<> static inline const double convert_sample<int32_t,double >(const register int32_t sample) { }
+@@ -241,22 +251,22 @@
+
+ // float -> ...
+ // float -> int8_t
+- template<> static inline const int8_t convert_sample<float,int8_t>(const register float sample) { return (int8_t)floorf((sample>1.0f ? 1.0f : (sample<-1.0f ? -1.0f : sample))*127.0f); }
++ template<> STATIC inline const int8_t convert_sample<float,int8_t>(const register float sample) { return (int8_t)floorf((sample>1.0f ? 1.0f : (sample<-1.0f ? -1.0f : sample))*127.0f); }
+
+ // float -> int16_t
+- template<> static inline const int16_t convert_sample<float,int16_t>(const register float sample) { return (int16_t)floorf((sample>1.0f ? 1.0f : (sample<-1.0f ? -1.0f : sample))*32767.0f); }
++ template<> STATIC inline const int16_t convert_sample<float,int16_t>(const register float sample) { return (int16_t)floorf((sample>1.0f ? 1.0f : (sample<-1.0f ? -1.0f : sample))*32767.0f); }
+
+ // float -> int24_t
+- template<> static inline const int24_t convert_sample<float,int24_t>(const register float sample) { int24_t r; r.set((int_fast32_t)floorf((sample>1.0f ? 1.0f : (sample<-1.0f ? -1.0f : sample))*8388607.0f)); return r; }
++ template<> STATIC inline const int24_t convert_sample<float,int24_t>(const register float sample) { int24_t r; r.set((int_fast32_t)floorf((sample>1.0f ? 1.0f : (sample<-1.0f ? -1.0f : sample))*8388607.0f)); return r; }
+
+ // float -> int32_t
+- template<> static inline const int32_t convert_sample<float,int32_t>(const register float sample) { return (int32_t) floor((double)(sample>1.0f ? 1.0f : (sample<-1.0f ? -1.0f : sample)) * 2147483647.0); }
++ template<> STATIC inline const int32_t convert_sample<float,int32_t>(const register float sample) { return (int32_t) floor((double)(sample>1.0f ? 1.0f : (sample<-1.0f ? -1.0f : sample)) * 2147483647.0); }
+
+ // float -> float
+- template<> static inline const float convert_sample<float,float>(const register float sample) { return sample; }
++ template<> STATIC inline const float convert_sample<float,float>(const register float sample) { return sample; }
+
+ // float -> double
+- template<> static inline const double convert_sample<float,double>(const register float sample) { return (double)sample; }
++ template<> STATIC inline const double convert_sample<float,double>(const register float sample) { return (double)sample; }
+
+
+ // double -> ...
+@@ -264,7 +274,7 @@
+ //template<> static inline const int8_t convert_sample<double,int8_t>(const register double sample) { }
+
+ // double -> int16_t
+- template<> static inline const int16_t convert_sample<double,int16_t>(const register double sample) { return (int16_t)floor((sample>1.0 ? 1.0 : (sample<-1.0 ? -1.0 : sample))*32767.0); }
++ template<> STATIC inline const int16_t convert_sample<double,int16_t>(const register double sample) { return (int16_t)floor((sample>1.0 ? 1.0 : (sample<-1.0 ? -1.0 : sample))*32767.0); }
+
+ // double -> int24_t
+ //template<> static inline const int24_t convert_sample<double,int24_t>(const register double sample) { }
+@@ -273,10 +283,10 @@
+ //template<> static inline const int32_t convert_sample<double,int32_t>(const register double sample) { }
+
+ // double -> float
+- template<> static inline const float convert_sample<double,float>(const register double sample) { return (float)sample; }
++ template<> STATIC inline const float convert_sample<double,float>(const register double sample) { return (float)sample; }
+
+ // double -> double
+- template<> static inline const double convert_sample<double,double>(const register double sample) { return sample; }
++ template<> STATIC inline const double convert_sample<double,double>(const register double sample) { return sample; }
+
+
+
+diff -Naur rezound-0.12.3beta~/src/backend/Generate/CGenerateNoiseAction.cpp rezound-0.12.3beta/src/backend/Generate/CGenerateNoiseAction.cpp
+--- rezound-0.12.3beta~/src/backend/Generate/CGenerateNoiseAction.cpp 2008-03-18 22:20:36.000000000 -0400
++++ rezound-0.12.3beta/src/backend/Generate/CGenerateNoiseAction.cpp 2008-03-18 22:33:05.000000000 -0400
+@@ -22,6 +22,7 @@
+ #include "CGenerateNoiseAction.h"
+
+ #include "../CActionParameters.h"
++#include <cstdlib>
+
+ CGenerateNoiseAction::CGenerateNoiseAction(const AActionFactory *factory,const CActionSound *actionSound,const double _noiseLength,const double _volume,const NoiseTypes _noiseType,const StereoImage _stereoImage,const double _maxParticleVelocity):
+ AAction(factory,actionSound),
+diff -Naur rezound-0.12.3beta~/src/misc/CNestedDataFile/anytype.h rezound-0.12.3beta/src/misc/CNestedDataFile/anytype.h
+--- rezound-0.12.3beta~/src/misc/CNestedDataFile/anytype.h 2008-03-18 22:20:36.000000000 -0400
++++ rezound-0.12.3beta/src/misc/CNestedDataFile/anytype.h 2008-03-18 22:33:11.000000000 -0400
+@@ -20,6 +20,16 @@
+ #ifndef __anytype_H__
+ #define __anytype_H__
+
++#ifndef GCC_VERSION
++#define GCC_VERSION (__GNUC__ * 100 + __GNUC_MINOR__)
++#endif
++
++#if GCC_VERSION >= 403
++# define STATIC
++#else
++# define STATIC static
++#endif
++
+ #include <sstream>
+ #include <string>
+ #include <vector> // for the vector implemenation to/from string
+@@ -67,28 +77,28 @@
+
+ // template specializations of string_to_anytype
+
+-template<> static const string string_to_anytype<string>(const string &str,string &ret) { return s2at::unescape_chars(s2at::remove_surrounding_quotes(str)); }
++template<> STATIC const string string_to_anytype<string>(const string &str,string &ret) { return s2at::unescape_chars(s2at::remove_surrounding_quotes(str)); }
+
+-template<> static const bool string_to_anytype<bool>(const string &str,bool &ret) { return s2at::remove_surrounding_quotes(str)=="true" ? ret=true : ret=false; }
++template<> STATIC const bool string_to_anytype<bool>(const string &str,bool &ret) { return s2at::remove_surrounding_quotes(str)=="true" ? ret=true : ret=false; }
+
+-template<> static const char string_to_anytype<char>(const string &str,char &ret) { istringstream ss(s2at::remove_surrounding_quotes(str)); NO_LOCALE(ss) ret=0; ss >> ret; return ret; }
+-template<> static const unsigned char string_to_anytype<unsigned char>(const string &str,unsigned char &ret) { istringstream ss(s2at::remove_surrounding_quotes(str)); NO_LOCALE(ss) ret=0; ss >> ret; return ret; }
++template<> STATIC const char string_to_anytype<char>(const string &str,char &ret) { istringstream ss(s2at::remove_surrounding_quotes(str)); NO_LOCALE(ss) ret=0; ss >> ret; return ret; }
++template<> STATIC const unsigned char string_to_anytype<unsigned char>(const string &str,unsigned char &ret) { istringstream ss(s2at::remove_surrounding_quotes(str)); NO_LOCALE(ss) ret=0; ss >> ret; return ret; }
+
+-template<> static const short string_to_anytype<short>(const string &str,short &ret) { istringstream ss(s2at::remove_surrounding_quotes(str)); NO_LOCALE(ss) ret=0; ss >> ret; return ret; }
+-template<> static const unsigned short string_to_anytype<unsigned short>(const string &str,unsigned short &ret) { istringstream ss(s2at::remove_surrounding_quotes(str)); NO_LOCALE(ss) ret=0; ss >> ret; return ret; }
++template<> STATIC const short string_to_anytype<short>(const string &str,short &ret) { istringstream ss(s2at::remove_surrounding_quotes(str)); NO_LOCALE(ss) ret=0; ss >> ret; return ret; }
++template<> STATIC const unsigned short string_to_anytype<unsigned short>(const string &str,unsigned short &ret) { istringstream ss(s2at::remove_surrounding_quotes(str)); NO_LOCALE(ss) ret=0; ss >> ret; return ret; }
+
+-template<> static const int string_to_anytype<int>(const string &str,int &ret) { istringstream ss(s2at::remove_surrounding_quotes(str)); NO_LOCALE(ss) ret=0; ss >> ret; return ret; }
+-template<> static const unsigned int string_to_anytype<unsigned int>(const string &str,unsigned int &ret) { istringstream ss(s2at::remove_surrounding_quotes(str)); NO_LOCALE(ss) ret=0; ss >> ret; return ret; }
++template<> STATIC const int string_to_anytype<int>(const string &str,int &ret) { istringstream ss(s2at::remove_surrounding_quotes(str)); NO_LOCALE(ss) ret=0; ss >> ret; return ret; }
++template<> STATIC const unsigned int string_to_anytype<unsigned int>(const string &str,unsigned int &ret) { istringstream ss(s2at::remove_surrounding_quotes(str)); NO_LOCALE(ss) ret=0; ss >> ret; return ret; }
+
+-template<> static const long string_to_anytype<long>(const string &str,long &ret) { istringstream ss(s2at::remove_surrounding_quotes(str)); NO_LOCALE(ss) ret=0; ss >> ret; return ret; }
+-template<> static const unsigned long string_to_anytype<unsigned long>(const string &str,unsigned long &ret) { istringstream ss(s2at::remove_surrounding_quotes(str)); NO_LOCALE(ss) ret=0; ss >> ret; return ret; }
++template<> STATIC const long string_to_anytype<long>(const string &str,long &ret) { istringstream ss(s2at::remove_surrounding_quotes(str)); NO_LOCALE(ss) ret=0; ss >> ret; return ret; }
++template<> STATIC const unsigned long string_to_anytype<unsigned long>(const string &str,unsigned long &ret) { istringstream ss(s2at::remove_surrounding_quotes(str)); NO_LOCALE(ss) ret=0; ss >> ret; return ret; }
+
+-template<> static const long long string_to_anytype<long long>(const string &str,long long &ret) { istringstream ss(s2at::remove_surrounding_quotes(str)); NO_LOCALE(ss) ret=0; ss >> ret; return ret; }
+-template<> static const unsigned long long string_to_anytype<unsigned long long>(const string &str,unsigned long long &ret) { istringstream ss(s2at::remove_surrounding_quotes(str)); NO_LOCALE(ss) ret=0; ss >> ret; return ret; }
++template<> STATIC const long long string_to_anytype<long long>(const string &str,long long &ret) { istringstream ss(s2at::remove_surrounding_quotes(str)); NO_LOCALE(ss) ret=0; ss >> ret; return ret; }
++template<> STATIC const unsigned long long string_to_anytype<unsigned long long>(const string &str,unsigned long long &ret) { istringstream ss(s2at::remove_surrounding_quotes(str)); NO_LOCALE(ss) ret=0; ss >> ret; return ret; }
+
+-template<> static const float string_to_anytype<float>(const string &str,float &ret) { istringstream ss(s2at::remove_surrounding_quotes(str)); NO_LOCALE(ss) ret=0.0f; ss >> ret; return ret; }
+-template<> static const double string_to_anytype<double>(const string &str,double &ret) { istringstream ss(s2at::remove_surrounding_quotes(str)); NO_LOCALE(ss) ret=0.0; ss >> ret; return ret; }
+-template<> static const long double string_to_anytype<long double>(const string &str,long double &ret) { istringstream ss(s2at::remove_surrounding_quotes(str)); NO_LOCALE(ss) ret=0.0; ss >> ret; return ret; }
++template<> STATIC const float string_to_anytype<float>(const string &str,float &ret) { istringstream ss(s2at::remove_surrounding_quotes(str)); NO_LOCALE(ss) ret=0.0f; ss >> ret; return ret; }
++template<> STATIC const double string_to_anytype<double>(const string &str,double &ret) { istringstream ss(s2at::remove_surrounding_quotes(str)); NO_LOCALE(ss) ret=0.0; ss >> ret; return ret; }
++template<> STATIC const long double string_to_anytype<long double>(const string &str,long double &ret) { istringstream ss(s2at::remove_surrounding_quotes(str)); NO_LOCALE(ss) ret=0.0; ss >> ret; return ret; }
+
+ // I really wished that I didn't have to explicitly use 'vector' in the definition; I'd have like to use any container with an iterator interface
+ #include <CMutex.h>
+@@ -119,31 +129,31 @@
+
+ // template specializations of anytype_to_string
+
+-template<> static const string anytype_to_string<string>(const string &any) { return "\""+s2at::escape_chars(any)+"\""; }
++template<> STATIC const string anytype_to_string<string>(const string &any) { return "\""+s2at::escape_chars(any)+"\""; }
+
+-template<> static const string anytype_to_string<bool>(const bool &any) { return any ? "true" : "false"; }
++template<> STATIC const string anytype_to_string<bool>(const bool &any) { return any ? "true" : "false"; }
+
+-template<> static const string anytype_to_string<char>(const char &any) { ostringstream ss; NO_LOCALE(ss) ss << any; return ss.str(); }
+-template<> static const string anytype_to_string<unsigned char>(const unsigned char &any) { ostringstream ss; NO_LOCALE(ss) ss << any; return ss.str(); }
++template<> STATIC const string anytype_to_string<char>(const char &any) { ostringstream ss; NO_LOCALE(ss) ss << any; return ss.str(); }
++template<> STATIC const string anytype_to_string<unsigned char>(const unsigned char &any) { ostringstream ss; NO_LOCALE(ss) ss << any; return ss.str(); }
+
+-template<> static const string anytype_to_string<short>(const short &any) { ostringstream ss; NO_LOCALE(ss) ss << any; return ss.str(); }
+-template<> static const string anytype_to_string<unsigned short>(const unsigned short &any) { ostringstream ss; NO_LOCALE(ss) ss << any; return ss.str(); }
++template<> STATIC const string anytype_to_string<short>(const short &any) { ostringstream ss; NO_LOCALE(ss) ss << any; return ss.str(); }
++template<> STATIC const string anytype_to_string<unsigned short>(const unsigned short &any) { ostringstream ss; NO_LOCALE(ss) ss << any; return ss.str(); }
+
+-template<> static const string anytype_to_string<int>(const int &any) { ostringstream ss; NO_LOCALE(ss) ss << any; return ss.str(); }
+-template<> static const string anytype_to_string<unsigned int>(const unsigned int &any) { ostringstream ss; NO_LOCALE(ss) ss << any; return ss.str(); }
++template<> STATIC const string anytype_to_string<int>(const int &any) { ostringstream ss; NO_LOCALE(ss) ss << any; return ss.str(); }
++template<> STATIC const string anytype_to_string<unsigned int>(const unsigned int &any) { ostringstream ss; NO_LOCALE(ss) ss << any; return ss.str(); }
+
+-template<> static const string anytype_to_string<long>(const long &any) { ostringstream ss; NO_LOCALE(ss) ss << any; return ss.str(); }
+-template<> static const string anytype_to_string<unsigned long>(const unsigned long &any) { ostringstream ss; NO_LOCALE(ss) ss << any; return ss.str(); }
++template<> STATIC const string anytype_to_string<long>(const long &any) { ostringstream ss; NO_LOCALE(ss) ss << any; return ss.str(); }
++template<> STATIC const string anytype_to_string<unsigned long>(const unsigned long &any) { ostringstream ss; NO_LOCALE(ss) ss << any; return ss.str(); }
+
+-template<> static const string anytype_to_string<long long>(const long long &any) { ostringstream ss; NO_LOCALE(ss) ss << any; return ss.str(); }
+-template<> static const string anytype_to_string<unsigned long long>(const unsigned long long &any) { ostringstream ss; NO_LOCALE(ss) ss << any; return ss.str(); }
++template<> STATIC const string anytype_to_string<long long>(const long long &any) { ostringstream ss; NO_LOCALE(ss) ss << any; return ss.str(); }
++template<> STATIC const string anytype_to_string<unsigned long long>(const unsigned long long &any) { ostringstream ss; NO_LOCALE(ss) ss << any; return ss.str(); }
+
+ // I've picked a rather arbitrary way of formatting floats one way or another depending on how big it is.. I wish there were a way to output the ascii in such a way as to preserve all the information in the float (without printing the hex of it or something like that)
+ #include <istring>
+ #include <math.h> // for isnan which I hope is there (maybe fix in common.h if it's not
+-template<> static const string anytype_to_string<float>(const float &any) { if(isnan(any)) return "0"; else { ostringstream ss; NO_LOCALE(ss) if(any>999999.0) {ss.setf(ios::scientific); ss.width(0); ss.precision(12); ss.fill(' '); } else {ss.setf(ios::fixed); ss.precision(6); ss.fill(' '); } ss << any; return istring(ss.str()).trim(); } }
+-template<> static const string anytype_to_string<double>(const double &any) { if(isnan(any)) return "0"; else { ostringstream ss; NO_LOCALE(ss) if(any>999999.0) {ss.setf(ios::scientific); ss.width(0); ss.precision(12); ss.fill(' '); } else {ss.setf(ios::fixed); ss.precision(6); ss.fill(' '); } ss << any; return istring(ss.str()).trim(); } }
+-template<> static const string anytype_to_string<long double>(const long double &any) { if(isnan(any)) return "0"; else { ostringstream ss; NO_LOCALE(ss) if(any>999999.0) {ss.setf(ios::scientific); ss.width(0); ss.precision(12); ss.fill(' '); } else {ss.setf(ios::fixed); ss.precision(6); ss.fill(' '); } ss << any; return istring(ss.str()).trim(); } }
++template<> STATIC const string anytype_to_string<float>(const float &any) { if(isnan(any)) return "0"; else { ostringstream ss; NO_LOCALE(ss) if(any>999999.0) {ss.setf(ios::scientific); ss.width(0); ss.precision(12); ss.fill(' '); } else {ss.setf(ios::fixed); ss.precision(6); ss.fill(' '); } ss << any; return istring(ss.str()).trim(); } }
++template<> STATIC const string anytype_to_string<double>(const double &any) { if(isnan(any)) return "0"; else { ostringstream ss; NO_LOCALE(ss) if(any>999999.0) {ss.setf(ios::scientific); ss.width(0); ss.precision(12); ss.fill(' '); } else {ss.setf(ios::fixed); ss.precision(6); ss.fill(' '); } ss << any; return istring(ss.str()).trim(); } }
++template<> STATIC const string anytype_to_string<long double>(const long double &any) { if(isnan(any)) return "0"; else { ostringstream ss; NO_LOCALE(ss) if(any>999999.0) {ss.setf(ios::scientific); ss.width(0); ss.precision(12); ss.fill(' '); } else {ss.setf(ios::fixed); ss.precision(6); ss.fill(' '); } ss << any; return istring(ss.str()).trim(); } }
+
+
+ // I really wished that I didn't have to explicitly use 'vector' in the definition, I'd have like to use any container with an iterator interface
+diff -Naur rezound-0.12.3beta~/src/misc/endian_util.h rezound-0.12.3beta/src/misc/endian_util.h
+--- rezound-0.12.3beta~/src/misc/endian_util.h 2008-03-18 22:20:36.000000000 -0400
++++ rezound-0.12.3beta/src/misc/endian_util.h 2008-03-18 22:29:18.000000000 -0400
+@@ -21,6 +21,16 @@
+ #ifndef __endian_util_H__
+ #define __endian_util_H__
+
++#ifndef GCC_VERSION
++#define GCC_VERSION (__GNUC__ * 100 + __GNUC_MINOR__)
++#endif
++
++#if GCC_VERSION >= 403
++# define STATIC
++#else
++# define STATIC static
++#endif
++
+ /*
+ * This header files given functionality to convenient change endian-ness of values
+ * and through the use of very few function names regardless of the type.
+@@ -131,13 +141,13 @@
+ }
+
+ // --- implementation for 1 byte quantities (nothing)
+- template<> inline static void really_swap_endian_ptr<1>(void *value,const unsigned size)
++ template<> inline STATIC void really_swap_endian_ptr<1>(void *value,const unsigned size)
+ {
+ // nothing to do
+ }
+
+ // --- implementation for 2 byte quantities
+- template<> inline static void really_swap_endian_ptr<2>(void *value,const unsigned size)
++ template<> inline STATIC void really_swap_endian_ptr<2>(void *value,const unsigned size)
+ {
+ const register uint16_t v=((uint16_t *)value)[0];
+ ((uint16_t *)value)[0]=
+@@ -147,7 +157,7 @@
+ }
+
+ // --- implementation for 4 byte quantities
+- template<> inline static void really_swap_endian_ptr<4>(void *value,const unsigned size)
++ template<> inline STATIC void really_swap_endian_ptr<4>(void *value,const unsigned size)
+ {
+ const register uint32_t v=((uint32_t *)value)[0];
+ ((uint32_t *)value)[0]=
+@@ -157,7 +167,7 @@
+ }
+
+ // --- implementation for 8 byte quantities
+- template<> inline static void really_swap_endian_ptr<8>(void *value,const unsigned size)
++ template<> inline STATIC void really_swap_endian_ptr<8>(void *value,const unsigned size)
+ {
+ const register uint64_t v=((uint64_t *)value)[0];
+ // of 8, swap upper most and lower most octets then the next two inward, and so on ..
diff --git a/src/patchsets/rezound/0.12.3_beta/100_all_reconf_warnings.patch b/src/patchsets/rezound/0.12.3_beta/100_all_reconf_warnings.patch
new file mode 100644
index 0000000000..b16d5384a9
--- /dev/null
+++ b/src/patchsets/rezound/0.12.3_beta/100_all_reconf_warnings.patch
@@ -0,0 +1,37 @@
+Index: rezound-0.12.3beta/configure.ac
+===================================================================
+--- rezound-0.12.3beta.orig/configure.ac
++++ rezound-0.12.3beta/configure.ac
+@@ -24,7 +24,7 @@
+ # Process this file with autoconf to produce a configure script.
+
+ AC_INIT(rezound, 0.12.3beta, [http://sourceforge.net/tracker/?atid=105056&group_id=5056])
+-AC_CONFIG_AUX_DIR(config)
++AC_CONFIG_AUX_DIR([config])
+ AM_CONFIG_HEADER([config/config.h])
+ AM_INIT_AUTOMAKE
+ AC_DISABLE_SHARED # This makes libtool only build static libs
+Index: rezound-0.12.3beta/config/am_include.mk
+===================================================================
+--- rezound-0.12.3beta.orig/config/am_include.mk
++++ rezound-0.12.3beta/config/am_include.mk
+@@ -35,19 +35,6 @@ INCLUDES=\
+ -I$(top_srcdir)/src/PoolFile
+
+
+-## CXXFLAGS is also automatically added to the $(CXX) macro at compile time, and
+-## is passed down to the children as well
+-## I list these here in case there needs to always be some flags passed to the compiler
+-CXXFLAGS=@CXXFLAGS@
+-
+-
+-## LDFLAGS will be added at link time
+-## note that the -l flags are set by the LIBS macro that is set by configure
+-## This line doesn't need to be here, configure will add LDFLAGS on it's own,
+-## but I'm leaving here as a place to add LDFLAGS if so desired
+-LDFLAGS=@LDFLAGS@
+-
+-
+ # doc directory
+ pkgdocdir=$(prefix)/doc/@PACKAGE@
+
diff --git a/src/patchsets/rezound/0.12.3_beta/110_all_libtool.patch b/src/patchsets/rezound/0.12.3_beta/110_all_libtool.patch
new file mode 100644
index 0000000000..000ede3389
--- /dev/null
+++ b/src/patchsets/rezound/0.12.3_beta/110_all_libtool.patch
@@ -0,0 +1,43 @@
+Index: rezound-0.12.3beta/config/m4/cxx-lib.m4
+===================================================================
+--- rezound-0.12.3beta.orig/config/m4/cxx-lib.m4
++++ rezound-0.12.3beta/config/m4/cxx-lib.m4
+@@ -59,7 +59,7 @@ dnl
+ dnl What a mess with the AS_TR_CPP($1); now if I knew how to assign a variable
+ dnl at the top that I could use everwhere else I would
+ dnl
+-AC_DEFUN(ajv_CXX_CHECK_LIB,
++AC_DEFUN([ajv_CXX_CHECK_LIB],
+
+ dnl prepare to beable to AC_DEFINE the HAVE_LIBXXX #define
+ [AH_TEMPLATE(AS_TR_CPP(HAVE_LIB$1),[defined by $0])]
+@@ -117,18 +117,15 @@ AC_DEFUN(ajv_CXX_CHECK_LIB,
+
+ saved_CPPFLAGS="$CPPFLAGS"
+ saved_CXXFLAGS="$CXXFLAGS"
+- saved_LDFLAGS="$LDFLAGS"
++ saved_LIBS="$LIBS"
+ saved_CXX="$CXX"
+
+ [CPPFLAGS="$CPPFLAGS $ajv_inc@&t@AS_TR_CPP($1)_path"]
+ [CXXFLAGS="$CXXFLAGS $ajv_inc@&t@AS_TR_CPP($1)_path"]
+- [LDFLAGS="$LDFLAGS $ajv_lib@&t@AS_TR_CPP($1)_path -l$1 $5"]
++ [LIBS="$LIBS $ajv_lib@&t@AS_TR_CPP($1)_path -l$1 $5"]
+
+ builddir=`pwd` # I'm assuming that the pwd will always be what $(top_builddir) will be set to in AC_OUTPUT
+
+- # HACK: force AC_LINK_IFELSE to use libtool to link so it will get FOX's dependancies. Personally, I think it should do this anyway because I've used AC_PROG_LIBTOOL to request libtool as the linker for the subsequent make
+- CXX="$builddir/libtool --mode=link $CXX"
+-
+ [AC_LINK_IFELSE([
+ #include <$3>
+ int main() { $2 xxx; return 0; }
+@@ -187,7 +184,7 @@ AC_DEFUN(ajv_CXX_CHECK_LIB,
+
+ CPPFLAGS="$saved_CPPFLAGS"
+ CXXFLAGS="$saved_CXXFLAGS"
+- LDFLAGS="$saved_LDFLAGS"
++ LIBS="$saved_LIBS"
+ CXX="$saved_CXX"
+
+ [AC_LANG_POP(C++)]
diff --git a/src/patchsets/rezound/0.12.3_beta/series b/src/patchsets/rezound/0.12.3_beta/series
index 380daf203e..3226f86c82 100644
--- a/src/patchsets/rezound/0.12.3_beta/series
+++ b/src/patchsets/rezound/0.12.3_beta/series
@@ -5,3 +5,7 @@
050_all_portaudio19.patch
060_all_raw_save.patch
070_all_m4.patch
+080_all_endian_typo.patch
+090_all_gcc_4.3.patch
+100_all_reconf_warnings.patch
+110_all_libtool.patch