summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2012-09-24 20:30:36 +0000
committerMichael Haubenwallner <haubi@gentoo.org>2012-09-24 20:30:36 +0000
commit23a4dc3848fb069af1013b415801447b6a4dcfba (patch)
tree4988d7d48ed8b8eab001f212d3e3982f89b74087 /src/patchsets/mico
parentAutomated update of outdated-cpan-packages.xml (diff)
downloadgentoo-23a4dc3848fb069af1013b415801447b6a4dcfba.tar.gz
gentoo-23a4dc3848fb069af1013b415801447b6a4dcfba.tar.bz2
gentoo-23a4dc3848fb069af1013b415801447b6a4dcfba.zip
Add patch to have --with-gtk accept 'gtk-major' instead of path.
Diffstat (limited to 'src/patchsets/mico')
-rw-r--r--src/patchsets/mico/9999/013_all_gtk-versions.patch473
1 files changed, 473 insertions, 0 deletions
diff --git a/src/patchsets/mico/9999/013_all_gtk-versions.patch b/src/patchsets/mico/9999/013_all_gtk-versions.patch
new file mode 100644
index 0000000000..f1af685c96
--- /dev/null
+++ b/src/patchsets/mico/9999/013_all_gtk-versions.patch
@@ -0,0 +1,473 @@
+--- configure.in.orig 2011-06-06 14:26:10.529680983 +0200
++++ configure.in 2011-06-06 15:14:01.246026167 +0200
+@@ -152,8 +152,8 @@
+ QTDIR=$withval, QTDIR="")
+
+ AC_ARG_WITH(gtk,
+- [ --with-gtk=gtkdir use GTK installed in gtkdir],
+- GTKDIR=$withval, GTKDIR="")
++ [ --with-gtk=gtk-major use GTK major version, either 1, 2 or 3],
++ , with_gtk="no")
+
+ AC_ARG_WITH(tcl,
+ [ --with-tcl=tcldir use TCL installed in tcldir],
+@@ -1156,16 +1156,28 @@
+ fi
+
+
++HAVE_GTK=no
+ AC_SUBST(HAVE_GTK)
+
+-if test X"$GTKDIR" != X; then
+- AM_PATH_GTK(,HAVE_GTK=yes,
+- AC_MSG_WARN(cannot find gtk-config. GTK parts disabled)
+- HAVE_GTK=no)
+-else
+- HAVE_GTK=no
++if test "X$with_gtk" = Xyes -o "X$with_gtk" = X3; then
++ AC_LANG_C
++ AM_PATH_GTK_3_0(,HAVE_GTK=yes; with_gtk=3)
++ AC_LANG_CPLUSPLUS
++fi
++
++if test "X$with_gtk" = Xyes -o "X$with_gtk" = X2; then
++ AC_LANG_C
++ AM_PATH_GTK_2_0(,HAVE_GTK=yes; with_gtk=2)
++ AC_LANG_CPLUSPLUS
+ fi
+
++if test "X$with_gtk" = Xyes -o "X$with_gtk" = X1; then
++ AM_PATH_GTK(,HAVE_GTK=yes; with_gtk=1)
++fi
++
++if test "X$with_gtk" != Xno && test "X$HAVE_GTK" = Xno; then
++ AC_MSG_WARN(cannot find any GTK+ version, GTK parts disabled)
++fi
+
+ AC_SUBST(HAVE_TCL)
+ AC_SUBST(TCL_LIBS)
+--- aclocal.m4.orig 2011-06-06 14:25:41.073169479 +0200
++++ aclocal.m4 2011-06-06 14:33:38.022926510 +0200
+@@ -878,3 +878,422 @@
+ AC_SUBST(GTK_LIBS)
+ rm -f conf.gtktest
+ ])
++
++
++# Configure paths for GTK+
++# Owen Taylor 1997-2001
++
++dnl AM_PATH_GTK_2_0([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND [, MODULES]]]])
++dnl Test for GTK+, and define GTK_CFLAGS and GTK_LIBS, if gthread is specified in MODULES,
++dnl pass to pkg-config
++dnl
++AC_DEFUN([AM_PATH_GTK_2_0],
++[dnl
++dnl Get the cflags and libraries from pkg-config
++dnl
++AC_ARG_ENABLE(gtktest, [ --disable-gtktest do not try to compile and run a test GTK+ program],
++ , enable_gtktest=yes)
++
++ pkg_config_args=gtk+-2.0
++ for module in . $4
++ do
++ case "$module" in
++ gthread)
++ pkg_config_args="$pkg_config_args gthread-2.0"
++ ;;
++ esac
++ done
++
++ no_gtk=""
++
++ AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
++
++ if test x$PKG_CONFIG != xno ; then
++ if pkg-config --atleast-pkgconfig-version 0.7 ; then
++ :
++ else
++ echo "*** pkg-config too old; version 0.7 or better required."
++ no_gtk=yes
++ PKG_CONFIG=no
++ fi
++ else
++ no_gtk=yes
++ fi
++
++ min_gtk_version=ifelse([$1], ,2.0.0,$1)
++ AC_MSG_CHECKING(for GTK+ - version >= $min_gtk_version)
++
++ if test x$PKG_CONFIG != xno ; then
++ ## don't try to run the test against uninstalled libtool libs
++ if $PKG_CONFIG --uninstalled $pkg_config_args; then
++ echo "Will use uninstalled version of GTK+ found in PKG_CONFIG_PATH"
++ enable_gtktest=no
++ fi
++
++ if $PKG_CONFIG --atleast-version $min_gtk_version $pkg_config_args; then
++ :
++ else
++ no_gtk=yes
++ fi
++ fi
++
++ if test x"$no_gtk" = x ; then
++ GTK_CFLAGS=`$PKG_CONFIG $pkg_config_args --cflags`
++ GTK_LIBS=`$PKG_CONFIG $pkg_config_args --libs`
++ gtk_config_major_version=`$PKG_CONFIG --modversion gtk+-2.0 | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
++ gtk_config_minor_version=`$PKG_CONFIG --modversion gtk+-2.0 | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
++ gtk_config_micro_version=`$PKG_CONFIG --modversion gtk+-2.0 | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
++ if test "x$enable_gtktest" = "xyes" ; then
++ ac_save_CFLAGS="$CFLAGS"
++ ac_save_LIBS="$LIBS"
++ CFLAGS="$CFLAGS $GTK_CFLAGS"
++ LIBS="$GTK_LIBS $LIBS"
++dnl
++dnl Now check if the installed GTK+ is sufficiently new. (Also sanity
++dnl checks the results of pkg-config to some extent)
++dnl
++ rm -f conf.gtktest
++ AC_TRY_RUN([
++#include <gtk/gtk.h>
++#include <stdio.h>
++#include <stdlib.h>
++
++int
++main ()
++{
++ int major, minor, micro;
++ char *tmp_version;
++
++ fclose (fopen ("conf.gtktest", "w"));
++
++ /* HP/UX 9 (%@#!) writes to sscanf strings */
++ tmp_version = g_strdup("$min_gtk_version");
++ if (sscanf(tmp_version, "%d.%d.%d", &major, &minor, &micro) != 3) {
++ printf("%s, bad version string\n", "$min_gtk_version");
++ exit(1);
++ }
++
++ if ((gtk_major_version != $gtk_config_major_version) ||
++ (gtk_minor_version != $gtk_config_minor_version) ||
++ (gtk_micro_version != $gtk_config_micro_version))
++ {
++ printf("\n*** 'pkg-config --modversion gtk+-2.0' returned %d.%d.%d, but GTK+ (%d.%d.%d)\n",
++ $gtk_config_major_version, $gtk_config_minor_version, $gtk_config_micro_version,
++ gtk_major_version, gtk_minor_version, gtk_micro_version);
++ printf ("*** was found! If pkg-config was correct, then it is best\n");
++ printf ("*** to remove the old version of GTK+. You may also be able to fix the error\n");
++ printf("*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing\n");
++ printf("*** /etc/ld.so.conf. Make sure you have run ldconfig if that is\n");
++ printf("*** required on your system.\n");
++ printf("*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH\n");
++ printf("*** to point to the correct configuration files\n");
++ }
++ else if ((gtk_major_version != GTK_MAJOR_VERSION) ||
++ (gtk_minor_version != GTK_MINOR_VERSION) ||
++ (gtk_micro_version != GTK_MICRO_VERSION))
++ {
++ printf("*** GTK+ header files (version %d.%d.%d) do not match\n",
++ GTK_MAJOR_VERSION, GTK_MINOR_VERSION, GTK_MICRO_VERSION);
++ printf("*** library (version %d.%d.%d)\n",
++ gtk_major_version, gtk_minor_version, gtk_micro_version);
++ }
++ else
++ {
++ if ((gtk_major_version > major) ||
++ ((gtk_major_version == major) && (gtk_minor_version > minor)) ||
++ ((gtk_major_version == major) && (gtk_minor_version == minor) && (gtk_micro_version >= micro)))
++ {
++ return 0;
++ }
++ else
++ {
++ printf("\n*** An old version of GTK+ (%d.%d.%d) was found.\n",
++ gtk_major_version, gtk_minor_version, gtk_micro_version);
++ printf("*** You need a version of GTK+ newer than %d.%d.%d. The latest version of\n",
++ major, minor, micro);
++ printf("*** GTK+ is always available from ftp://ftp.gtk.org.\n");
++ printf("***\n");
++ printf("*** If you have already installed a sufficiently new version, this error\n");
++ printf("*** probably means that the wrong copy of the pkg-config shell script is\n");
++ printf("*** being found. The easiest way to fix this is to remove the old version\n");
++ printf("*** of GTK+, but you can also set the PKG_CONFIG environment to point to the\n");
++ printf("*** correct copy of pkg-config. (In this case, you will have to\n");
++ printf("*** modify your LD_LIBRARY_PATH enviroment variable, or edit /etc/ld.so.conf\n");
++ printf("*** so that the correct libraries are found at run-time))\n");
++ }
++ }
++ return 1;
++}
++],, no_gtk=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
++ CFLAGS="$ac_save_CFLAGS"
++ LIBS="$ac_save_LIBS"
++ fi
++ fi
++ if test "x$no_gtk" = x ; then
++ AC_MSG_RESULT(yes (version $gtk_config_major_version.$gtk_config_minor_version.$gtk_config_micro_version))
++ ifelse([$2], , :, [$2])
++ else
++ AC_MSG_RESULT(no)
++ if test "$PKG_CONFIG" = "no" ; then
++ echo "*** A new enough version of pkg-config was not found."
++ echo "*** See http://pkgconfig.sourceforge.net"
++ else
++ if test -f conf.gtktest ; then
++ :
++ else
++ echo "*** Could not run GTK+ test program, checking why..."
++ ac_save_CFLAGS="$CFLAGS"
++ ac_save_LIBS="$LIBS"
++ CFLAGS="$CFLAGS $GTK_CFLAGS"
++ LIBS="$LIBS $GTK_LIBS"
++ AC_TRY_LINK([
++#include <gtk/gtk.h>
++#include <stdio.h>
++], [ return ((gtk_major_version) || (gtk_minor_version) || (gtk_micro_version)); ],
++ [ echo "*** The test program compiled, but did not run. This usually means"
++ echo "*** that the run-time linker is not finding GTK+ or finding the wrong"
++ echo "*** version of GTK+. If it is not finding GTK+, you'll need to set your"
++ echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
++ echo "*** to the installed location Also, make sure you have run ldconfig if that"
++ echo "*** is required on your system"
++ echo "***"
++ echo "*** If you have an old version installed, it is best to remove it, although"
++ echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH" ],
++ [ echo "*** The test program failed to compile or link. See the file config.log for the"
++ echo "*** exact error that occured. This usually means GTK+ is incorrectly installed."])
++ CFLAGS="$ac_save_CFLAGS"
++ LIBS="$ac_save_LIBS"
++ fi
++ fi
++ GTK_CFLAGS=""
++ GTK_LIBS=""
++ ifelse([$3], , :, [$3])
++ fi
++ AC_SUBST(GTK_CFLAGS)
++ AC_SUBST(GTK_LIBS)
++ rm -f conf.gtktest
++])
++
++
++# Configure paths for GTK+
++# Owen Taylor 1997-2001
++
++dnl AM_PATH_GTK_3_0([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND [, MODULES]]]])
++dnl Test for GTK+, and define GTK_CFLAGS and GTK_LIBS, if gthread is specified in MODULES,
++dnl pass to pkg-config
++dnl
++AC_DEFUN([AM_PATH_GTK_3_0],
++[dnl
++dnl Get the cflags and libraries from pkg-config
++dnl
++AC_ARG_ENABLE(gtktest, [ --disable-gtktest do not try to compile and run a test GTK+ program],
++ , enable_gtktest=yes)
++
++ pkg_config_args=gtk+-3.0
++ for module in . $4
++ do
++ case "$module" in
++ gthread)
++ pkg_config_args="$pkg_config_args gthread-2.0"
++ ;;
++ esac
++ done
++
++ no_gtk=""
++
++ AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
++
++ if test x$PKG_CONFIG != xno ; then
++ if $PKG_CONFIG --atleast-pkgconfig-version 0.7 ; then
++ :
++ else
++ echo "*** pkg-config too old; version 0.7 or better required."
++ no_gtk=yes
++ PKG_CONFIG=no
++ fi
++ else
++ no_gtk=yes
++ fi
++
++ min_gtk_version=ifelse([$1], ,3.0.0,$1)
++ AC_MSG_CHECKING(for GTK+ - version >= $min_gtk_version)
++
++ if test x$PKG_CONFIG != xno ; then
++ ## don't try to run the test against uninstalled libtool libs
++ if $PKG_CONFIG --uninstalled $pkg_config_args; then
++ echo "Will use uninstalled version of GTK+ found in PKG_CONFIG_PATH"
++ enable_gtktest=no
++ fi
++
++ if $PKG_CONFIG --atleast-version $min_gtk_version $pkg_config_args; then
++ :
++ else
++ no_gtk=yes
++ fi
++ fi
++
++ if test x"$no_gtk" = x ; then
++ GTK_CFLAGS=`$PKG_CONFIG $pkg_config_args --cflags`
++ GTK_LIBS=`$PKG_CONFIG $pkg_config_args --libs`
++ gtk_config_major_version=`$PKG_CONFIG --modversion gtk+-3.0 | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
++ gtk_config_minor_version=`$PKG_CONFIG --modversion gtk+-3.0 | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
++ gtk_config_micro_version=`$PKG_CONFIG --modversion gtk+-3.0 | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
++ if test "x$enable_gtktest" = "xyes" ; then
++ ac_save_CFLAGS="$CFLAGS"
++ ac_save_LIBS="$LIBS"
++ CFLAGS="$CFLAGS $GTK_CFLAGS"
++ LIBS="$GTK_LIBS $LIBS"
++dnl
++dnl Now check if the installed GTK+ is sufficiently new. (Also sanity
++dnl checks the results of pkg-config to some extent)
++dnl
++ rm -f conf.gtktest
++ AC_TRY_RUN([
++#include <gtk/gtk.h>
++#include <stdio.h>
++#include <stdlib.h>
++
++int
++main ()
++{
++ int major, minor, micro;
++ char *tmp_version;
++
++ fclose (fopen ("conf.gtktest", "w"));
++
++ /* HP/UX 9 (%@#!) writes to sscanf strings */
++ tmp_version = g_strdup("$min_gtk_version");
++ if (sscanf(tmp_version, "%d.%d.%d", &major, &minor, &micro) != 3) {
++ printf("%s, bad version string\n", "$min_gtk_version");
++ exit(1);
++ }
++
++ if ((gtk_major_version != $gtk_config_major_version) ||
++ (gtk_minor_version != $gtk_config_minor_version) ||
++ (gtk_micro_version != $gtk_config_micro_version))
++ {
++ printf("\n*** 'pkg-config --modversion gtk+-3.0' returned %d.%d.%d, but GTK+ (%d.%d.%d)\n",
++ $gtk_config_major_version, $gtk_config_minor_version, $gtk_config_micro_version,
++ gtk_major_version, gtk_minor_version, gtk_micro_version);
++ printf ("*** was found! If pkg-config was correct, then it is best\n");
++ printf ("*** to remove the old version of GTK+. You may also be able to fix the error\n");
++ printf("*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing\n");
++ printf("*** /etc/ld.so.conf. Make sure you have run ldconfig if that is\n");
++ printf("*** required on your system.\n");
++ printf("*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH\n");
++ printf("*** to point to the correct configuration files\n");
++ }
++ else if ((gtk_major_version != GTK_MAJOR_VERSION) ||
++ (gtk_minor_version != GTK_MINOR_VERSION) ||
++ (gtk_micro_version != GTK_MICRO_VERSION))
++ {
++ printf("*** GTK+ header files (version %d.%d.%d) do not match\n",
++ GTK_MAJOR_VERSION, GTK_MINOR_VERSION, GTK_MICRO_VERSION);
++ printf("*** library (version %d.%d.%d)\n",
++ gtk_major_version, gtk_minor_version, gtk_micro_version);
++ }
++ else
++ {
++ if ((gtk_major_version > major) ||
++ ((gtk_major_version == major) && (gtk_minor_version > minor)) ||
++ ((gtk_major_version == major) && (gtk_minor_version == minor) && (gtk_micro_version >= micro)))
++ {
++ return 0;
++ }
++ else
++ {
++ printf("\n*** An old version of GTK+ (%d.%d.%d) was found.\n",
++ gtk_major_version, gtk_minor_version, gtk_micro_version);
++ printf("*** You need a version of GTK+ newer than %d.%d.%d. The latest version of\n",
++ major, minor, micro);
++ printf("*** GTK+ is always available from ftp://ftp.gtk.org.\n");
++ printf("***\n");
++ printf("*** If you have already installed a sufficiently new version, this error\n");
++ printf("*** probably means that the wrong copy of the pkg-config shell script is\n");
++ printf("*** being found. The easiest way to fix this is to remove the old version\n");
++ printf("*** of GTK+, but you can also set the PKG_CONFIG environment to point to the\n");
++ printf("*** correct copy of pkg-config. (In this case, you will have to\n");
++ printf("*** modify your LD_LIBRARY_PATH enviroment variable, or edit /etc/ld.so.conf\n");
++ printf("*** so that the correct libraries are found at run-time))\n");
++ }
++ }
++ return 1;
++}
++],, no_gtk=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
++ CFLAGS="$ac_save_CFLAGS"
++ LIBS="$ac_save_LIBS"
++ fi
++ fi
++ if test "x$no_gtk" = x ; then
++ AC_MSG_RESULT(yes (version $gtk_config_major_version.$gtk_config_minor_version.$gtk_config_micro_version))
++ ifelse([$2], , :, [$2])
++ else
++ AC_MSG_RESULT(no)
++ if test "$PKG_CONFIG" = "no" ; then
++ echo "*** A new enough version of pkg-config was not found."
++ echo "*** See http://pkgconfig.sourceforge.net"
++ else
++ if test -f conf.gtktest ; then
++ :
++ else
++ echo "*** Could not run GTK+ test program, checking why..."
++ ac_save_CFLAGS="$CFLAGS"
++ ac_save_LIBS="$LIBS"
++ CFLAGS="$CFLAGS $GTK_CFLAGS"
++ LIBS="$LIBS $GTK_LIBS"
++ AC_TRY_LINK([
++#include <gtk/gtk.h>
++#include <stdio.h>
++], [ return ((gtk_major_version) || (gtk_minor_version) || (gtk_micro_version)); ],
++ [ echo "*** The test program compiled, but did not run. This usually means"
++ echo "*** that the run-time linker is not finding GTK+ or finding the wrong"
++ echo "*** version of GTK+. If it is not finding GTK+, you'll need to set your"
++ echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
++ echo "*** to the installed location Also, make sure you have run ldconfig if that"
++ echo "*** is required on your system"
++ echo "***"
++ echo "*** If you have an old version installed, it is best to remove it, although"
++ echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH" ],
++ [ echo "*** The test program failed to compile or link. See the file config.log for the"
++ echo "*** exact error that occured. This usually means GTK+ is incorrectly installed."])
++ CFLAGS="$ac_save_CFLAGS"
++ LIBS="$ac_save_LIBS"
++ fi
++ fi
++ GTK_CFLAGS=""
++ GTK_LIBS=""
++ ifelse([$3], , :, [$3])
++ fi
++ AC_SUBST(GTK_CFLAGS)
++ AC_SUBST(GTK_LIBS)
++ rm -f conf.gtktest
++])
++
++dnl GTK_CHECK_BACKEND(BACKEND-NAME [, MINIMUM-VERSION [, ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]]])
++dnl Tests for BACKEND-NAME in the GTK targets list
++dnl
++AC_DEFUN([GTK_CHECK_BACKEND],
++[
++ pkg_config_args=ifelse([$1],,gtk+-3.0, gtk+-$1-3.0)
++ min_gtk_version=ifelse([$2],,3.0.0,$2)
++
++ AC_PATH_PROG(PKG_CONFIG, [pkg-config], [AC_MSG_ERROR([No pkg-config found])])
++
++ if $PKG_CONFIG --atleast-version $min_gtk_version $pkg_config_args ; then
++ target_found=yes
++ else
++ target_found=no
++ fi
++
++ if test "x$target_found" = "xno"; then
++ ifelse([$4],,[AC_MSG_ERROR([Backend $backend not found.])],[$4])
++ else
++ ifelse([$3],,[:],[$3])
++ fi
++])