From 67b7e18a754d3a945808d79093f6bd85d7f0023f Mon Sep 17 00:00:00 2001
From: Sam James <sam@gentoo.org>
Date: Thu, 1 Sep 2022 01:57:51 +0100
Subject: sys-cluster/libquo: fix MissingUseDepDefault

Upstream ported to newer hwloc in
https://github.com/lanl/libquo/commit/3e150fa2e66ed8674e17e2d7860b23e71dd3866b.

Signed-off-by: Sam James <sam@gentoo.org>
---
 sys-cluster/libquo/libquo-1.3.1-r1.ebuild | 41 -------------------------------
 sys-cluster/libquo/libquo-1.3.1-r2.ebuild | 41 +++++++++++++++++++++++++++++++
 sys-cluster/libquo/libquo-9999.ebuild     |  4 +--
 3 files changed, 43 insertions(+), 43 deletions(-)
 delete mode 100644 sys-cluster/libquo/libquo-1.3.1-r1.ebuild
 create mode 100644 sys-cluster/libquo/libquo-1.3.1-r2.ebuild

(limited to 'sys-cluster')

diff --git a/sys-cluster/libquo/libquo-1.3.1-r1.ebuild b/sys-cluster/libquo/libquo-1.3.1-r1.ebuild
deleted file mode 100644
index 3d9b0bc1a748..000000000000
--- a/sys-cluster/libquo/libquo-1.3.1-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-FORTRAN_NEEDED=fortran
-FORTRAN_STANDARD=90
-
-inherit fortran-2
-
-if [ "${PV}" = "9999" ]; then
-	EGIT_REPO_URI="https://github.com/lanl/${PN}.git"
-	inherit autotools git-r3
-else
-	SRC_URI="https://lanl.github.io/${PN}/dists/${P}.tar.gz"
-	KEYWORDS="~amd64"
-fi
-
-DESCRIPTION="Run-time tuning of process binding policies made easy"
-HOMEPAGE="https://lanl.github.io/libquo/"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="fortran static-libs test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
-	virtual/mpi[fortran?]
-	sys-process/numactl
-	sys-apps/hwloc:=[numa,xml]
-	"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
-	default
-	[[ ${PV} = 9999 ]] && eautoreconf
-}
-
-src_configure() {
-	econf CC=mpicc FC=$(usex fortran mpif90 false)
-}
diff --git a/sys-cluster/libquo/libquo-1.3.1-r2.ebuild b/sys-cluster/libquo/libquo-1.3.1-r2.ebuild
new file mode 100644
index 000000000000..e50bb9edbd6b
--- /dev/null
+++ b/sys-cluster/libquo/libquo-1.3.1-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+FORTRAN_NEEDED=fortran
+FORTRAN_STANDARD=90
+
+inherit fortran-2
+
+if [ "${PV}" = "9999" ]; then
+	EGIT_REPO_URI="https://github.com/lanl/${PN}.git"
+	inherit autotools git-r3
+else
+	SRC_URI="https://lanl.github.io/${PN}/dists/${P}.tar.gz"
+	KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Run-time tuning of process binding policies made easy"
+HOMEPAGE="https://lanl.github.io/libquo/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="fortran static-libs test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+	virtual/mpi[fortran?]
+	sys-process/numactl
+	sys-apps/hwloc:=[numa(+),xml]
+	"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+	default
+	[[ ${PV} = 9999 ]] && eautoreconf
+}
+
+src_configure() {
+	econf CC=mpicc FC=$(usex fortran mpif90 false)
+}
diff --git a/sys-cluster/libquo/libquo-9999.ebuild b/sys-cluster/libquo/libquo-9999.ebuild
index 3d9b0bc1a748..e50bb9edbd6b 100644
--- a/sys-cluster/libquo/libquo-9999.ebuild
+++ b/sys-cluster/libquo/libquo-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=8
@@ -27,7 +27,7 @@ RESTRICT="!test? ( test )"
 DEPEND="
 	virtual/mpi[fortran?]
 	sys-process/numactl
-	sys-apps/hwloc:=[numa,xml]
+	sys-apps/hwloc:=[numa(+),xml]
 	"
 RDEPEND="${DEPEND}"
 
-- 
cgit v1.2.3-65-gdbad