From 1c80883eeaa9d8e18f343ac6ac2d833d6a6a2479 Mon Sep 17 00:00:00 2001
From: Michał Górny <mgorny@gentoo.org>
Date: Fri, 21 Jun 2024 17:11:30 +0200
Subject: dev-python/selenium: Add missing websocket-client dep
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Closes: https://bugs.gentoo.org/934645
Signed-off-by: Michał Górny <mgorny@gentoo.org>
---
 dev-python/selenium/selenium-4.22.0-r1.ebuild | 72 +++++++++++++++++++++++++++
 dev-python/selenium/selenium-4.22.0.ebuild    | 71 --------------------------
 2 files changed, 72 insertions(+), 71 deletions(-)
 create mode 100644 dev-python/selenium/selenium-4.22.0-r1.ebuild
 delete mode 100644 dev-python/selenium/selenium-4.22.0.ebuild

(limited to 'dev-python/selenium')

diff --git a/dev-python/selenium/selenium-4.22.0-r1.ebuild b/dev-python/selenium/selenium-4.22.0-r1.ebuild
new file mode 100644
index 000000000000..9a743e2e46f4
--- /dev/null
+++ b/dev-python/selenium/selenium-4.22.0-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_TESTED=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" python3_13 )
+
+inherit distutils-r1 pypi
+
+# upstream sometimes tags it as ${P}, sometimes as ${P}-python, sigh
+TEST_TAG=${P}
+TEST_P=selenium-${TEST_TAG}
+
+DESCRIPTION="Python language binding for Selenium Remote Control"
+HOMEPAGE="
+	https://www.seleniumhq.org/
+	https://github.com/SeleniumHQ/selenium/tree/trunk/py/
+	https://pypi.org/project/selenium/
+"
+SRC_URI+="
+	test? (
+		https://github.com/SeleniumHQ/selenium/archive/${TEST_TAG}.tar.gz
+			-> ${TEST_P}.gh.tar.gz
+	)
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+	>=dev-python/certifi-2021.10.8[${PYTHON_USEDEP}]
+	<dev-python/trio-1[${PYTHON_USEDEP}]
+	>=dev-python/trio-0.17[${PYTHON_USEDEP}]
+	<dev-python/trio-websocket-1[${PYTHON_USEDEP}]
+	>=dev-python/trio-websocket-0.9[${PYTHON_USEDEP}]
+	<dev-python/typing-extensions-5[${PYTHON_USEDEP}]
+	>=dev-python/typing-extensions-4.9[${PYTHON_USEDEP}]
+	<dev-python/urllib3-3[${PYTHON_USEDEP}]
+	>=dev-python/urllib3-1.26[${PYTHON_USEDEP}]
+	>=dev-python/websocket-client-1.8.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+	test? (
+		dev-python/pytest-mock[${PYTHON_USEDEP}]
+	)
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+	if ! has "${EPYTHON/./_}" "${PYTHON_TESTED[@]}"; then
+		einfo "Skipping tests on ${EPYTHON}"
+		return
+	fi
+
+	local EPYTEST_DESELECT=(
+		# TODO: we may need extra setup or deps
+		test/selenium
+
+		# expects vanilla certifi
+		test/unit/selenium/webdriver/remote/remote_connection_tests.py::test_get_connection_manager_for_certs_and_timeout
+	)
+
+	cd "${WORKDIR}/${TEST_P}/py" || die
+	rm -rf selenium || die
+	# https://github.com/SeleniumHQ/selenium/blob/selenium-4.8.2-python/py/test/runner/run_pytest.py#L20-L24
+	# seriously?
+	epytest -o "python_files=*_tests.py test_*.py"
+}
diff --git a/dev-python/selenium/selenium-4.22.0.ebuild b/dev-python/selenium/selenium-4.22.0.ebuild
deleted file mode 100644
index e5f0a6117408..000000000000
--- a/dev-python/selenium/selenium-4.22.0.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_TESTED=( python3_{10..12} pypy3 )
-PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" python3_13 )
-
-inherit distutils-r1 pypi
-
-# upstream sometimes tags it as ${P}, sometimes as ${P}-python, sigh
-TEST_TAG=${P}
-TEST_P=selenium-${TEST_TAG}
-
-DESCRIPTION="Python language binding for Selenium Remote Control"
-HOMEPAGE="
-	https://www.seleniumhq.org/
-	https://github.com/SeleniumHQ/selenium/tree/trunk/py/
-	https://pypi.org/project/selenium/
-"
-SRC_URI+="
-	test? (
-		https://github.com/SeleniumHQ/selenium/archive/${TEST_TAG}.tar.gz
-			-> ${TEST_P}.gh.tar.gz
-	)
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
-	>=dev-python/certifi-2021.10.8[${PYTHON_USEDEP}]
-	<dev-python/trio-1[${PYTHON_USEDEP}]
-	>=dev-python/trio-0.17[${PYTHON_USEDEP}]
-	<dev-python/trio-websocket-1[${PYTHON_USEDEP}]
-	>=dev-python/trio-websocket-0.9[${PYTHON_USEDEP}]
-	<dev-python/typing-extensions-5[${PYTHON_USEDEP}]
-	>=dev-python/typing-extensions-4.9[${PYTHON_USEDEP}]
-	<dev-python/urllib3-3[${PYTHON_USEDEP}]
-	>=dev-python/urllib3-1.26[${PYTHON_USEDEP}]
-"
-BDEPEND="
-	test? (
-		dev-python/pytest-mock[${PYTHON_USEDEP}]
-	)
-"
-
-distutils_enable_tests pytest
-
-python_test() {
-	if ! has "${EPYTHON/./_}" "${PYTHON_TESTED[@]}"; then
-		einfo "Skipping tests on ${EPYTHON}"
-		return
-	fi
-
-	local EPYTEST_DESELECT=(
-		# TODO: we may need extra setup or deps
-		test/selenium
-
-		# expects vanilla certifi
-		test/unit/selenium/webdriver/remote/remote_connection_tests.py::test_get_connection_manager_for_certs_and_timeout
-	)
-
-	cd "${WORKDIR}/${TEST_P}/py" || die
-	rm -rf selenium || die
-	# https://github.com/SeleniumHQ/selenium/blob/selenium-4.8.2-python/py/test/runner/run_pytest.py#L20-L24
-	# seriously?
-	epytest -o "python_files=*_tests.py test_*.py"
-}
-- 
cgit v1.2.3-65-gdbad