From 9b4665ba3d5478661fb0d5ff0085288c14797e03 Mon Sep 17 00:00:00 2001
From: Matthew Thode <prometheanfire@gentoo.org>
Date: Tue, 13 Dec 2022 11:04:50 -0600
Subject: app-admin/puppet: drop 7.19.0

Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
---
 app-admin/puppet/Manifest             |   1 -
 app-admin/puppet/puppet-7.19.0.ebuild | 127 ----------------------------------
 2 files changed, 128 deletions(-)
 delete mode 100644 app-admin/puppet/puppet-7.19.0.ebuild

(limited to 'app-admin/puppet')

diff --git a/app-admin/puppet/Manifest b/app-admin/puppet/Manifest
index 4b5446af3f98..a28b469a3fa4 100644
--- a/app-admin/puppet/Manifest
+++ b/app-admin/puppet/Manifest
@@ -1,4 +1,3 @@
 DIST puppet-5.5.22.tar.gz 2998132 BLAKE2B 8662c89190d0904fe44ffeca1cf9a9ddca40d57ba6fb2d1e644ca353ceb55b1ca3a91416f1eef2975233c9c4498784e7d7280c111ea0cc070870cadc69341d99 SHA512 5332b084a63bdf244672cc4751022c84a1cc50d3f394a13bdcbccf7fcf4ebea67953e88957f23046608bf25e9182548449be824c18289cb2bf1e3ed29b40dc58
-DIST puppet-7.19.0.tar.gz 2817098 BLAKE2B d2d756aa236461963ac260167f9500693ea94f1b2ce7b6f881c55712f78668ce5935528a74d3a77e5b02123aeb4404c1bbfc91237622dcb68e686e920302acb9 SHA512 952ae1e77e9d9aaa0a0a731f408550fd3bf483dda9bbb12845e534e6208321db774325da8621f36535d7601bd7b8611098e486ef733428b7108f613f5dade4e0
 DIST puppet-7.20.0.tar.gz 2817232 BLAKE2B 479c4e162230371bd69509844fcd97d0d3392eb2e66578b38e6dc120dd3dd15804d73f70c1b29f1f3d9e57af539f82e605a86c9afff15e78ff48ddf482432c4d SHA512 6774bf03ad0ee80c0fd2cd8ebad60da56df7ed9818a526084fc2cf1ba2fecc81555fff200f5feef2b5d7a2275d90f44b24160de7221d682de470b511a7051f7f
 DIST puppet-7.21.0.tar.gz 2819997 BLAKE2B 96de8ceefeea12c51288e05af5d7b126811d23388492053b0d581856f11976f0492064eb89bc585ff7f455df537d5c04fb318814945a158d531d32efdd54ff02 SHA512 b0fbdf63391054d0496c67be963f98e3d85e3a1536e50d6a3f09d0c49110bb4c92bebdc38a48cd50e824e27268150cda0643c6df0edb01b3587f00a591645ee6
diff --git a/app-admin/puppet/puppet-7.19.0.ebuild b/app-admin/puppet/puppet-7.19.0.ebuild
deleted file mode 100644
index b0c6d6d3ffe3..000000000000
--- a/app-admin/puppet/puppet-7.19.0.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_TASK_DOC="doc:all"
-RUBY_FAKEGEM_EXTRAINSTALL="locales"
-
-inherit ruby-fakegem systemd tmpfiles
-
-DESCRIPTION="A system automation and configuration management software"
-HOMEPAGE="https://puppet.com/"
-SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 x86"
-IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite vim-syntax"
-RESTRICT="test"
-
-ruby_add_rdepend "
-	dev-ruby/hiera
-	dev-ruby/json:=
-	dev-ruby/semantic_puppet
-	>=dev-ruby/facter-3.0.0
-	dev-ruby/concurrent-ruby
-	augeas? ( dev-ruby/ruby-augeas )
-	diff? ( dev-ruby/diff-lcs )
-	doc? ( dev-ruby/rdoc )
-	ldap? ( dev-ruby/ruby-ldap )
-	shadow? ( dev-ruby/ruby-shadow )
-	sqlite? ( dev-ruby/sqlite3 )
-	virtual/ruby-ssl
-	dev-ruby/hocon"
-
-ruby_add_bdepend "
-	doc? ( dev-ruby/yard )
-	test? (
-		dev-ruby/mocha
-		dev-ruby/rack
-		dev-ruby/rspec-its
-	)"
-# this should go in the above lists, but isn't because of test deps not being keyworded
-#   dev-ruby/rspec-collection_matchers
-
-RDEPEND+=" ${RDEPEND}
-	rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
-	selinux? (
-		sys-libs/libselinux[ruby]
-		sec-policy/selinux-puppet
-	)
-	vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
-	>=app-portage/eix-0.18.0
-	acct-user/puppet
-	acct-group/puppet"
-PDEPEND="emacs? ( >=app-emacs/puppet-mode-0.3-r1 )"
-
-all_ruby_prepare() {
-	# Avoid spec that require unpackaged json-schema.
-	rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
-
-	# fix systemd path
-	eapply -p0 "${FILESDIR}/puppet-systemd.patch"
-
-	# Avoid specs that can only run in the puppet.git repository. This
-	# should be narrowed down to the specific specs.
-	rm spec/integration/parser/compiler_spec.rb || die
-
-	# Avoid failing spec that need further investigation.
-	rm spec/unit/module_tool/metadata_spec.rb || die
-}
-
-each_ruby_install() {
-	each_fakegem_install
-#	dosym "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${P}" "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${PN}"
-}
-
-all_ruby_install() {
-	all_fakegem_install
-
-	# systemd stuffs
-	systemd_dounit "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
-
-	# tmpfiles stuff
-	newtmpfiles "${FILESDIR}/tmpfiles.d" "puppet.conf"
-
-	# openrc init stuff
-	newinitd "${FILESDIR}"/puppet.init-4.x puppet
-
-	keepdir /etc/puppetlabs/puppet/ssl
-
-	keepdir /var/lib/puppet/facts
-	keepdir /var/lib/puppet/files
-	fowners -R puppet:puppet /var/lib/puppet
-
-	fperms 0750 /var/lib/puppet
-
-	fperms 0750 /etc/puppetlabs
-	fperms 0750 /etc/puppetlabs/puppet
-	fperms 0750 /etc/puppetlabs/puppet/ssl
-	fowners -R :puppet /etc/puppetlabs
-	fowners -R :puppet /var/lib/puppet
-
-	# ext and examples files
-	for f in $(find ext examples -type f) ; do
-		docinto "$(dirname ${f})"
-		dodoc "${f}"
-	done
-}
-
-pkg_postinst() {
-	tmpfiles_process puppet.conf
-
-	elog
-	elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
-	elog "cause puppet to hang while installing packages."
-	elog
-	elog "Portage Puppet module with Gentoo-specific resources:"
-	elog "http://forge.puppetlabs.com/gentoo/portage"
-	elog
-	elog "If updating from puppet 5 to 6, keep in mind that webrick (server/master)"
-	elog "suppert was removed for >=6.x, please migrate to puppetserver if you have"
-	elog "not already done so."
-	elog
-}
-- 
cgit v1.2.3-65-gdbad