summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libxkbcommon/Manifest3
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-1.0.3.ebuild65
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-1.1.0.ebuild65
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-1.2.1.ebuild65
4 files changed, 0 insertions, 198 deletions
diff --git a/x11-libs/libxkbcommon/Manifest b/x11-libs/libxkbcommon/Manifest
index b2765cfb2c5e..4d717f518ba9 100644
--- a/x11-libs/libxkbcommon/Manifest
+++ b/x11-libs/libxkbcommon/Manifest
@@ -1,4 +1 @@
-DIST libxkbcommon-1.0.3.tar.xz 432944 BLAKE2B 49dcefcc17cbbfe5623728e9852e700a623e07ad7e6df78c8d7c39784948eb230f9e141d8aaa1de94305cb552244fe54d384abbc8e57f5ec5846915b5ae484e3 SHA512 b05a2db0acd6628427baad1967979a161019dec90a078a926d41f4dfeffb84eab63e627803df1a401e42c8e48953d6c434ce08d7206eae21e890890f29b03d3c
-DIST libxkbcommon-1.1.0.tar.xz 439488 BLAKE2B ddccb9942af5f5d80b750bf8f02289e073615c99bed2a8f7ff1d03ca70bffdbe3b1fe15daef2346819887efe10a308d00f671fc2ae50e0fe33e76e4b748f6d01 SHA512 6137329653ada711abc0e093532627111ab1fb53e6b2b0d05ec4d77709cfc4368f094ebbf68b23c8e9af9a69826351b64466e81c11e6593eafa7e43cd3e7bf75
-DIST libxkbcommon-1.2.1.tar.xz 453172 BLAKE2B f8846befae348287032601f589607a9c899826135b325245824650d77435050fe7e300514cc9f16bd0f3c37693c9f8f08d78aa738c160676019338d72addcd80 SHA512 28de91166a289586a78068b725b904da46fca144936ea0677ec9234c7f0499b9ae321d79c57f15782b63c6e7a37b074fe44648673a2294bbde13110195567e3b
DIST libxkbcommon-1.3.0.tar.xz 455256 BLAKE2B f53a47005dd411855d1d5c39a33ef58d22982b2d4c2014320722f7fe9a9b468366c6090fadd067e50a846f22de7b80164b684615a8bcb1b14a478609cc4deb74 SHA512 9585ab1df7f2d95b991a786ee1f1de0a645aa315edb93cb093f3409fc76ef7b8f8189a6a7bfd179dc01c5d105d9c9eea40a395762eeffe0618b0c3ee116c0d18
diff --git a/x11-libs/libxkbcommon/libxkbcommon-1.0.3.ebuild b/x11-libs/libxkbcommon/libxkbcommon-1.0.3.ebuild
deleted file mode 100644
index b41c3709264f..000000000000
--- a/x11-libs/libxkbcommon/libxkbcommon-1.0.3.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-if [[ ${PV} = *9999* ]]; then
- GIT_ECLASS="git-r3"
- EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
-else
- SRC_URI="https://xkbcommon.org/download/${P}.tar.xz"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-fi
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit meson multilib-minimal ${GIT_ECLASS} python-any-r1
-
-DESCRIPTION="keymap handling library for toolkits and window systems"
-HOMEPAGE="https://xkbcommon.org/ https://github.com/xkbcommon/libxkbcommon/"
-LICENSE="MIT"
-IUSE="X doc static-libs test"
-RESTRICT="!test? ( test )"
-SLOT="0"
-
-BDEPEND="
- sys-devel/bison
- doc? ( app-doc/doxygen )
- test? ( ${PYTHON_DEPS} )
-"
-RDEPEND="
- X? ( >=x11-libs/libxcb-1.10:=[${MULTILIB_USEDEP},xkb] )
- dev-libs/libxml2[${MULTILIB_USEDEP}]
- x11-misc/compose-tables
-"
-DEPEND="${RDEPEND}
- X? ( x11-base/xorg-proto )"
-
-pkg_setup() {
- if use test; then
- python-any-r1_pkg_setup
- fi
-}
-
-multilib_src_configure() {
- local emesonargs=(
- -Ddefault_library="$(usex static-libs both shared)"
- -Dxkb-config-root="${EPREFIX}/usr/share/X11/xkb"
- -Denable-wayland=false # Demo applications
- $(meson_use X enable-x11)
- $(meson_use doc enable-docs)
- )
- meson_src_configure
-}
-
-multilib_src_compile() {
- meson_src_compile
-}
-
-multilib_src_test() {
- meson_src_test
-}
-
-multilib_src_install() {
- meson_src_install
-}
diff --git a/x11-libs/libxkbcommon/libxkbcommon-1.1.0.ebuild b/x11-libs/libxkbcommon/libxkbcommon-1.1.0.ebuild
deleted file mode 100644
index 31300e452df1..000000000000
--- a/x11-libs/libxkbcommon/libxkbcommon-1.1.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-if [[ ${PV} = *9999* ]]; then
- GIT_ECLASS="git-r3"
- EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
-else
- SRC_URI="https://github.com/xkbcommon/libxkbcommon/releases/download/xkbcommon-${PV}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-fi
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit meson multilib-minimal ${GIT_ECLASS} python-any-r1
-
-DESCRIPTION="keymap handling library for toolkits and window systems"
-HOMEPAGE="https://xkbcommon.org/ https://github.com/xkbcommon/libxkbcommon/"
-LICENSE="MIT"
-IUSE="X doc static-libs test"
-RESTRICT="!test? ( test )"
-SLOT="0"
-
-BDEPEND="
- sys-devel/bison
- doc? ( app-doc/doxygen )
- test? ( ${PYTHON_DEPS} )
-"
-RDEPEND="
- X? ( >=x11-libs/libxcb-1.10:=[${MULTILIB_USEDEP},xkb] )
- dev-libs/libxml2[${MULTILIB_USEDEP}]
- x11-misc/compose-tables
-"
-DEPEND="${RDEPEND}
- X? ( x11-base/xorg-proto )"
-
-pkg_setup() {
- if use test; then
- python-any-r1_pkg_setup
- fi
-}
-
-multilib_src_configure() {
- local emesonargs=(
- -Ddefault_library="$(usex static-libs both shared)"
- -Dxkb-config-root="${EPREFIX}/usr/share/X11/xkb"
- -Denable-wayland=false # Demo applications
- $(meson_use X enable-x11)
- $(meson_use doc enable-docs)
- )
- meson_src_configure
-}
-
-multilib_src_compile() {
- meson_src_compile
-}
-
-multilib_src_test() {
- meson_src_test
-}
-
-multilib_src_install() {
- meson_src_install
-}
diff --git a/x11-libs/libxkbcommon/libxkbcommon-1.2.1.ebuild b/x11-libs/libxkbcommon/libxkbcommon-1.2.1.ebuild
deleted file mode 100644
index c34ea6d0be18..000000000000
--- a/x11-libs/libxkbcommon/libxkbcommon-1.2.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-if [[ ${PV} = *9999* ]]; then
- GIT_ECLASS="git-r3"
- EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
-else
- SRC_URI="https://xkbcommon.org/download/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-fi
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit meson multilib-minimal ${GIT_ECLASS} python-any-r1
-
-DESCRIPTION="keymap handling library for toolkits and window systems"
-HOMEPAGE="https://xkbcommon.org/ https://github.com/xkbcommon/libxkbcommon/"
-LICENSE="MIT"
-IUSE="X doc static-libs test"
-RESTRICT="!test? ( test )"
-SLOT="0"
-
-BDEPEND="
- sys-devel/bison
- doc? ( app-doc/doxygen )
- test? ( ${PYTHON_DEPS} )
-"
-RDEPEND="
- X? ( >=x11-libs/libxcb-1.10:=[${MULTILIB_USEDEP},xkb] )
- dev-libs/libxml2[${MULTILIB_USEDEP}]
- x11-misc/compose-tables
-"
-DEPEND="${RDEPEND}
- X? ( x11-base/xorg-proto )"
-
-pkg_setup() {
- if use test; then
- python-any-r1_pkg_setup
- fi
-}
-
-multilib_src_configure() {
- local emesonargs=(
- -Ddefault_library="$(usex static-libs both shared)"
- -Dxkb-config-root="${EPREFIX}/usr/share/X11/xkb"
- -Denable-wayland=false # Demo applications
- $(meson_use X enable-x11)
- $(meson_use doc enable-docs)
- )
- meson_src_configure
-}
-
-multilib_src_compile() {
- meson_src_compile
-}
-
-multilib_src_test() {
- meson_src_test
-}
-
-multilib_src_install() {
- meson_src_install
-}