summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/watchdog')
-rw-r--r--sys-apps/watchdog/files/watchdog-5.16-implicit-func-decls-musl.patch30
-rw-r--r--sys-apps/watchdog/watchdog-5.16-r1.ebuild42
2 files changed, 72 insertions, 0 deletions
diff --git a/sys-apps/watchdog/files/watchdog-5.16-implicit-func-decls-musl.patch b/sys-apps/watchdog/files/watchdog-5.16-implicit-func-decls-musl.patch
new file mode 100644
index 000000000000..82f41ed63420
--- /dev/null
+++ b/sys-apps/watchdog/files/watchdog-5.16-implicit-func-decls-musl.patch
@@ -0,0 +1,30 @@
+https://cgit.openembedded.org/openembedded-core/plain/meta/recipes-extended/watchdog/watchdog/0001-shutdown-Do-not-guard-sys-quota.h-sys-swap.h-and-sys.patch?id=a53722b962e79e0831c0fba24ef7c1cfda24971a
+
+From ca1d379fa13c4055d42d2ff3a647b4397768efcd Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 23 Aug 2022 19:23:26 -0700
+Subject: [PATCH] shutdown: Do not guard sys/quota.h sys/swap.h and
+ sys/reboot.h with __GLIBC__
+
+These headers are provided by uclibc/musl/glibc and bionic so we can
+assume they are not needed to be glibc specific includes. This also
+ensures that we get proper declaration of reboot() API
+
+Upstream-Status: Submitted [https://sourceforge.net/p/watchdog/patches/12/]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/src/shutdown.c
++++ b/src/shutdown.c
+@@ -29,13 +29,9 @@
+ #include "extern.h"
+ #include "ext2_mnt.h"
+
+-#if defined __GLIBC__
+ #include <sys/quota.h>
+ #include <sys/swap.h>
+ #include <sys/reboot.h>
+-#else /* __GLIBC__ */
+-#include <linux/quota.h>
+-#endif /* __GLIBC__ */
+
+ #include <unistd.h>
+
diff --git a/sys-apps/watchdog/watchdog-5.16-r1.ebuild b/sys-apps/watchdog/watchdog-5.16-r1.ebuild
new file mode 100644
index 000000000000..896261cadca2
--- /dev/null
+++ b/sys-apps/watchdog/watchdog-5.16-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic systemd toolchain-funcs
+
+DESCRIPTION="A software watchdog and /dev/watchdog daemon"
+HOMEPAGE="https://sourceforge.net/projects/watchdog/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="nfs"
+
+RDEPEND="nfs? ( net-libs/libtirpc )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.16-implicit-func-decls-musl.patch
+)
+
+src_configure() {
+ if use nfs; then
+ append-cppflags "$($(tc-getPKG_CONFIG) libtirpc --cflags)"
+ append-libs "$($(tc-getPKG_CONFIG) libtirpc --libs)"
+ fi
+ econf $(use_enable nfs)
+}
+
+src_install() {
+ default
+ dodoc -r examples
+
+ newconfd "${FILESDIR}"/${PN}-conf.d ${PN}
+ newinitd "${FILESDIR}"/${PN}-init.d-r1 ${PN}
+ systemd_dounit "${FILESDIR}"/watchdog.service
+}