summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ncdc/Manifest1
-rw-r--r--net-p2p/ncdc/ncdc-1.23.ebuild59
-rw-r--r--net-p2p/ncdc/ncdc-9999.ebuild15
3 files changed, 69 insertions, 6 deletions
diff --git a/net-p2p/ncdc/Manifest b/net-p2p/ncdc/Manifest
index e3553ce01161..7fd4e557d289 100644
--- a/net-p2p/ncdc/Manifest
+++ b/net-p2p/ncdc/Manifest
@@ -1 +1,2 @@
DIST ncdc-1.22.1.tar.gz 371572 BLAKE2B 22125062a42f77e8a7a8afc699523b27a2b7ec566891676ca13b415e93cdae8e2d8d38f303070c7f098408f537266404a875b9ed7f9931a39933916a0ba576ab SHA512 b084ee28a799705009600c450016719ebb992cb0bf7e026513f4cd7e93b2566e7bf8e352eec92f3d69612ce06c930587759d7f7d20d14ee9fe1d5c4b8c4393af
+DIST ncdc-1.23.tar.gz 378384 BLAKE2B 0558b8b51f9cda81ec553171f76a0f6c29a1a67e6f69c5cc2c181428f3bb1db2ecd5a9c2f0c609dac53323ad62e478171121572f0a9d707d9d6d9e9727441873 SHA512 c1b2098df517631a64b24efaeb328a796ed716dca08b61248bb39bba866055ce1e017f33cc594197824476ec65ada53b13bfb56878b5b8aa330288017ad15df2
diff --git a/net-p2p/ncdc/ncdc-1.23.ebuild b/net-p2p/ncdc/ncdc-1.23.ebuild
new file mode 100644
index 000000000000..dea5357e9c22
--- /dev/null
+++ b/net-p2p/ncdc/ncdc-1.23.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="ncurses directconnect client"
+HOMEPAGE="https://dev.yorhel.nl/ncdc"
+if [[ ${PV} == *9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://g.blicky.net/ncdc.git"
+else
+ SRC_URI="https://dev.yorhel.nl/download/${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="geoip"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.32:2
+ >=net-libs/gnutls-3:=
+ sys-libs/ncurses:=[unicode(+)]
+ sys-libs/zlib:=
+ geoip? (
+ dev-libs/geoip
+ dev-libs/libmaxminddb
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/makeheaders
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with geoip)
+ )
+
+ if [[ ${PV} == *9999 ]] ; then
+ myeconfargs+=( --enable-git-version )
+ fi
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
diff --git a/net-p2p/ncdc/ncdc-9999.ebuild b/net-p2p/ncdc/ncdc-9999.ebuild
index f6cebc9b3c0a..e001c6590371 100644
--- a/net-p2p/ncdc/ncdc-9999.ebuild
+++ b/net-p2p/ncdc/ncdc-9999.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="ncurses directconnect client"
HOMEPAGE="https://dev.yorhel.nl/ncdc"
-if [[ "${PV}" == *9999 ]] ; then
+if [[ ${PV} == *9999 ]] ; then
inherit autotools git-r3
EGIT_REPO_URI="git://g.blicky.net/ncdc.git"
else
@@ -22,7 +22,7 @@ IUSE="geoip"
RDEPEND="
app-arch/bzip2
dev-db/sqlite:3
- dev-libs/glib:2
+ >=dev-libs/glib-2.32:2
net-libs/gnutls:=
sys-libs/ncurses:=[unicode(+)]
sys-libs/zlib:=
@@ -38,16 +38,19 @@ BDEPEND="
src_prepare() {
default
- [[ "${PV}" == *9999 ]] && eautoreconf
+
+ [[ ${PV} == *9999 ]] && eautoreconf
}
src_configure() {
local myeconfargs=(
$(use_with geoip)
)
- if [[ "${PV}" == *9999 ]] ; then
+
+ if [[ ${PV} == *9999 ]] ; then
myeconfargs+=( --enable-git-version )
fi
+
econf "${myeconfargs[@]}"
}