summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/altermime/files/altermime-0.3.11-respect-flags.patch')
-rw-r--r--net-mail/altermime/files/altermime-0.3.11-respect-flags.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/net-mail/altermime/files/altermime-0.3.11-respect-flags.patch b/net-mail/altermime/files/altermime-0.3.11-respect-flags.patch
new file mode 100644
index 000000000000..9f114ca17491
--- /dev/null
+++ b/net-mail/altermime/files/altermime-0.3.11-respect-flags.patch
@@ -0,0 +1,20 @@
+--- altermime-0.3.11.orig/Makefile
++++ altermime-0.3.11/Makefile
+@@ -9,7 +9,7 @@
+ # opposite of a disclaimer.
+ ALTERMIME_OPTIONS=-DALTERMIME_PRETEXT
+ #ALTERMIME_OPTIONS=
+-CFLAGS=-Wall -Werror -g -I. -O2 $(ALTERMIME_OPTIONS)
++CFLAGS+=-Wall $(ALTERMIME_OPTIONS)
+ OBJS= strstack.o mime_alter.o ffget.o pldstr.o filename-filters.o logger.o MIME_headers.o libmime-decoders.o boundary-stack.o qpe.o
+
+
+@@ -19,7 +19,7 @@
+ all: altermime
+
+ altermime: altermime.c ${OBJS}
+- ${CC} ${CFLAGS} altermime.c ${OBJS} -o altermime
++ ${CC} ${CFLAGS} ${LDFLAGS} altermime.c ${OBJS} -o altermime
+
+
+ # Build Install