summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/kino')
-rw-r--r--media-video/kino/files/kino-1.3.4-ffmpeg4.patch13
-rw-r--r--media-video/kino/kino-1.3.4-r1.ebuild3
2 files changed, 15 insertions, 1 deletions
diff --git a/media-video/kino/files/kino-1.3.4-ffmpeg4.patch b/media-video/kino/files/kino-1.3.4-ffmpeg4.patch
new file mode 100644
index 000000000000..b0f359f06ba3
--- /dev/null
+++ b/media-video/kino/files/kino-1.3.4-ffmpeg4.patch
@@ -0,0 +1,13 @@
+diff --git a/old/frame.cc b/src/frame.cc
+index c88508f..1e2573a 100644
+--- a/old/frame.cc
++++ b/src/frame.cc
+@@ -1367,7 +1367,7 @@ bool Frame::CreateEncoder( bool isPAL, bool isWide )
+ avcodecEncoder->thread_count = 2;
+ avcodecEncoder->time_base= isPAL ? ( AVRational ){ 1, 25 } : ( AVRational ){ 1001, 30000 };
+ avcodecEncoder->pix_fmt = isPAL ? AV_PIX_FMT_YUV420P : AV_PIX_FMT_YUV411P;
+- avcodecEncoder->flags |= CODEC_FLAG_INTERLACED_DCT;
++ avcodecEncoder->flags |= AV_CODEC_FLAG_INTERLACED_DCT;
+ avcodec_open2( avcodecEncoder, avcodec_find_encoder( AV_CODEC_ID_DVVIDEO ), NULL );
+ av_new_packet( &avpacketEncoder, 144000 );
+ tempImage = ( uint8_t* ) av_malloc(
diff --git a/media-video/kino/kino-1.3.4-r1.ebuild b/media-video/kino/kino-1.3.4-r1.ebuild
index cb82c2338e31..9fc8dbb085ae 100644
--- a/media-video/kino/kino-1.3.4-r1.ebuild
+++ b/media-video/kino/kino-1.3.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -81,6 +81,7 @@ src/page_bttv.cc' po/POTFILES.in || die
eapply "${FILESDIR}/${P}-libav-0.8.patch"
eapply "${FILESDIR}/${P}-libavcodec-pkg-config.patch"
eapply "${FILESDIR}/${P}-ffmpeg3.patch"
+ eapply "${FILESDIR}/${P}-ffmpeg4.patch"
mv configure.in configure.ac || die
eautoreconf