summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/bempc')
-rw-r--r--media-sound/bempc/Manifest1
-rw-r--r--media-sound/bempc/bempc-0.11.ebuild44
-rw-r--r--media-sound/bempc/metadata.xml9
3 files changed, 54 insertions, 0 deletions
diff --git a/media-sound/bempc/Manifest b/media-sound/bempc/Manifest
new file mode 100644
index 000000000000..0d50a2fe3a00
--- /dev/null
+++ b/media-sound/bempc/Manifest
@@ -0,0 +1 @@
+DIST bempc-0.11.tar.xz 182588 SHA256 62ce13e82c42b891d2e49ff691f2c7c60b8d62809ea44f729af5e1685a108703 SHA512 ec1cd82d7b93b45c16ff54e6e14f0625af0042b863c65f72e06eeaf67933384fd527f6db15725363fc02ca1ce9a6855fbf215da2bef2e8c52e8fec70d742de5c WHIRLPOOL 1e72200c28928aee34a3458a45012990ca22619024c8adf700b6a789e188b6a6ab7526a317945dde7a5ce567240b1a9154364a2a2d2eb0d5c75538d56e72a113
diff --git a/media-sound/bempc/bempc-0.11.ebuild b/media-sound/bempc/bempc-0.11.ebuild
new file mode 100644
index 000000000000..350de0bc1aa8
--- /dev/null
+++ b/media-sound/bempc/bempc-0.11.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+LANGS="cs de"
+inherit qt4-r2 fdo-mime
+
+DESCRIPTION="Qt4 MPD client with experimental UI"
+HOMEPAGE="http://qt-apps.org/content/show.php?content=137091"
+SRC_URI="http://qt-apps.org/CONTENT/content-files/137091-${P}.txz -> ${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libmpdclient
+ >=dev-qt/qtcore-4.6:4
+ >=dev-qt/qtgui-4.6:4"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ local INSTALLED_LANGS= LANG=
+
+ # Install on live fs should be done by portage itself
+ sed -ie 's/postinstall/#postinstall/g' be.mpc.pro
+
+ # Install only chosen locales
+ for LANG in ${LINGUAS}; do
+ if has ${LANG} ${LANGS}; then
+ INSTALLED_LANGS="${INSTALLED_LANGS} be.mpc_${LANG}.qm"
+ fi
+ done
+ sed -ie "s/i18n.files += be.mpc_cs.qm be.mpc_de.qm/i18n.files += ${INSTALLED_LANGS}/" be.mpc.pro
+
+ # Fix invalid desktop file
+ sed -ie 's/Categories=Application;Qt;Audio;/Categories=Qt;AudioVideo;Audio;/' be.mpc.desktop
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/media-sound/bempc/metadata.xml b/media-sound/bempc/metadata.xml
new file mode 100644
index 000000000000..860c306fcfde
--- /dev/null
+++ b/media-sound/bempc/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <herd>qt</herd>
+</pkgmetadata>