summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/waybar/Manifest1
-rw-r--r--gui-apps/waybar/metadata.xml26
-rw-r--r--gui-apps/waybar/waybar-0.7.2.ebuild62
-rw-r--r--gui-apps/waybar/waybar-9999.ebuild62
4 files changed, 151 insertions, 0 deletions
diff --git a/gui-apps/waybar/Manifest b/gui-apps/waybar/Manifest
new file mode 100644
index 000000000000..1af185fb428b
--- /dev/null
+++ b/gui-apps/waybar/Manifest
@@ -0,0 +1 @@
+DIST waybar-0.7.2.tar.gz 101206 BLAKE2B d44b46c840094340e1e5f70d4ef3d01faf483a8c744ce6b549c1fa8767bf455c4c0ef67b564c61795e44c652d37c09848cce6f50ee3664de73477da6b4bce84e SHA512 d83f92d0111cdd01b276907fad18344dbf35be1e0bbbce2208f928e0d5e0fcccfa65ff2279de5a7e4dad5f04a6c99521670d75d65e32a0382bec2bf32eea00e2
diff --git a/gui-apps/waybar/metadata.xml b/gui-apps/waybar/metadata.xml
new file mode 100644
index 000000000000..3b8f2d78b9bc
--- /dev/null
+++ b/gui-apps/waybar/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bernardo@standard.ai</email>
+ <name>Bernardo Meurer</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Gentoo Proxy Maintainers Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Highly customizable Wayland bar for Sway and Wlroots based compositors.
+ </longdescription>
+ <use>
+ <flag name="libcxx">Build with Clang's libc++ instead of libstdc++ on Linux.</flag>
+ <flag name="mpd">Enable support for the Music Player Daemon</flag>
+ <flag name="network">Enable libnl support for network related features</flag>
+ <flag name="tray">Enable support for tray</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">Alexays/Waybar</remote-id>
+ <bugs-to>https://github.com/Alexays/Waybar/issues</bugs-to>
+ <changelog>https://github.com/Alexays/Waybar/releases</changelog>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-apps/waybar/waybar-0.7.2.ebuild b/gui-apps/waybar/waybar-0.7.2.ebuild
new file mode 100644
index 000000000000..bfcfa38df7f0
--- /dev/null
+++ b/gui-apps/waybar/waybar-0.7.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Highly customizable Wayland bar for Sway and Wlroots based compositors."
+HOMEPAGE="https://github.com/Alexays/Waybar"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Alexays/${PN^}.git"
+else
+ SRC_URI="https://github.com/Alexays/${PN^}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="libcxx mpd network pulseaudio tray +udev"
+
+DEPEND="
+ dev-cpp/gtkmm:3.0
+ dev-libs/jsoncpp:=
+ dev-libs/libinput:=
+ dev-libs/libsigc++:2
+ >=dev-libs/libfmt-5.3.0:=
+ >=dev-libs/spdlog-1.3.1:=
+ dev-libs/wayland
+ dev-libs/wayland-protocols
+ gui-libs/wlroots
+
+ libcxx? ( sys-libs/libcxx )
+ mpd? ( media-libs/libmpdclient )
+ network? ( dev-libs/libnl:3 )
+ pulseaudio? ( media-sound/pulseaudio )
+ tray? ( dev-libs/libdbusmenu[gtk3] )
+ udev? ( virtual/libudev:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+if [[ ${PV} != 9999 ]]; then
+ S="${WORKDIR}/${PN^}-${PV}"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use libcxx)
+ $(meson_feature mpd)
+ $(meson_feature network libnl)
+ $(meson_feature pulseaudio)
+ $(meson_feature tray dbusmenu-gtk)
+ $(meson_feature udev libudev)
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/waybar/waybar-9999.ebuild b/gui-apps/waybar/waybar-9999.ebuild
new file mode 100644
index 000000000000..bfcfa38df7f0
--- /dev/null
+++ b/gui-apps/waybar/waybar-9999.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Highly customizable Wayland bar for Sway and Wlroots based compositors."
+HOMEPAGE="https://github.com/Alexays/Waybar"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Alexays/${PN^}.git"
+else
+ SRC_URI="https://github.com/Alexays/${PN^}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="libcxx mpd network pulseaudio tray +udev"
+
+DEPEND="
+ dev-cpp/gtkmm:3.0
+ dev-libs/jsoncpp:=
+ dev-libs/libinput:=
+ dev-libs/libsigc++:2
+ >=dev-libs/libfmt-5.3.0:=
+ >=dev-libs/spdlog-1.3.1:=
+ dev-libs/wayland
+ dev-libs/wayland-protocols
+ gui-libs/wlroots
+
+ libcxx? ( sys-libs/libcxx )
+ mpd? ( media-libs/libmpdclient )
+ network? ( dev-libs/libnl:3 )
+ pulseaudio? ( media-sound/pulseaudio )
+ tray? ( dev-libs/libdbusmenu[gtk3] )
+ udev? ( virtual/libudev:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+if [[ ${PV} != 9999 ]]; then
+ S="${WORKDIR}/${PN^}-${PV}"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use libcxx)
+ $(meson_feature mpd)
+ $(meson_feature network libnl)
+ $(meson_feature pulseaudio)
+ $(meson_feature tray dbusmenu-gtk)
+ $(meson_feature udev libudev)
+ )
+ meson_src_configure
+}