summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/doom-data')
-rw-r--r--games-fps/doom-data/Manifest1
-rw-r--r--games-fps/doom-data/doom-data-1-r1.ebuild43
-rw-r--r--games-fps/doom-data/metadata.xml8
3 files changed, 52 insertions, 0 deletions
diff --git a/games-fps/doom-data/Manifest b/games-fps/doom-data/Manifest
new file mode 100644
index 000000000000..c4b5680d5d21
--- /dev/null
+++ b/games-fps/doom-data/Manifest
@@ -0,0 +1 @@
+DIST doom1.wad.bz2 1689021 SHA256 77009084330d2d14540ffd78b05deef4cb5cb4058cb50cf17316fede43d4dcae SHA512 f3aa78fd1e36d2dbd176c8c5284f8cee4f39d8e34df5386fd668565e752410e2b776413c78c1e7a3571695a1668f1e4820338ebc9a2b1a0ed1a81896260534fe WHIRLPOOL 801adc114c3d2c0029e80608641e7d4e2330334305b38fc05ba1bc4caf2db188635c862d2a743b54ce8b908b541e012743242d7b91d45d4ef2a6b514c5e338a5
diff --git a/games-fps/doom-data/doom-data-1-r1.ebuild b/games-fps/doom-data/doom-data-1-r1.ebuild
new file mode 100644
index 000000000000..3cca2360fdf9
--- /dev/null
+++ b/games-fps/doom-data/doom-data-1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="collection of doom wad files from id"
+HOMEPAGE="http://www.idsoftware.com/"
+SRC_URI="mirror://gentoo/doom1.wad.bz2"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="amd64 arm sparc x86"
+IUSE="doomsday"
+
+DEPEND="doomsday? ( games-fps/doomsday )
+ !<=games-fps/freedoom-0.4.1"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}
+
+src_install() {
+ insinto "${GAMES_DATADIR}"/doom-data
+ doins *.wad
+ if use doomsday; then
+ # Make wrapper for doomsday
+ games_make_wrapper doomsday-demo "jdoom -file \
+ ${GAMES_DATADIR}/doom-data/doom1.wad"
+ make_desktop_entry doomsday-demo "Doomsday - Demo"
+ fi
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if use doomsday; then
+ elog "To use the doomsday engine, run doomsday-demo"
+ else
+ elog "A Doom engine is required to play the wad"
+ elog "Enable the doomsday use flag if you want to use"
+ elog " the doomsday engine"
+ fi
+}
diff --git a/games-fps/doom-data/metadata.xml b/games-fps/doom-data/metadata.xml
new file mode 100644
index 000000000000..c6592feff3b3
--- /dev/null
+++ b/games-fps/doom-data/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name="doomsday">Add wrapper to run it within doomsday</flag>
+ </use>
+</pkgmetadata>