summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/umockdev/umockdev-0.9.4.ebuild')
-rw-r--r--dev-util/umockdev/umockdev-0.9.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/umockdev/umockdev-0.9.4.ebuild b/dev-util/umockdev/umockdev-0.9.4.ebuild
new file mode 100644
index 000000000000..56a4b358cf1e
--- /dev/null
+++ b/dev-util/umockdev/umockdev-0.9.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit python-any-r1
+
+DESCRIPTION="Mock hardware devices for creating unit tests"
+HOMEPAGE="https://github.com/martinpitt/umockdev/"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs test"
+
+RDEPEND="virtual/libgudev:=
+ virtual/libudev:=
+ >=dev-libs/glib-2.32:2"
+DEPEND="${RDEPEND}
+ test? ( ${PYTHON_DEPS} )
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-sysmacros.patch #579988
+)
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}