summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pymountboot')
-rw-r--r--dev-python/pymountboot/pymountboot-9999.ebuild16
1 files changed, 3 insertions, 13 deletions
diff --git a/dev-python/pymountboot/pymountboot-9999.ebuild b/dev-python/pymountboot/pymountboot-9999.ebuild
index d2f6dde8a987..9fef9b4021f3 100644
--- a/dev-python/pymountboot/pymountboot-9999.ebuild
+++ b/dev-python/pymountboot/pymountboot-9999.ebuild
@@ -4,30 +4,20 @@
EAPI=5
PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy )
-inherit distutils-r1
-
-#if LIVE
-EGIT_REPO_URI="https://bitbucket.org/mgorny/${PN}.git"
-inherit git-r3
-#endif
+inherit distutils-r1 git-r3
DESCRIPTION="Python extension module to (re)mount /boot"
HOMEPAGE="https://bitbucket.org/mgorny/pymountboot/"
-SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+EGIT_REPO_URI="https://bitbucket.org/mgorny/${PN}.git"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS=""
IUSE=""
RDEPEND=">=sys-apps/util-linux-2.20"
DEPEND="${RDEPEND}"
-#if LIVE
-KEYWORDS=
-SRC_URI=
-#endif
-
python_compile() {
python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
distutils-r1_python_compile