summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hyper-h2/hyper-h2-3.0.1.ebuild')
-rw-r--r--dev-python/hyper-h2/hyper-h2-3.0.1.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/hyper-h2/hyper-h2-3.0.1.ebuild b/dev-python/hyper-h2/hyper-h2-3.0.1.ebuild
deleted file mode 100644
index 455744ef8e0a..000000000000
--- a/dev-python/hyper-h2/hyper-h2-3.0.1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{6,7})
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP/2 State-Machine based protocol implementation"
-HOMEPAGE="https://python-hyper.org/h2/en/stable/ https://pypi.org/project/h2/"
-SRC_URI="https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/hyperframe-5.0.0[${PYTHON_USEDEP}]
- <dev-python/hyperframe-6.0.0[${PYTHON_USEDEP}]
- >=dev-python/hpack-2.3.0[${PYTHON_USEDEP}]
- <dev-python/hpack-4.0.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/enum34-1.1.6[${PYTHON_USEDEP}]' python2_7)
- $(python_gen_cond_dep '<dev-python/enum34-2.0.0[${PYTHON_USEDEP}]' python2_7)
-"
-DEPEND="${RDEPEND}
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- pytest -vv test || die "Tests fail with ${EPYTHON}"
-}