summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/epsilon')
-rw-r--r--dev-python/epsilon/epsilon-0.7.1.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/dev-python/epsilon/epsilon-0.7.1.ebuild b/dev-python/epsilon/epsilon-0.7.1.ebuild
index 8cf2f709a88b..f0fb386ce8b8 100644
--- a/dev-python/epsilon/epsilon-0.7.1.ebuild
+++ b/dev-python/epsilon/epsilon-0.7.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
PYTHON_COMPAT=( python2_7 )
-inherit twisted-r1 eutils
+inherit twisted-r1
DESCRIPTION="Epsilon is a Python utilities package, most famous for its Time class"
HOMEPAGE="http://divmod.org/trac/wiki/DivmodEpsilon https://pypi.python.org/pypi/Epsilon"
@@ -13,11 +13,15 @@ SRC_URI="mirror://pypi/${TWISTED_PN:0:1}/${TWISTED_PN}/${TWISTED_P}.tar.gz"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="test"
-RDEPEND=">=dev-python/twisted-core-13.2.0[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]"
+RDEPEND="
+ || (
+ dev-python/twisted[${PYTHON_USEDEP}]
+ >=dev-python/twisted-core-13.2.0[${PYTHON_USEDEP}]
+ )
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- ${DEPEND}"
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ ${DEPEND}"
PATCHES=( "${FILESDIR}/epsilon_plugincache_portagesandbox.patch" )